CVE-2016-3732
Moodle sensitive information disclosure
The capability check to access other badges in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13, and earlier allows remote authenticated users to read the badges of other users.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
4.3
The capability check to access other badges in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13, and earlier allows remote authenticated users to read the badges of other users.
- Record
CVE-2016-3732- CVSS 3.0
- 4.3 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:P/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
CVE List No score
The capability check to access other badges in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13, and earlier allows remote authenticated users to read the badges of other users.
- Record
CVE-2016-3732- Updated
- 2026-11-02
EUVDEUVD-2022-2475 No score
The capability check to access other badges in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13, and earlier allows remote authenticated users to read the badges of other users.
- Record
EUVD-2022-2475- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5282-96ff-xx3h
4.3
Moodle sensitive information disclosure
The capability check to access other badges in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13, and earlier allows remote authenticated users to read the badges of other users.
- Record
GHSA-5282-96ff-xx3h- CVSS 3.0
- 4.3 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
OSV
4.3
The capability check to access other badges in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13, and earlier allows remote authenticated users to read the badges of other users.
- Record
CVE-2016-3732- CVSS 3.0
- 4.3 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
OSVGHSA-5282-96ff-xx3h
4.3
Moodle sensitive information disclosure
The capability check to access other badges in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13, and earlier allows remote authenticated users to read the badges of other users.
- Record
GHSA-5282-96ff-xx3h- CVSS 3.0
- 4.3 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-3732
4.3
The capability check to access other badges in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13, and earlier allows remote authenticated users to read the badges of other users.
- Record
UBUNTU-CVE-2016-3732- CVSS 3.0
- 4.3 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
3.0.0 to 3.0.3 | 3.0.4 |
moodle/moodlePackagist |
2.9.0 to 2.9.5 | 2.9.6 |
moodle/moodlePackagist |
2.8.0 to 2.8.11 | 2.8.12 |
moodle/moodlePackagist |
2.7.0 to 2.7.13 | 2.7.14 |
moodle/moodlePackagist |
3.0.0 up to 3.0.4, plus listed versions v3.0.0v3.0.1v3.0.2v3.0.3 |
3.0.4 |
moodle/moodlePackagist |
2.9.0 up to 2.9.6, plus listed versions v2.9.0v2.9.1v2.9.2v2.9.3v2.9.4v2.9.5 |
2.9.6 |
moodle/moodlePackagist |
2.8.0 up to 2.8.12, plus listed versions v2.8.0v2.8.1v2.8.10v2.8.11v2.8.2 Show 7 moreShow lessv2.8.3v2.8.4v2.8.5v2.8.6v2.8.7v2.8.8v2.8.9 |
2.8.12 |
moodle/moodlePackagist |
2.7.0 up to 2.7.14, plus listed versions v2.7.0v2.7.1v2.7.10v2.7.11v2.7.12 Show 9 moreShow lessv2.7.13v2.7.2v2.7.3v2.7.4v2.7.5v2.7.6v2.7.7v2.7.8v2.7.9 |
2.7.14 |
moodleUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
moodleUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-3732 is a medium vulnerability (CVSS 4.3) in Moodle, published April 20, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.55%, the 75th percentile. Fixed in moodle/moodle 3.0.4.
References
openwall.com/lists/oss-security/2016/05/17/4
bugzilla.redhat.com/show_bug.cgi?id=1335933
securitytracker.com/id/1035902
nvd.nist.gov/vuln/detail/CVE-2016-3732
web.archive.org/web/20210413170947/http://www.securitytracker.com/id/1035902
github.com/advisories/GHSA-5282-96ff-xx3h
github.com/moodle/moodle
ubuntu.com/security/CVE-2016-3732
cve.org/CVERecord?id=CVE-2016-3732