Every CVE Search/ Get API key

CVE-2016-3734

Moodle Cross-site request forgery (CSRF) vulnerability

8.8 HighFix available

Cross-site request forgery (CSRF) vulnerability in markposts.php in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13 and earlier allows remote attackers to hijack the authentication of users for requests that marks forum posts as read.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.13%Down 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 8.8

Cross-site request forgery (CSRF) vulnerability in markposts.php in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13 and earlier allows remote attackers to hijack the authentication of users for requests that marks forum posts as read.

Record
CVE-2016-3734
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-352
Updated
2026-11-02
CVE List No score

Cross-site request forgery (CSRF) vulnerability in markposts.php in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13 and earlier allows remote attackers to hijack the authentication of users for requests that marks forum posts as read.

Record
CVE-2016-3734
Updated
2026-11-02
EUVDEUVD-2022-5130 No score

Cross-site request forgery (CSRF) vulnerability in markposts.php in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13 and earlier allows remote attackers to hijack the authentication of users for requests that marks forum posts as read.

Record
EUVD-2022-5130
Updated
2026-11-03
GitHub AdvisoriesGHSA-r867-v437-4rrm 8.8

Moodle Cross-site request forgery (CSRF) vulnerability

Cross-site request forgery (CSRF) vulnerability in markposts.php in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13 and earlier allows remote attackers to hijack the authentication of users for requests that marks forum posts as read.

Record
GHSA-r867-v437-4rrm
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-352
Updated
2026-11-02
OSV 8.8

Cross-site request forgery (CSRF) vulnerability in markposts.php in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13 and earlier allows remote attackers to hijack the authentication of users for requests that marks forum posts as read.

Record
CVE-2016-3734
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-r867-v437-4rrm 8.8

Moodle Cross-site request forgery (CSRF) vulnerability

Cross-site request forgery (CSRF) vulnerability in markposts.php in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13 and earlier allows remote attackers to hijack the authentication of users for requests that marks forum posts as read.

Record
GHSA-r867-v437-4rrm
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-352
Updated
2026-11-02
OSVUBUNTU-CVE-2016-3734 8.8

Cross-site request forgery (CSRF) vulnerability in markposts.php in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13 and earlier allows remote attackers to hijack the authentication of users for requests that marks forum posts as read.

Record
UBUNTU-CVE-2016-3734
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
before 2.7.14
2.7.14
moodle/moodle
Packagist
2.8 up to 2.8.12
2.8.12
moodle/moodle
Packagist
2.9 up to 2.9.6
2.9.6
moodle/moodle
Packagist
3.0 up to 3.0.4
3.0.4
moodle/moodle
Packagist
before 2.7.14, plus listed versions
v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6
Show 45 moreShow less
v2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-betav2.6.0-rc1v2.6.1v2.6.10v2.6.11v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.6.7v2.6.8v2.6.9v2.7.0v2.7.0-betav2.7.0-rc1
2.7.14
moodle/moodle
Packagist
2.8 up to 2.8.12, plus listed versions
v2.8.0v2.8.0-betav2.8.0-rc1v2.8.0-rc2v2.8.1
Show 10 moreShow less
v2.8.10v2.8.11v2.8.2v2.8.3v2.8.4v2.8.5v2.8.6v2.8.7v2.8.8v2.8.9
2.8.12
moodle/moodle
Packagist
2.9 up to 2.9.6, plus listed versions
v2.9.0v2.9.0-betav2.9.0-rc1v2.9.0-rc2v2.9.1
Show 4 moreShow less
v2.9.2v2.9.3v2.9.4v2.9.5
2.9.6
moodle/moodle
Packagist
3.0 up to 3.0.4, plus listed versions
v3.0.0v3.0.0-betav3.0.0-rc1v3.0.0-rc2v3.0.0-rc3
Show 4 moreShow less
v3.0.0-rc4v3.0.1v3.0.2v3.0.3
3.0.4

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-3734 is a high vulnerability (CVSS 8.8) in Moodle, published April 20, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.13%, the 66th percentile. Fixed in moodle/moodle 2.7.14.

References

Show 11 moreShow less
This page doesn't list everything

Left out here: 14 versions. The JSON record has them.

MoveEnter Open