CVE-2016-4007
Multiple unspecified vulnerabilities in the obs-service-extract_file package before 0.3-5.1 in...
Multiple unspecified vulnerabilities in the obs-service-extract_file package before 0.3-5.1 in openSUSE Leap 42.1 and before 0.3-3.1 in openSUSE 13.2 allow attackers to execute arbitrary commands via a service definition, related to executing unzip with "illegal options."
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Multiple unspecified vulnerabilities in the obs-service-extract_file package before 0.3-5.1 in openSUSE Leap 42.1 and before 0.3-3.1 in openSUSE 13.2 allow attackers to execute arbitrary commands via a service definition, related to executing unzip with "illegal options."
- Record
CVE-2016-4007- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 10.0 High
AV:N/AC:L/Au:N/C:C/I:C/A:C - Updated
- 2026-11-02
CVE List No score
Multiple unspecified vulnerabilities in the obs-service-extract_file package before 0.3-5.1 in openSUSE Leap 42.1 and before 0.3-3.1 in openSUSE 13.2 allow attackers to execute arbitrary commands via a service definition, related to executing unzip with "illegal options."
- Record
CVE-2016-4007- Updated
- 2026-11-02
EUVDEUVD-2016-5014 No score
Multiple unspecified vulnerabilities in the obs-service-extract_file package before 0.3-5.1 in openSUSE Leap 42.1 and before 0.3-3.1 in openSUSE 13.2 allow attackers to execute arbitrary commands via a service definition, related to executing unzip with "illegal options."
- Record
EUVD-2016-5014- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-9rh7-7vch-gx4m
9.8
Multiple unspecified vulnerabilities in the obs-service-extract_file package before 0.3-5.1 in...
Multiple unspecified vulnerabilities in the obs-service-extract_file package before 0.3-5.1 in openSUSE Leap 42.1 and before 0.3-3.1 in openSUSE 13.2 allow attackers to execute arbitrary commands via a service definition, related to executing unzip with "illegal options."
- Record
GHSA-9rh7-7vch-gx4m- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVSUSE-SU-2016:1839-1 No score
Security update for obs-service-source_validator
This update for obs-service-source_validator to version 0.6+git20160531.fbfe336 fixes one security issue.
This security issue was fixed:
- CVE-2016-4007: harden source services against code/parameter injection (bsc#967265)
This non-security issue was fixed:
- bsc#967610: Several occurrences of uninitialized value
- Record
SUSE-SU-2016:1839-1- Updated
- 2026-11-02
OSVSUSE-SU-2018:0065-1 No score
Fixing security issues on OBS toolchain
This OBS toolchain update fixes the following issues:
Package 'build':
- CVE-2017-14804: Improve file name check extractbuild (bsc#1069904)
- Fixed Dockerfile repository parsing
Package 'obs-service-source_validator':
- CVE-2017-9274: Don't use rpmbuild to extract sources, patches etc. from a spec (bnc#938556).
- CVE-2016-4007: Several maintained source services are vulnerable to code/paramter injection (bsc#967265)
- Update to version 0.7.
- Use spec_query instead of output_versions using the specfile parser from the build package (boo#1059858)
- obs-service-source_validator: several occurrences of uninitialized value (bsc#967610)
- hack for util-linux specfiles (bnc#891829)
- fix dependency to gnupg2 for Fedora (bnc#827480)
- exit if tmpdir creation fails (bnc#796918)
Package 'osc':
- Update to version 0.162.0.
- Record
SUSE-SU-2018:0065-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
obs-service-source_validatorSUSE:Linux Enterprise Software Development Kit 12 SP1 |
before 0.6+git20160531.fbfe336-5.3 | 0.6+git20160531.fbfe336-5.3 |
buildSUSE:Linux Enterprise Software Development Kit 11 SP4 From an advisory covering 3 CVEs |
before 20171128-8.3.3 | 20171128-8.3.3 |
oscSUSE:Linux Enterprise Software Development Kit 11 SP4 From an advisory covering 3 CVEs |
before 0.162.1-7.4.1 | 0.162.1-7.4.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-4007 is a critical vulnerability (CVSS 9.8) in Opensuse Leap, published April 13, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.47%, the 84th percentile. Fixed in obs-service-source_validator 0.6+git20160531.fbfe336-5.3.
References
lists.opensuse.org/opensuse-security-announce/2016-02/msg00046.html
lists.opensuse.org/opensuse-security-announce/2016-07/msg00019.html
build.opensuse.org/request/show/361096
lists.opensuse.org/opensuse-security-announce/2016-06/msg00050.html
lists.opensuse.org/opensuse-security-announce/2016-06/msg00049.html
nvd.nist.gov/vuln/detail/CVE-2016-4007
Show 14 moreShow less
github.com/advisories/GHSA-9rh7-7vch-gx4m
suse.com/support/update/announcement/2016/suse-su-20161839-1
bugzilla.suse.com/967265
bugzilla.suse.com/967610
suse.com/security/cve/CVE-2016-4007
suse.com/support/update/announcement/2018/suse-su-20180065-1
bugzilla.suse.com/1059858
bugzilla.suse.com/1069904
bugzilla.suse.com/796918
bugzilla.suse.com/827480
bugzilla.suse.com/891829
bugzilla.suse.com/938556
suse.com/security/cve/CVE-2017-14804
suse.com/security/cve/CVE-2017-9274