CVE-2016-4303
The parse_string function in cjson.c in the cJSON library mishandles UTF8/16 strings, which...
CVE-2016-4303 is a critical vulnerability (CVSS 9.8) in Debian Linux, published July 5, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.96%, the 94th percentile. Fixed in iperf3 3.1.3-1.
The parse_string function in cjson.c in the cJSON library mishandles UTF8/16 strings, which allows remote attackers to cause a denial of service (crash) or execute arbitrary code via a non-hex character in a JSON string, which triggers a heap-based buffer overflow.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
The parse_string function in cjson.c in the cJSON library mishandles UTF8/16 strings, which allows remote attackers to cause a denial of service (crash) or execute arbitrary code via a non-hex character in a JSON string, which triggers a heap-based buffer overflow.
- Record
CVE-2016-4303- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-120
- Updated
- 2026-11-02
CVE List No score
The parse_string function in cjson.c in the cJSON library mishandles UTF8/16 strings, which allows remote attackers to cause a denial of service (crash) or execute arbitrary code via a non-hex character in a JSON string, which triggers a heap-based buffer overflow.
- Record
CVE-2016-4303- Updated
- 2026-11-02
EUVDEUVD-2016-5303 No score
The parse_string function in cjson.c in the cJSON library mishandles UTF8/16 strings, which allows remote attackers to cause a denial of service (crash) or execute arbitrary code via a non-hex character in a JSON string, which triggers a heap-based buffer overflow.
- Record
EUVD-2016-5303- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-86rq-gv28-jjr6
9.8
The parse_string function in cjson.c in the cJSON library mishandles UTF8/16 strings, which...
The parse_string function in cjson.c in the cJSON library mishandles UTF8/16 strings, which allows remote attackers to cause a denial of service (crash) or execute arbitrary code via a non-hex character in a JSON string, which triggers a heap-based buffer overflow.
- Record
GHSA-86rq-gv28-jjr6- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-119, CWE-120
- Updated
- 2026-11-02
OSV
9.8
The parse_string function in cjson.c in the cJSON library mishandles UTF8/16 strings, which allows remote attackers to cause a denial of service (crash) or execute arbitrary code via a non-hex character in a JSON string, which triggers a heap-based buffer overflow.
- Record
CVE-2016-4303- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-4303
9.8
The parse_string function in cjson.c in the cJSON library mishandles UTF8/16 strings, which allows remote attackers to cause a denial of service (crash) or execute arbitrary code via a non-hex character in a JSON string, which triggers a heap-based buffer overflow.
- Record
DEBIAN-CVE-2016-4303- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 6 moreShow less
OSVUBUNTU-CVE-2016-4303
9.8
The parse_string function in cjson.c in the cJSON library mishandles UTF8/16 strings, which allows remote attackers to cause a denial of service (crash) or execute arbitrary code via a non-hex character in a JSON string, which triggers a heap-based buffer overflow.
- Record
UBUNTU-CVE-2016-4303- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2016-0235 No score
Updated iperf packages fix security vulnerability
A malicious process can connect to an iperf server and, by sending a malformed message on the control channel, corrupt the server process's heap area. This can lead to a crash (and a denial of service), or theoretically a remote code execution as the user running the iperf server. A malicious iperf server could potentially mount a similar attack on an iperf client (CVE-2016-4303).
- Record
MGASA-2016-0235- Updated
- 2026-11-02
OSVopenSUSE-SU-2016:2113-1 No score
Security update for iperf
iperf was updated to the the following vulnerability:
- CVE-2016-4303: A malicious client could have triggered a buffer overflow / heap corruption issue by sending a specially crafted JSON string, and possibly execute arbitrary code (boo#984453)
- Record
openSUSE-SU-2016:2113-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2016:2121-1 No score
Security update for iperf
iperf was updated to the the following vulnerability:
- CVE-2016-4303: A malicious client could have triggered a buffer overflow / heap corruption issue by sending a specially crafted JSON string, and possibly execute arbitrary code (boo#984453)
- Record
openSUSE-SU-2016:2121-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10145-1 No score
iperf-3.1.3-1.3 on GA media
These are all security issues fixed in the iperf-3.1.3-1.3 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10145-1- Updated
- 2026-11-02
OSVUSN-4788-1 No score
iperf3 vulnerability
It was discovered that iperf mishandled certain UTF-8 and UTF-16 strings. A remote attacker could use this vulnerability to cause a denial of service or possibly execute arbitrary code.
- Record
USN-4788-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
iperf3Debian:12 |
before 3.1.3-1 | 3.1.3-1 |
iperf3Debian:13 |
before 3.1.3-1 | 3.1.3-1 |
iperf3Debian:14 |
before 3.1.3-1 | 3.1.3-1 |
iperf3Debian:8 |
before 3.0.7-1+deb8u1, plus listed versions 3.0.7-1 |
3.0.7-1+deb8u1 |
iperfMageia:5 |
before 3.0.12-1.mga5 | 3.0.12-1.mga5 |
iperf3Ubuntu:Pro:16.04:LTS |
before 3.0.11-1ubuntu0.1~esm1, plus listed versions 3.0.11-1 |
3.0.11-1ubuntu0.1~esm1 |
iperfSUSE:Package Hub 12 |
before 3.1.3-6.1 | 3.1.3-6.1 |
iperfopenSUSE:Tumbleweed |
before 3.1.3-1.3 | 3.1.3-1.3 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
talosintelligence.com/reports/TALOS-2016-0164
blog.talosintel.com/2016/06/esnet-vulnerability.html
software.es.net/iperf/news.html
raw.githubusercontent.com/esnet/security/master/cve-2016-4303/esnet-secadv-2016-0001.txt.asc
github.com/esnet/iperf/commit/91f2fa59e8ed80dfbf400add0164ee0e508e412a
lists.opensuse.org/opensuse-updates/2016-08/msg00082.html
Show 13 moreShow less
lists.opensuse.org/opensuse-updates/2016-08/msg00090.html
lists.debian.org/debian-lts-announce/2020/01/msg00023.html
nvd.nist.gov/vuln/detail/CVE-2016-4303
github.com/advisories/GHSA-86rq-gv28-jjr6
security-tracker.debian.org/tracker/CVE-2016-4303
advisories.mageia.org/MGASA-2016-0235.html
bugs.mageia.org/show_bug.cgi?id=18743
lists.fedoraproject.org/archives/list/[email protected]/thread/4DE6NEEUEC3XI62GE2MB2EK5BUCZ6MCP
ubuntu.com/security/CVE-2016-4303
cve.org/CVERecord?id=CVE-2016-4303
ubuntu.com/security/notices/USN-4788-1
bugzilla.suse.com/984453
suse.com/security/cve/CVE-2016-4303