Every CVE Search/ Get API key

CVE-2016-4330

In the HDF5 1.8.16 library's failure to check if the number of dimensions for an array read from...

8.6 HighFix available

In the HDF5 1.8.16 library's failure to check if the number of dimensions for an array read from the file is within the bounds of the space allocated for it, a heap-based buffer overflow will occur, potentially leading to arbitrary code execution.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.80%Down 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 8.6

In the HDF5 1.8.16 library's failure to check if the number of dimensions for an array read from the file is within the bounds of the space allocated for it, a heap-based buffer overflow will occur, potentially leading to arbitrary code execution.

Record
CVE-2016-4330
CVSS 3.0
8.6 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
CVSS 2.0
6.9 MediumAV:L/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

In the HDF5 1.8.16 library's failure to check if the number of dimensions for an array read from the file is within the bounds of the space allocated for it, a heap-based buffer overflow will occur, potentially leading to arbitrary code execution.

Record
CVE-2016-4330
Updated
2026-11-02
EUVDEUVD-2016-5330 No score

In the HDF5 1.8.16 library's failure to check if the number of dimensions for an array read from the file is within the bounds of the space allocated for it, a heap-based buffer overflow will occur, potentially leading to arbitrary code execution.

Record
EUVD-2016-5330
Updated
2026-11-03
GitHub AdvisoriesGHSA-gffv-475w-fvh4 8.6

In the HDF5 1.8.16 library's failure to check if the number of dimensions for an array read from...

In the HDF5 1.8.16 library's failure to check if the number of dimensions for an array read from the file is within the bounds of the space allocated for it, a heap-based buffer overflow will occur, potentially leading to arbitrary code execution.

Record
GHSA-gffv-475w-fvh4
CVSS 3.0
8.6 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Weakness
CWE-119
Updated
2026-11-02
OSV 8.6

In the HDF5 1.8.16 library's failure to check if the number of dimensions for an array read from the file is within the bounds of the space allocated for it, a heap-based buffer overflow will occur, potentially leading to arbitrary code execution.

Record
CVE-2016-4330
CVSS 3.0
8.6 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-4330 8.6

In the HDF5 1.8.16 library's failure to check if the number of dimensions for an array read from the file is within the bounds of the space allocated for it, a heap-based buffer overflow will occur, potentially leading to arbitrary code execution.

Record
DEBIAN-CVE-2016-4330
CVSS 3.0
8.6 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2016-4330 8.6

In the HDF5 1.8.16 library's failure to check if the number of dimensions for an array read from the file is within the bounds of the space allocated for it, a heap-based buffer overflow will occur, potentially leading to arbitrary code execution.

Record
UBUNTU-CVE-2016-4330
CVSS 3.0
8.6 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2016-0425 No score

Updated hdf5 packages fix security vulnerabilities

In the HDF5 1.8.16 library's failure to check if the number of dimensions for an array read from the file is within the bounds of the space allocated for it, a heap-based buffer overflow will occur, potentially leading to arbitrary code execution (CVE-2016-4330).

When decoding data out of a dataset encoded with the H5Z_NBIT decoding, the HDF5 1.8.16 library will fail to ensure that the precision is within the bounds of the size leading to arbitrary code execution (CVE-2016-4331).

The library's failure to check if certain message types support a particular flag, the HDF5 1.8.16 library will cast the structure to an alternative structure and then assign to fields that aren't supported by the message type and the library will write outside the bounds of the heap buffer. This can lead to code execution under the context of the library (CVE-2016-4332).

The HDF5 1.8.16 library allocating space for the array using a value from the file has an impact within the loop for initializing said array allowing a value within the file to modify the loop's terminator. Due to this, an aggressor can cause the loop's index to point outside the bounds of the array when initializing it (CVE-2016-4333).

Record
MGASA-2016-0425
Updated
2026-11-02
OSVopenSUSE-SU-2018:1051-1 No score

Security update for hdf5

This update for hdf5 fixes the following issues:

  • fix security issues (arbitary code execution): CVE-2016-4330: H5T_ARRAY Code Execution (boo#1011201) CVE-2016-4331: H5Z_NBIT Code Execution (boo#1011204) CVE-2016-4332: Shareable Message Type Code Execution (boo#1011205) CVE-2016-4333: Array index bounds issue (boo#1011198)
Record
openSUSE-SU-2018:1051-1
Updated
2026-11-02
OSVopenSUSE-SU-2018:1056-1 No score

Security update for hdf5

This update for hdf5 fixes the following issues:

  • fix security issues (arbitary code execution): CVE-2016-4330: H5T_ARRAY Code Execution (boo#1011201) CVE-2016-4331: H5Z_NBIT Code Execution (boo#1011204) CVE-2016-4332: Shareable Message Type Code Execution (boo#1011205) CVE-2016-4333: Array index bounds issue (boo#1011198)
Record
openSUSE-SU-2018:1056-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
hdf5
Debian:12
before 1.10.0-patch1+docs-1
1.10.0-patch1+docs-1
hdf5
Debian:13
before 1.10.0-patch1+docs-1
1.10.0-patch1+docs-1
hdf5
Debian:14
before 1.10.0-patch1+docs-1
1.10.0-patch1+docs-1
hdf5
Debian:7
From an advisory covering 4 CVEs
before 1.8.8-9+deb7u1, plus listed versions
1.8.8-9
1.8.8-9+deb7u1
hdf5
Debian:8
From an advisory covering 4 CVEs
before 1.8.13+docs-15+deb8u1, plus listed versions
1.8.13+docs-15
1.8.13+docs-15+deb8u1
hdf5
Mageia:5
From an advisory covering 4 CVEs
before 1.8.13-4.1.mga5
1.8.13-4.1.mga5
hdf5
Ubuntu:14.04:LTS
before 1.8.11-5ubuntu7.1, plus listed versions
1.8.11-3ubuntu11.8.11-5ubuntu11.8.11-5ubuntu21.8.11-5ubuntu61.8.11-5ubuntu7
1.8.11-5ubuntu7.1
hdf5
Ubuntu:16.04:LTS
before 1.8.16+docs-4ubuntu1.1, plus listed versions
1.8.15-patch1+docs-41.8.15-patch1+docs-51.8.16+docs-11.8.16+docs-21.8.16+docs-31.8.16+docs-3ubuntu11.8.16+docs-41.8.16+docs-4ubuntu1
1.8.16+docs-4ubuntu1.1
hdf5
SUSE:Package Hub 12
From an advisory covering 4 CVEs
before 1.8.17-5.1
1.8.17-5.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-4330 is a high vulnerability (CVSS 8.6) in Hdfgroup Hdf5, published November 18, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.80%, the 56th percentile. Fixed in hdf5 1.10.0-patch1+docs-1.

References

Show 15 moreShow less
MoveEnter Open