Every CVE Search/ Get API key

CVE-2016-4338

The mysql user parameter configuration script (userparameter_mysql.conf) in the agent in Zabbix...

8.1 HighPublic exploitFix available

The mysql user parameter configuration script (userparameter_mysql.conf) in the agent in Zabbix before 2.0.18, 2.2.x before 2.2.13, and 3.0.x before 3.0.3, when used with a shell other than bash, allows context-dependent attackers to execute arbitrary code or SQL commands via the mysql.size parameter.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

25.2%Down 11.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 8.1

The mysql user parameter configuration script (userparameter_mysql.conf) in the agent in Zabbix before 2.0.18, 2.2.x before 2.2.13, and 3.0.x before 3.0.3, when used with a shell other than bash, allows context-dependent attackers to execute arbitrary code or SQL commands via the mysql.size parameter.

Record
CVE-2016-4338
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-89
Updated
2026-11-02
CVE List No score

The mysql user parameter configuration script (userparameter_mysql.conf) in the agent in Zabbix before 2.0.18, 2.2.x before 2.2.13, and 3.0.x before 3.0.3, when used with a shell other than bash, allows context-dependent attackers to execute arbitrary code or SQL commands via the mysql.size parameter.

Record
CVE-2016-4338
Updated
2026-11-02
EUVDEUVD-2016-5338 No score

The mysql user parameter configuration script (userparameter_mysql.conf) in the agent in Zabbix before 2.0.18, 2.2.x before 2.2.13, and 3.0.x before 3.0.3, when used with a shell other than bash, allows context-dependent attackers to execute arbitrary code or SQL commands via the mysql.size parameter.

Record
EUVD-2016-5338
Updated
2026-11-03
GitHub AdvisoriesGHSA-399r-wgcm-v67f 8.1

The mysql user parameter configuration script (userparameter_mysql.conf) in the agent in Zabbix...

The mysql user parameter configuration script (userparameter_mysql.conf) in the agent in Zabbix before 2.0.18, 2.2.x before 2.2.13, and 3.0.x before 3.0.3, when used with a shell other than bash, allows context-dependent attackers to execute arbitrary code or SQL commands via the mysql.size parameter.

Record
GHSA-399r-wgcm-v67f
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-89
Updated
2026-11-02
OSV 8.1

The mysql user parameter configuration script (userparameter_mysql.conf) in the agent in Zabbix before 2.0.18, 2.2.x before 2.2.13, and 3.0.x before 3.0.3, when used with a shell other than bash, allows context-dependent attackers to execute arbitrary code or SQL commands via the mysql.size parameter.

Record
CVE-2016-4338
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-4338 8.1

The mysql user parameter configuration script (userparameter_mysql.conf) in the agent in Zabbix before 2.0.18, 2.2.x before 2.2.13, and 3.0.x before 3.0.3, when used with a shell other than bash, allows context-dependent attackers to execute arbitrary code or SQL commands via the mysql.size parameter.

Record
DEBIAN-CVE-2016-4338
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-4338 8.1

The mysql user parameter configuration script (userparameter_mysql.conf) in the agent in Zabbix before 2.0.18, 2.2.x before 2.2.13, and 3.0.x before 3.0.3, when used with a shell other than bash, allows context-dependent attackers to execute arbitrary code or SQL commands via the mysql.size parameter.

Record
UBUNTU-CVE-2016-4338
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUSN-4767-1 No score

zabbix vulnerabilities

Fu Chuang discovered that Zabbix did not properly parse IPs. A remote attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 14.04 ESM, Ubuntu 16.04 ESM and Ubuntu 18.04 ESM. (CVE-2020-11800)

It was discovered that Zabbix incorrectly handled certain requests. A remote attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 14.04 ESM and Ubuntu 16.04 ESM. (CVE-2017-2824, CVE-2017-2825)

It was discovered that Zabbix incorrectly handled certain XML files. A remote attacker could possibly use this issue to read arbitrary files or potentially execute arbitrary code. This issue only affected Ubuntu 14.04 ESM. (CVE-2014-3005)

It was discovered that Zabbix incorrectly handled certain inputs. A remote attacker could possibly use this issue to execute arbitrary SQL commands. This issue only affected Ubuntu 14.04 ESM. (CVE-2016-10134, CVE-2016-4338)

It was discovered that Zabbix incorrectly handled the request parameter. A remote attacker could possibly use this issue to redirect requests to external links. This issue only affected Ubuntu 14.04 ESM and Ubuntu 18.04 ESM. (CVE-2016-10742)

It was discovered that Zabbix incorrectly handled failed login attempts. A remote attacker could possibly use this issue to enumerate users. (CVE-2019-15132)

It was discovered that Zabbix did not properly validate input. A remote attacker could exploit this to conduct cross-site scripting (XSS) attacks. This issue only affected Ubuntu 16.04 ESM, Ubuntu 18.04 ESM and Ubuntu 20.04 ESM. (CVE-2020-15803)

Record
USN-4767-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
zabbix
Debian:12
before 1:3.0.3+dfsg-1
1:3.0.3+dfsg-1
zabbix
Debian:13
before 1:3.0.3+dfsg-1
1:3.0.3+dfsg-1
zabbix
Debian:14
before 1:3.0.3+dfsg-1
1:3.0.3+dfsg-1
zabbix
Ubuntu:Pro:14.04:LTS
before 1:2.2.2+dfsg-1ubuntu1+esm1, plus listed versions
1:2.0.6+dfsg-1ubuntu21:2.2.0+dfsg-1ubuntu11:2.2.0+dfsg-6ubuntu11:2.2.1+dfsg-1ubuntu31:2.2.2+dfsg-1ubuntu1
1:2.2.2+dfsg-1ubuntu1+esm1
zabbix
Ubuntu:Pro:14.04:LTS
before 1:2.2.2+dfsg-1ubuntu1+esm4, plus listed versions
1:2.0.6+dfsg-1ubuntu21:2.2.0+dfsg-1ubuntu11:2.2.0+dfsg-6ubuntu11:2.2.1+dfsg-1ubuntu31:2.2.2+dfsg-1ubuntu11:2.2.2+dfsg-1ubuntu1+esm11:2.2.2+dfsg-1ubuntu1+esm3
1:2.2.2+dfsg-1ubuntu1+esm4
zabbix
Ubuntu:Pro:16.04:LTS
before 1:2.4.7+dfsg-2ubuntu2.1+esm3, plus listed versions
1:2.4.6+dfsg-11:2.4.7+dfsg-11:2.4.7+dfsg-21:2.4.7+dfsg-2ubuntu21:2.4.7+dfsg-2ubuntu2.11:2.4.7+dfsg-2ubuntu2.1+esm11:2.4.7+dfsg-2ubuntu2.1+esm2
1:2.4.7+dfsg-2ubuntu2.1+esm3
zabbix
Ubuntu:Pro:18.04:LTS
before 1:3.0.12+dfsg-1ubuntu0.1~esm3, plus listed versions
1:3.0.7+dfsg-31:3.0.12+dfsg-11:3.0.12+dfsg-1ubuntu0.1~esm11:3.0.12+dfsg-1ubuntu0.1~esm2
1:3.0.12+dfsg-1ubuntu0.1~esm3
zabbix
Ubuntu:Pro:20.04:LTS
before 1:4.0.17+dfsg-1ubuntu0.1~esm1, plus listed versions
1:4.0.4+dfsg-1build21:4.0.4+dfsg-1build31:4.0.11+dfsg-11:4.0.14+dfsg-11:4.0.15+dfsg-11:4.0.16+dfsg-11:4.0.16+dfsg-1build11:4.0.17+dfsg-1
1:4.0.17+dfsg-1ubuntu0.1~esm1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBZabbix Agent 3.0.1 - 'mysql.size' Shell Command Injection2016-05-04

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-4338 is a high vulnerability (CVSS 8.1) in Zabbix, published January 23, 2017. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 25.2%, the 97th percentile. Fixed in zabbix 1:3.0.3+dfsg-1.

References

Show 19 moreShow less
MoveEnter Open