CVE-2016-4353
ber-decoder.c in Libksba before 1.3.3 does not properly handle decoder stack overflows, which...
CVE-2016-4353 is a high vulnerability (CVSS 7.5) in Gnupg Libksba, published April 29, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.15%, the 82nd percentile. Fixed in libksba 1.3.3-1.
ber-decoder.c in Libksba before 1.3.3 does not properly handle decoder stack overflows, which allows remote attackers to cause a denial of service (abort) via crafted BER data.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
ber-decoder.c in Libksba before 1.3.3 does not properly handle decoder stack overflows, which allows remote attackers to cause a denial of service (abort) via crafted BER data.
- Record
CVE-2016-4353- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
ber-decoder.c in Libksba before 1.3.3 does not properly handle decoder stack overflows, which allows remote attackers to cause a denial of service (abort) via crafted BER data.
- Record
CVE-2016-4353- Updated
- 2026-11-02
EUVDEUVD-2016-5353 No score
ber-decoder.c in Libksba before 1.3.3 does not properly handle decoder stack overflows, which allows remote attackers to cause a denial of service (abort) via crafted BER data.
- Record
EUVD-2016-5353- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-qcgh-wvgp-7qgv
7.5
ber-decoder.c in Libksba before 1.3.3 does not properly handle decoder stack overflows, which...
ber-decoder.c in Libksba before 1.3.3 does not properly handle decoder stack overflows, which allows remote attackers to cause a denial of service (abort) via crafted BER data.
- Record
GHSA-qcgh-wvgp-7qgv- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSVBELL-CVE-2016-4353
7.5
CVE-2016-4353 does not affect BellSoft software
- Record
BELL-CVE-2016-4353- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSV
7.5
ber-decoder.c in Libksba before 1.3.3 does not properly handle decoder stack overflows, which allows remote attackers to cause a denial of service (abort) via crafted BER data.
- Record
CVE-2016-4353- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-4353
7.5
ber-decoder.c in Libksba before 1.3.3 does not properly handle decoder stack overflows, which allows remote attackers to cause a denial of service (abort) via crafted BER data.
- Record
DEBIAN-CVE-2016-4353- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-4353
7.5
ber-decoder.c in Libksba before 1.3.3 does not properly handle decoder stack overflows, which allows remote attackers to cause a denial of service (abort) via crafted BER data.
- Record
UBUNTU-CVE-2016-4353- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUSN-2982-1 No score
libksba vulnerabilities
Hanno Böck discovered that Libksba incorrectly handled decoding certain BER data. An attacker could use this issue to cause Libksba to crash, resulting in a denial of service. This issue only applied to Ubuntu 12.04 LTS and Ubuntu 14.04 LTS. (CVE-2016-4353)
Hanno Böck discovered that Libksba incorrectly handled decoding certain BER data. An attacker could use this issue to cause Libksba to crash, resulting in a denial of service, or possibly execute arbitrary code. This issue only applied to Ubuntu 12.04 LTS and Ubuntu 14.04 LTS. (CVE-2016-4354, CVE-2016-4355)
Hanno Böck discovered that Libksba incorrectly handled incorrect utf-8 strings when decoding certain DN data. An attacker could use this issue to cause Libksba to crash, resulting in a denial of service, or possibly execute arbitrary code. This issue only applied to Ubuntu 12.04 LTS and Ubuntu 14.04 LTS. (CVE-2016-4356)
Pascal Cuoq discovered that Libksba incorrectly handled incorrect utf-8 strings when decoding certain DN data. An attacker could use this issue to cause Libksba to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2016-4574)
Pascal Cuoq discovered that Libksba incorrectly handled decoding certain data. An attacker could use this issue to cause Libksba to crash, resulting in a denial of service. (CVE-2016-4579)
- Record
USN-2982-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libksbaDebian:12 |
before 1.3.3-1 | 1.3.3-1 |
libksbaDebian:13 |
before 1.3.3-1 | 1.3.3-1 |
libksbaDebian:14 |
before 1.3.3-1 | 1.3.3-1 |
libksbaUbuntu:14.04:LTS |
before 1.3.0-3ubuntu0.14.04.2, plus listed versions 1.3.0-21.3.0-2ubuntu11.3.0-31.3.0-3ubuntu0.14.04.1 |
1.3.0-3ubuntu0.14.04.2 |
libksbaUbuntu:16.04:LTS |
before 1.3.3-1ubuntu0.16.04.1, plus listed versions 1.3.3-1 |
1.3.3-1ubuntu0.16.04.1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
ubuntu.com/usn/USN-2982-1
openwall.com/lists/oss-security/2016/04/29/5
openwall.com/lists/oss-security/2016/04/29/8
security.gentoo.org/glsa/201604-04
git.gnupg.org/cgi-bin/gitweb.cgi?p=libksba.git%3Ba=commit%3Bh=07116a314f4dcd4d96990bbd74db95a03a9f650a
nvd.nist.gov/vuln/detail/CVE-2016-4353
Show 13 moreShow less
git.gnupg.org/cgi-bin/gitweb.cgi?p=libksba.git;a=commit;h=07116a314f4dcd4d96990bbd74db95a03a9f650a
github.com/advisories/GHSA-qcgh-wvgp-7qgv
docs.bell-sw.com/security/cves/CVE-2016-4353
security-tracker.debian.org/tracker/CVE-2016-4353
ubuntu.com/security/CVE-2016-4353
openwall.com/lists/oss-security/2015/04/13/5
ubuntu.com/security/notices/USN-2982-1
cve.org/CVERecord?id=CVE-2016-4353
ubuntu.com/security/CVE-2016-4354
ubuntu.com/security/CVE-2016-4355
ubuntu.com/security/CVE-2016-4356
ubuntu.com/security/CVE-2016-4574
ubuntu.com/security/CVE-2016-4579