Every CVE Search/ Get API key

CVE-2016-4414

The onReadyRead function in core/coreauthhandler.cpp in Quassel before 0.12.4 allows remote...

7.5 HighFix available

The onReadyRead function in core/coreauthhandler.cpp in Quassel before 0.12.4 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) via invalid handshake data.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

2.85%Up 1.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

The onReadyRead function in core/coreauthhandler.cpp in Quassel before 0.12.4 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) via invalid handshake data.

Record
CVE-2016-4414
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

The onReadyRead function in core/coreauthhandler.cpp in Quassel before 0.12.4 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) via invalid handshake data.

Record
CVE-2016-4414
Updated
2026-11-02
EUVDEUVD-2016-5414 No score

The onReadyRead function in core/coreauthhandler.cpp in Quassel before 0.12.4 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) via invalid handshake data.

Record
EUVD-2016-5414
Updated
2026-11-03
GitHub AdvisoriesGHSA-r62h-rf3r-q857 7.5

The onReadyRead function in core/coreauthhandler.cpp in Quassel before 0.12.4 allows remote...

The onReadyRead function in core/coreauthhandler.cpp in Quassel before 0.12.4 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) via invalid handshake data.

Record
GHSA-r62h-rf3r-q857
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV 7.5

The onReadyRead function in core/coreauthhandler.cpp in Quassel before 0.12.4 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) via invalid handshake data.

Record
CVE-2016-4414
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-4414 7.5

The onReadyRead function in core/coreauthhandler.cpp in Quassel before 0.12.4 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) via invalid handshake data.

Record
DEBIAN-CVE-2016-4414
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-4414 7.5

The onReadyRead function in core/coreauthhandler.cpp in Quassel before 0.12.4 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) via invalid handshake data.

Record
UBUNTU-CVE-2016-4414
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2016-0166 No score

Updated quassel packages fix CVE-2016-4414

Updated quassel packages fix security vulnerability:

It was found that quasselcore is vulnerable to a denial of service attack by unauthenticated clients. The protocol negotiation did not take into account lack of a match in handshake data, in which case PeerFactory::createPeer returns a nullptr, which is immediately dereferenced (CVE-2016-4414).

Record
MGASA-2016-0166
Updated
2026-11-02
OSVopenSUSE-SU-2024:10119-1 No score

quassel-base-0.12.4-3.3 on GA media

These are all security issues fixed in the quassel-base-0.12.4-3.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10119-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
quassel
Debian:12
before 1:0.12.4-2
1:0.12.4-2
quassel
Debian:13
before 1:0.12.4-2
1:0.12.4-2
quassel
Debian:14
before 1:0.12.4-2
1:0.12.4-2
quassel
Mageia:5
before 0.10.1-5.2.mga5
0.10.1-5.2.mga5
quassel
Ubuntu:16.04:LTS
All versions, plus listed versions
0.12.2-0ubuntu10.12.2-0ubuntu1.16.04.2
None known
quassel
openSUSE:Tumbleweed
before 0.12.4-3.3
0.12.4-3.3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-4414 is a high vulnerability (CVSS 7.5) in Quassel-irc Quassel, published May 5, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.85%, the 86th percentile. Fixed in quassel 1:0.12.4-2.

References

Show 13 moreShow less
MoveEnter Open