Every CVE Search/ Get API key

CVE-2016-4418

epan/dissectors/packet-ber.c in the ASN.1 BER dissector in Wireshark 1.12.x before 1.12.10 and 2...

5.9 MediumFix available

epan/dissectors/packet-ber.c in the ASN.1 BER dissector in Wireshark 1.12.x before 1.12.10 and 2.x before 2.0.2 allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted packet that triggers an empty set.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.35%Up 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.9

epan/dissectors/packet-ber.c in the ASN.1 BER dissector in Wireshark 1.12.x before 1.12.10 and 2.x before 2.0.2 allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted packet that triggers an empty set.

Record
CVE-2016-4418
CVSS 3.0
5.9 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

epan/dissectors/packet-ber.c in the ASN.1 BER dissector in Wireshark 1.12.x before 1.12.10 and 2.x before 2.0.2 allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted packet that triggers an empty set.

Record
CVE-2016-4418
Updated
2026-11-02
EUVDEUVD-2016-5418 No score

epan/dissectors/packet-ber.c in the ASN.1 BER dissector in Wireshark 1.12.x before 1.12.10 and 2.x before 2.0.2 allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted packet that triggers an empty set.

Record
EUVD-2016-5418
Updated
2026-11-03
GitHub AdvisoriesGHSA-x3p3-h634-496f 5.9

epan/dissectors/packet-ber.c in the ASN.1 BER dissector in Wireshark 1.12.x before 1.12.10 and 2...

epan/dissectors/packet-ber.c in the ASN.1 BER dissector in Wireshark 1.12.x before 1.12.10 and 2.x before 2.0.2 allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted packet that triggers an empty set.

Record
GHSA-x3p3-h634-496f
CVSS 3.0
5.9 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-119
Updated
2026-11-02
OSV 5.9

epan/dissectors/packet-ber.c in the ASN.1 BER dissector in Wireshark 1.12.x before 1.12.10 and 2.x before 2.0.2 allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted packet that triggers an empty set.

Record
CVE-2016-4418
CVSS 3.0
5.9 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-4418 5.9

epan/dissectors/packet-ber.c in the ASN.1 BER dissector in Wireshark 1.12.x before 1.12.10 and 2.x before 2.0.2 allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted packet that triggers an empty set.

Record
DEBIAN-CVE-2016-4418
CVSS 3.0
5.9 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-4418 5.9

epan/dissectors/packet-ber.c in the ASN.1 BER dissector in Wireshark 1.12.x before 1.12.10 and 2.x before 2.0.2 allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted packet that triggers an empty set.

Record
UBUNTU-CVE-2016-4418
CVSS 3.0
5.9 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wireshark
Debian:12
before 2.0.2+ga16e22e-1
2.0.2+ga16e22e-1
wireshark
Debian:13
before 2.0.2+ga16e22e-1
2.0.2+ga16e22e-1
wireshark
Debian:14
before 2.0.2+ga16e22e-1
2.0.2+ga16e22e-1
wireshark
Debian:7
before 1.8.2-5wheezy18, plus listed versions
1.8.2-5wheezy101.8.2-5wheezy111.8.2-5wheezy121.8.2-5wheezy131.8.2-5wheezy14
Show 13 moreShow less
1.8.2-5wheezy151.8.2-5wheezy15~deb6u11.8.2-5wheezy161.8.2-5wheezy16~deb6u11.8.2-5wheezy171.8.2-5wheezy21.8.2-5wheezy31.8.2-5wheezy41.8.2-5wheezy51.8.2-5wheezy61.8.2-5wheezy71.8.2-5wheezy81.8.2-5wheezy9
1.8.2-5wheezy18
wireshark
Debian:8
before 1.12.1+g01b65bf-4+deb8u5, plus listed versions
1.12.1+g01b65bf-41.12.1+g01b65bf-4+deb8u11.12.1+g01b65bf-4+deb8u21.12.1+g01b65bf-4+deb8u31.12.1+g01b65bf-4+deb8u4
1.12.1+g01b65bf-4+deb8u5
wireshark
Ubuntu:14.04:LTS
before 2.6.3-1~ubuntu14.04.1, plus listed versions
1.10.2-11.10.3-11.10.5-1ubuntu11.10.5-21.10.6-11.12.1+g01b65bf-4+deb8u11ubuntu0.14.04.1
2.6.3-1~ubuntu14.04.1
wireshark
Ubuntu:16.04:LTS
before 2.6.3-1~ubuntu16.04.1, plus listed versions
1.12.7+g7fc8978-11.12.8+g5b6e543-22.0.1+g59ea380-3build12.0.2+ga16e22e-12.2.6+g32dac6a-2ubuntu0.16.04
2.6.3-1~ubuntu16.04.1
wireshark
Ubuntu:18.04:LTS
before 2.6.3-1~ubuntu18.04.1, plus listed versions
2.4.2-12.4.3-12.4.4-12.4.5-1
2.6.3-1~ubuntu18.04.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-4418 is a medium vulnerability (CVSS 5.9) in Wireshark, published March 13, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.35%, the 71st percentile. Fixed in wireshark 2.0.2+ga16e22e-1.

References

Show 4 moreShow less
MoveEnter Open