CVE-2016-4567
MediaElement Vulnerable to Reflected XSS
CVE-2016-4567 is a medium vulnerability (CVSS 6.1) in Mediaelementjs Mediaelement.js, published May 22, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 7.35%, the 94th percentile. Fixed in mediaelement 2.11.1.
Cross-site scripting (XSS) vulnerability in flash/FlashMediaElement.as in MediaElement.js before 2.21.0, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via an obfuscated form of the jsinitfunction parameter, as demonstrated by "jsinitfunctio%gn."
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Cross-site scripting (XSS) vulnerability in flash/FlashMediaElement.as in MediaElement.js before 2.21.0, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via an obfuscated form of the jsinitfunction parameter, as demonstrated by "jsinitfunctio%gn."
- Record
CVE-2016-4567- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in flash/FlashMediaElement.as in MediaElement.js before 2.21.0, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via an obfuscated form of the jsinitfunction parameter, as demonstrated by "jsinitfunctio%gn."
- Record
CVE-2016-4567- Updated
- 2026-11-02
EUVDEUVD-2022-1928 No score
Cross-site scripting (XSS) vulnerability in flash/FlashMediaElement.as in MediaElement.js before 2.21.0, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via an obfuscated form of the jsinitfunction parameter, as demonstrated by "jsinitfunctio%gn."
- Record
EUVD-2022-1928- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-277w-qpxr-2549
6.1
MediaElement Vulnerable to Reflected XSS
Cross-site scripting (XSS) vulnerability in flash/FlashMediaElement.swf in MediaElement.js before 2.21.0, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via an obfuscated form of the jsinitfunction parameter, as demonstrated by "jsinitfunctio%gn."
- Record
GHSA-277w-qpxr-2549- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
Cross-site scripting (XSS) vulnerability in flash/FlashMediaElement.as in MediaElement.js before 2.21.0, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via an obfuscated form of the jsinitfunction parameter, as demonstrated by "jsinitfunctio%gn."
- Record
CVE-2016-4567- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-4567
6.1
Cross-site scripting (XSS) vulnerability in flash/FlashMediaElement.as in MediaElement.js before 2.21.0, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via an obfuscated form of the jsinitfunction parameter, as demonstrated by "jsinitfunctio%gn."
- Record
DEBIAN-CVE-2016-4567- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-277w-qpxr-2549
6.1
MediaElement Vulnerable to Reflected XSS
Cross-site scripting (XSS) vulnerability in flash/FlashMediaElement.swf in MediaElement.js before 2.21.0, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via an obfuscated form of the jsinitfunction parameter, as demonstrated by "jsinitfunctio%gn."
- Record
GHSA-277w-qpxr-2549- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-4567
6.1
Cross-site scripting (XSS) vulnerability in flash/FlashMediaElement.as in MediaElement.js before 2.21.0, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via an obfuscated form of the jsinitfunction parameter, as demonstrated by "jsinitfunctio%gn."
- Record
UBUNTU-CVE-2016-4567- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mediaelementnpm |
before 2.11.1 | 2.11.1 |
contao-components/mediaelementPackagist |
2.14.2 up to 2.21.1 | 2.21.1 |
contao/corePackagist |
3.0.0 up to 3.5.15 | 3.5.15 |
mediaelementDebian:12 |
All versions, plus listed versions 2.15.1+dfsg-3 |
None known |
mediaelementDebian:13 |
All versions, plus listed versions 2.15.1+dfsg-3 |
None known |
mediaelementDebian:14 |
All versions, plus listed versions 2.15.1+dfsg-3 |
None known |
contao-components/mediaelementPackagist |
2.14.2 up to 2.21.1, plus listed versions 2.15.02.15.12.15.1.12.16.02.16.1 Show 13 moreShow less2.16.22.16.32.16.42.17.02.18.02.18.12.18.22.19.02.19.0.12.19.0.22.20.02.20.12.21.0 |
2.21.1 |
contao/corePackagist |
3.0.0 up to 3.5.15, plus listed versions 3.0.13.0.23.0.33.0.43.0.5 Show 45 moreShow less3.0.63.1.03.1.13.1.23.1.33.1.43.1.53.1.RC13.1.beta13.2.03.2.13.2.103.2.113.2.123.2.133.2.143.2.153.2.163.2.173.2.183.2.193.2.23.2.203.2.213.2.33.2.43.2.53.2.63.2.73.2.83.2.93.2.RC13.2.beta13.2.beta23.3.03.3.0-RC13.3.0-RC23.3.0-beta13.3.13.3.23.3.33.3.43.3.53.3.63.3.7 |
3.5.15 |
mediaelementUbuntu:16.04:LTS |
All versions, plus listed versions 2.15.1+dfsg-1 |
None known |
mediaelementUbuntu:18.04:LTS |
All versions, plus listed versions 2.15.1+dfsg-1 |
None known |
Show 6 moreShow less
| Package | Affected | Fixed |
|---|---|---|
mediaelementUbuntu:20.04:LTS |
All versions, plus listed versions 2.15.1+dfsg-12.15.1+dfsg-1ubuntu1 |
None known |
mediaelementUbuntu:22.04:LTS |
All versions, plus listed versions 2.15.1+dfsg-3 |
None known |
mediaelementUbuntu:24.04:LTS |
All versions, plus listed versions 2.15.1+dfsg-3 |
None known |
mediaelementUbuntu:25.10 |
All versions, plus listed versions 2.15.1+dfsg-3 |
None known |
mediaelementUbuntu:26.10 |
All versions, plus listed versions 2.15.1+dfsg-3build1 |
None known |
mediaelementUbuntu:26.04:LTS |
All versions, plus listed versions 2.15.1+dfsg-32.15.1+dfsg-3build1 |
None known |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
github.com/johndyer/mediaelement/blob/master/changelog.md
openwall.com/lists/oss-security/2016/05/07/2
codex.wordpress.org/Version_4.5.2
securitytracker.com/id/1035818
gist.github.com/cure53/df34ea68c26441f3ae98f821ba1feb9c
github.com/johndyer/mediaelement/commit/34834eef8ac830b9145df169ec22016a4350f06e
Show 16 moreShow less
wpvulndb.com/vulnerabilities/8488
wordpress.org/news/2016/05/wordpress-4-5-2
core.trac.wordpress.org/changeset/37371
nvd.nist.gov/vuln/detail/CVE-2016-4567
github.com/mediaelement/mediaelement/commit/34834eef8ac830b9145df169ec22016a4350f06e
contao.org/en/news/contao-3_5_15.html
github.com/FriendsOfPHP/security-advisories/blob/master/contao-components/mediaelement/CVE-2016-4567.yaml
github.com/FriendsOfPHP/security-advisories/blob/master/contao/core/CVE-2016-4567.yaml
github.com/mediaelement/mediaelement/blob/b992ccf5f0c04a207d98bbb0868420751a61ec90/changelog.md?plain=1
github.com/mediaelement/mediaelement/blob/master/changelog.md
web.archive.org/web/20170205142412/http://www.securitytracker.com/id/1035818
github.com/advisories/GHSA-277w-qpxr-2549
security-tracker.debian.org/tracker/CVE-2016-4567
ubuntu.com/security/CVE-2016-4567
core.trac.wordpress.org/changeset/37370
cve.org/CVERecord?id=CVE-2016-4567
Left out here: 25 versions. The JSON record has them.