CVE-2016-4793
CakePHP allows remote attackers to spoof their IP
The clientIp function in CakePHP 3.2.4 and earlier allows remote attackers to spoof their IP via the CLIENT-IP HTTP header.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.5
The clientIp function in CakePHP 3.2.4 and earlier allows remote attackers to spoof their IP via the CLIENT-IP HTTP header.
- Record
CVE-2016-4793- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:P/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
The clientIp function in CakePHP 3.2.4 and earlier allows remote attackers to spoof their IP via the CLIENT-IP HTTP header.
- Record
CVE-2016-4793- Updated
- 2026-11-02
EUVDEUVD-2022-4314 No score
The clientIp function in CakePHP 3.2.4 and earlier allows remote attackers to spoof their IP via the CLIENT-IP HTTP header.
- Record
EUVD-2022-4314- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-j8p3-8m69-2hqq
7.5
CakePHP allows remote attackers to spoof their IP
The clientIp function in CakePHP 3.2.4 and earlier allows remote attackers to spoof their IP via the CLIENT-IP HTTP header.
- Record
GHSA-j8p3-8m69-2hqq- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
7.5
The clientIp function in CakePHP 3.2.4 and earlier allows remote attackers to spoof their IP via the CLIENT-IP HTTP header.
- Record
CVE-2016-4793- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-4793
7.5
The clientIp function in CakePHP 3.2.4 and earlier allows remote attackers to spoof their IP via the CLIENT-IP HTTP header.
- Record
DEBIAN-CVE-2016-4793- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVGHSA-j8p3-8m69-2hqq
7.5
CakePHP allows remote attackers to spoof their IP
The clientIp function in CakePHP 3.2.4 and earlier allows remote attackers to spoof their IP via the CLIENT-IP HTTP header.
- Record
GHSA-j8p3-8m69-2hqq- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-4793
7.5
The clientIp function in CakePHP 3.2.4 and earlier allows remote attackers to spoof their IP via the CLIENT-IP HTTP header.
- Record
UBUNTU-CVE-2016-4793- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-04
OSVUSN-8978-1 No score
cakephp vulnerability
Dawid Golunski discovered that CakePHP incorrectly trusted the CLIENT-IP HTTP header when determining the client IP address. A remote attacker could possibly use this issue to spoof their IP address.
- Record
USN-8978-1- Updated
- 2026-11-04
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
cakephp/cakephpPackagist |
1.2.0 up to 2.6.13 | 2.6.13 |
cakephp/cakephpPackagist |
2.7.0-rc1 up to 2.7.11 | 2.7.11 |
cakephp/cakephpPackagist |
2.8.0-rc1 up to 2.8.2 | 2.8.2 |
cakephp/cakephpPackagist |
3.0.0-rc1 up to 3.0.17 | 3.0.17 |
cakephp/cakephpPackagist |
3.1.0-beta1 up to 3.1.12 | 3.1.12 |
cakephp/cakephpPackagist |
3.2.0-rc1 up to 3.2.5 | 3.2.5 |
cakephpDebian:11 |
before 2.8.3-1 | 2.8.3-1 |
cakephpDebian:7 |
before 1.3.15-1+deb7u2, plus listed versions 1.3.15-11.3.15-1+deb7u1 |
1.3.15-1+deb7u2 |
cakephp/cakephpPackagist |
1.2.0 up to 2.6.13, plus listed versions 2.4.102.4.52.4.62.4.72.4.8 Show 29 moreShow less2.4.92.5.02.5.0-RC12.5.0-RC22.5.0-beta2.5.12.5.22.5.32.5.42.5.52.5.62.5.72.5.82.5.92.6.02.6.0-RC12.6.0-beta2.6.12.6.102.6.112.6.122.6.22.6.32.6.42.6.52.6.62.6.72.6.82.6.9 |
2.6.13 |
cakephp/cakephpPackagist |
2.7.0-rc1 up to 2.7.11, plus listed versions 2.7.02.7.12.7.102.7.22.7.3 Show 6 moreShow less2.7.42.7.52.7.62.7.72.7.82.7.9 |
2.7.11 |
Show 6 moreShow less
| Package | Affected | Fixed |
|---|---|---|
cakephp/cakephpPackagist |
2.8.0-rc1 up to 2.8.2, plus listed versions 2.8.02.8.0-RC12.8.1 |
2.8.2 |
cakephp/cakephpPackagist |
3.0.0-rc1 up to 3.0.17, plus listed versions 3.0.03.0.0-RC13.0.0-RC23.0.13.0.10 Show 14 moreShow less3.0.113.0.123.0.133.0.143.0.153.0.163.0.23.0.33.0.43.0.53.0.63.0.73.0.83.0.9 |
3.0.17 |
cakephp/cakephpPackagist |
3.1.0-beta1 up to 3.1.12, plus listed versions 3.1.03.1.0-RC13.1.0-beta23.1.13.1.10 Show 9 moreShow less3.1.113.1.23.1.33.1.43.1.53.1.63.1.73.1.83.1.9 |
3.1.12 |
cakephp/cakephpPackagist |
3.2.0-rc1 up to 3.2.5, plus listed versions 3.2.03.2.0-RC13.2.13.2.23.2.33.2.4 |
3.2.5 |
cakephpUbuntu:14.04:LTS |
before 1.3.15-1+deb7u2build0.14.04.1, plus listed versions 1.3.15-1 |
1.3.15-1+deb7u2build0.14.04.1 |
cakephpUbuntu:Pro:16.04:LTS |
before 2.8.0-1ubuntu0.1~esm1, plus listed versions 2.7.2-12.8.0-1 |
2.8.0-1ubuntu0.1~esm1 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | CakePHP Framework 3.2.4 - IP Spoofing | 2016-05-16 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, aliases, references | OSV | |
| affected, facts | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-4793 is a high vulnerability (CVSS 7.5) in Cakephp, published January 23, 2017. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 5.15%, the 92nd percentile. Fixed in cakephp/cakephp 2.6.13.
References
support.citrix.com/article/CTX236992
exploit-db.com/exploits/39813
legalhackers.com/advisories/CakePHP-IP-Spoofing-Vulnerability.txt
securityfocus.com/bid/95846
bakery.cakephp.org/2016/03/13/cakephp_2613_2711_282_3017_3112_325_released.html
nvd.nist.gov/vuln/detail/CVE-2016-4793