CVE-2016-4970
Loop with Unreachable Exit Condition in Netty
handler/ssl/OpenSslEngine.java in Netty 4.0.x before 4.0.37.Final and 4.1.x before 4.1.1.Final allows remote attackers to cause a denial of service (infinite loop).
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
handler/ssl/OpenSslEngine.java in Netty 4.0.x before 4.0.37.Final and 4.1.x before 4.1.1.Final allows remote attackers to cause a denial of service (infinite loop).
- Record
CVE-2016-4970- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 7.8 High
AV:N/AC:L/Au:N/C:N/I:N/A:C - Weakness
- CWE-835
- Updated
- 2026-11-02
CVE List No score
handler/ssl/OpenSslEngine.java in Netty 4.0.x before 4.0.37.Final and 4.1.x before 4.1.1.Final allows remote attackers to cause a denial of service (infinite loop).
- Record
CVE-2016-4970- Updated
- 2026-11-02
EUVDEUVD-2022-5233 No score
handler/ssl/OpenSslEngine.java in Netty 4.0.x before 4.0.37.Final and 4.1.x before 4.1.1.Final allows remote attackers to cause a denial of service (infinite loop).
- Record
EUVD-2022-5233- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-rv63-gqm8-9w8q
7.5
Loop with Unreachable Exit Condition in Netty
handler/ssl/OpenSslEngine.java in Netty 4.0.x before 4.0.37.Final and 4.1.x before 4.1.1.Final allows remote attackers to cause a denial of service (infinite loop).
- Record
GHSA-rv63-gqm8-9w8q- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-835
- Updated
- 2026-11-02
OSV
7.5
handler/ssl/OpenSslEngine.java in Netty 4.0.x before 4.0.37.Final and 4.1.x before 4.1.1.Final allows remote attackers to cause a denial of service (infinite loop).
- Record
CVE-2016-4970- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-4970
7.5
handler/ssl/OpenSslEngine.java in Netty 4.0.x before 4.0.37.Final and 4.1.x before 4.1.1.Final allows remote attackers to cause a denial of service (infinite loop).
- Record
DEBIAN-CVE-2016-4970- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVGHSA-rv63-gqm8-9w8q
7.5
Loop with Unreachable Exit Condition in Netty
handler/ssl/OpenSslEngine.java in Netty 4.0.x before 4.0.37.Final and 4.1.x before 4.1.1.Final allows remote attackers to cause a denial of service (infinite loop).
- Record
GHSA-rv63-gqm8-9w8q- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-835
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-4970
7.5
handler/ssl/OpenSslEngine.java in Netty 4.0.x before 4.0.37.Final and 4.1.x before 4.1.1.Final allows remote attackers to cause a denial of service (infinite loop).
- Record
UBUNTU-CVE-2016-4970- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVMGASA-2018-0485 No score
Updated netty & jctools packages fix security vulnerability
handler/ssl/OpenSslEngine.java in Netty before 4.0.37.Final allows remote attackers to cause a denial of service (infinite loop) (CVE-2016-4970).
- Record
MGASA-2018-0485- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
io.netty:netty-handlerMaven |
4.0.0.Alpha1 up to 4.0.37.Final | 4.0.37.Final |
io.netty:netty-handlerMaven |
4.1.0.Beta1 up to 4.1.1.Final | 4.1.1.Final |
nettyDebian:12 |
before 1:4.0.37-1 | 1:4.0.37-1 |
nettyDebian:13 |
before 1:4.0.37-1 | 1:4.0.37-1 |
nettyDebian:14 |
before 1:4.0.37-1 | 1:4.0.37-1 |
io.netty:netty-handlerMaven |
4.0.0.Alpha1 up to 4.0.37.Final, plus listed versions 4.0.0.Alpha24.0.0.Alpha34.0.0.Alpha44.0.0.Alpha54.0.0.Alpha6 Show 45 moreShow less4.0.0.Alpha74.0.0.Alpha84.0.0.Beta14.0.0.Beta24.0.0.Beta34.0.0.CR14.0.0.CR24.0.0.CR34.0.0.CR44.0.0.CR54.0.0.CR64.0.0.CR74.0.0.CR84.0.0.CR94.0.0.Final4.0.1.Final4.0.10.Final4.0.11.Final4.0.12.Final4.0.13.Final4.0.14.Beta14.0.14.Final4.0.15.Final4.0.16.Final4.0.17.Final4.0.18.Final4.0.19.Final4.0.2.Final4.0.20.Final4.0.21.Final4.0.22.Final4.0.23.Final4.0.24.Final4.0.25.Final4.0.26.Final4.0.27.Final4.0.28.Final4.0.29.Final4.0.3.Final4.0.30.Final4.0.31.Final4.0.32.Final4.0.33.Final4.0.34.Final4.0.35.Final |
4.0.37.Final |
io.netty:netty-handlerMaven |
4.1.0.Beta1 up to 4.1.1.Final, plus listed versions 4.1.0.Beta24.1.0.Beta34.1.0.Beta44.1.0.Beta54.1.0.Beta6 Show 10 moreShow less4.1.0.Beta74.1.0.Beta84.1.0.CR14.1.0.CR24.1.0.CR34.1.0.CR44.1.0.CR54.1.0.CR64.1.0.CR74.1.0.Final |
4.1.1.Final |
nettyMageia:6 |
before 4.0.42-1.mga6 | 4.0.42-1.mga6 |
jctoolsMageia:6 |
before 1.2.1-1.mga6 | 1.2.1-1.mga6 |
nettyUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 1:3.2.6.Final-21:4.0.32-11:4.0.33-11:4.0.34-11:4.0.34-1ubuntu0.1~esm1 Show 4 moreShow less1:4.0.34-1ubuntu0.1~esm21:4.0.34-1ubuntu0.1~esm31:4.0.34-1ubuntu0.1~esm41:4.0.34-1ubuntu0.1~esm5 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-4970 is a high vulnerability (CVSS 7.5) in Netty, published April 13, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 11.3%, the 95th percentile. Fixed in io.netty:netty-handler 4.0.37.Final.
References
rhn.redhat.com/errata/RHSA-2017-0179.html
rhn.redhat.com/errata/RHSA-2017-1097.html
netty.io/news/2016/06/07/4-1-1-Final.html
securityfocus.com/bid/96540
github.com/netty/netty/pull/5364
wiki.opendaylight.org/view/Security_Advisories
Show 12 moreShow less
netty.io/news/2016/06/07/4-0-37-Final.html
bugzilla.redhat.com/show_bug.cgi?id=1343616
lists.apache.org/thread.html/afaa5860e3a6d327eb96c3d82cbd2f5996de815a16854ed1ad310144%40%3Ccommits.cassandra.apache.org%3E
nvd.nist.gov/vuln/detail/CVE-2016-4970
lists.apache.org/thread.html/afaa5860e3a6d327eb96c3d82cbd2f5996de815a16854ed1ad310144@%3Ccommits.cassandra.apache.org%3E
github.com/advisories/GHSA-rv63-gqm8-9w8q
security-tracker.debian.org/tracker/CVE-2016-4970
github.com/netty/netty
advisories.mageia.org/MGASA-2018-0485.html
bugs.mageia.org/show_bug.cgi?id=23974
ubuntu.com/security/CVE-2016-4970
cve.org/CVERecord?id=CVE-2016-4970
Left out here: 7 versions. The JSON record has them.