Every CVE Search/ Get API key

CVE-2016-5005

Apache Archiva vulnerable to Cross-site Scripting

4.8 MediumFix available

CVE-2016-5005 is a medium vulnerability (CVSS 4.8) in Apache Archiva, published July 28, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.80%, the 91st percentile. Fixed in org.apache.archiva:archiva 2.2.1.

Cross-site scripting (XSS) vulnerability in Apache Archiva 1.3.9 and earlier allows remote authenticated administrators to inject arbitrary web script or HTML via the connector.sourceRepoId parameter to admin/addProxyConnector_commit.action.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
High
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

4.80%Up 2.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.8

Cross-site scripting (XSS) vulnerability in Apache Archiva 1.3.9 and earlier allows remote authenticated administrators to inject arbitrary web script or HTML via the connector.sourceRepoId parameter to admin/addProxyConnector_commit.action.

Record
CVE-2016-5005
CVSS 3.0
4.8 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in Apache Archiva 1.3.9 and earlier allows remote authenticated administrators to inject arbitrary web script or HTML via the connector.sourceRepoId parameter to admin/addProxyConnector_commit.action.

Record
CVE-2016-5005
Updated
2026-11-02
EUVDEUVD-2022-3193 No score

Cross-site scripting (XSS) vulnerability in Apache Archiva 1.3.9 and earlier allows remote authenticated administrators to inject arbitrary web script or HTML via the connector.sourceRepoId parameter to admin/addProxyConnector_commit.action.

Record
EUVD-2022-3193
Updated
2026-11-03
GitHub AdvisoriesGHSA-8jfm-rgmg-3wq2 4.8

Apache Archiva vulnerable to Cross-site Scripting

Cross-site scripting (XSS) vulnerability in Apache Archiva prior to version 2.2.1 allows remote authenticated administrators to inject arbitrary web script or HTML via the connector.sourceRepoId parameter to admin/addProxyConnector_commit.action.

Record
GHSA-8jfm-rgmg-3wq2
CVSS 3.0
4.8 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 4.8

Cross-site scripting (XSS) vulnerability in Apache Archiva 1.3.9 and earlier allows remote authenticated administrators to inject arbitrary web script or HTML via the connector.sourceRepoId parameter to admin/addProxyConnector_commit.action.

Record
CVE-2016-5005
CVSS 3.0
4.8 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-8jfm-rgmg-3wq2 4.8

Apache Archiva vulnerable to Cross-site Scripting

Cross-site scripting (XSS) vulnerability in Apache Archiva prior to version 2.2.1 allows remote authenticated administrators to inject arbitrary web script or HTML via the connector.sourceRepoId parameter to admin/addProxyConnector_commit.action.

Record
GHSA-8jfm-rgmg-3wq2
CVSS 3.0
4.8 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.archiva:archiva
Maven
before 2.2.1
2.2.1
org.apache.archiva:archiva
Maven
before 2.2.1, plus listed versions
1.11.1.11.1.21.1.31.1.4
Show 22 moreShow less
1.21.2-M11.2.11.2.21.31.3.11.3.21.3.31.3.41.3.51.3.61.3.81.3.91.4-M11.4-M21.4-M31.4-M42.0.02.0.12.1.02.1.12.2.0
2.2.1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 5 moreShow less
MoveEnter Open