Every CVE Search/ Get API key

CVE-2016-6132

The gdImageCreateFromTgaCtx function in the GD Graphics Library (aka libgd) before 2.2.3 allows...

6.5 MediumFix available

CVE-2016-6132 is a medium vulnerability (CVSS 6.5) in Libgd, published June 30, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.27%, the 88th percentile. Fixed in gd 2.2.3-r0.

The gdImageCreateFromTgaCtx function in the GD Graphics Library (aka libgd) before 2.2.3 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted TGA file.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

3.27%Up 1.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.5

The gdImageCreateFromTgaCtx function in the GD Graphics Library (aka libgd) before 2.2.3 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted TGA file.

Record
CVE-2016-6132
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

The gdImageCreateFromTgaCtx function in the GD Graphics Library (aka libgd) before 2.2.3 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted TGA file.

Record
CVE-2016-6132
Updated
2026-11-02
EUVDEUVD-2016-7066 No score

The gdImageCreateFromTgaCtx function in the GD Graphics Library (aka libgd) before 2.2.3 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted TGA file.

Record
EUVD-2016-7066
Updated
2026-11-03
GitHub AdvisoriesGHSA-p2gq-f8g2-6936 6.5

The gdImageCreateFromTgaCtx function in the GD Graphics Library (aka libgd) before 2.2.3 allows...

The gdImageCreateFromTgaCtx function in the GD Graphics Library (aka libgd) before 2.2.3 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted TGA file.

Record
GHSA-p2gq-f8g2-6936
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
OSVALPINE-CVE-2016-6132 6.5

The gdImageCreateFromTgaCtx function in the GD Graphics Library (aka libgd) before 2.2.3 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted TGA file.

Record
ALPINE-CVE-2016-6132
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV 6.5

The gdImageCreateFromTgaCtx function in the GD Graphics Library (aka libgd) before 2.2.3 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted TGA file.

Record
CVE-2016-6132
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 6 moreShow less
OSVDEBIAN-CVE-2016-6132 6.5

The gdImageCreateFromTgaCtx function in the GD Graphics Library (aka libgd) before 2.2.3 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted TGA file.

Record
DEBIAN-CVE-2016-6132
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-6132 6.5

The gdImageCreateFromTgaCtx function in the GD Graphics Library (aka libgd) before 2.2.3 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted TGA file.

Record
UBUNTU-CVE-2016-6132
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2016-0258 No score

Updated libgd packages fix security vulnerability

Updated libgd packages fix security vulnerabilities:

A read out-of-bounds was found in the parsing of TGA files when the header reports an incorrect size (CVE-2016-6132) or invalid bpp (CVE-2016-6214) or RLE value (upstream issue 248).

Integer overflow error within _gdContributionsAlloc() (CVE-2016-6207).

A regression in the previous update that caused some packages to fail to build against libgd has also been fixed (mga#18947).

Record
MGASA-2016-0258
Updated
2026-11-02
OSVopenSUSE-SU-2024:10062-1 No score

gd-2.2.3-2.1 on GA media

These are all security issues fixed in the gd-2.2.3-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10062-1
Updated
2026-11-02
OSVSUSE-SU-2016:2303-1 No score

Security update for gd

This update for gd fixes the following issues:

  • CVE-2016-6214: Buffer over-read issue when parsing crafted TGA file [bsc#991436]
  • CVE-2016-6132: read out-of-bands was found in the parsing of TGA files using libgd [bsc#987577]
  • CVE-2016-6128: Invalid color index not properly handled [bsc#991710]
  • CVE-2016-6207: Integer overflow error within _gdContributionsAlloc() [bsc#991622]
  • CVE-2016-6161: global out of bounds read when encoding gif from malformed input withgd2togif [bsc#988032]
  • CVE-2016-5116: avoid stack overflow (read) with large names [bsc#982176]
  • CVE-2016-6905: Out-of-bounds read in function read_image_tga in gd_tga.c [bsc#995034]
Record
SUSE-SU-2016:2303-1
Updated
2026-11-02
OSVUSN-3060-1 No score

libgd2 vulnerabilities

It was discovered that the GD library incorrectly handled certain malformed TGA images. If a user or automated system were tricked into processing a specially crafted TGA image, an attacker could cause a denial of service. (CVE-2016-6132, CVE-2016-6214)

It was discovered that the GD library incorrectly handled memory when using gdImageScale(). A remote attacker could possibly use this issue to cause a denial of service or possibly execute arbitrary code. (CVE-2016-6207)

Record
USN-3060-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gd
Alpine:v3.4
before 2.2.3-r0
2.2.3-r0
libgd2
Debian:12
before 2.2.2-29-g3c2b605-1
2.2.2-29-g3c2b605-1
libgd2
Debian:13
before 2.2.2-29-g3c2b605-1
2.2.2-29-g3c2b605-1
libgd2
Debian:14
before 2.2.2-29-g3c2b605-1
2.2.2-29-g3c2b605-1
libgd2
Debian:8
before 2.1.0-5+deb8u4, plus listed versions
2.1.0-52.1.0-5+deb8u12.1.0-5+deb8u22.1.0-5+deb8u3
2.1.0-5+deb8u4
libgd
Mageia:5
before 2.2.3-1.1.mga5
2.2.3-1.1.mga5
gd
SUSE:Linux Enterprise Desktop 12 SP1
before 2.1.0-12.1
2.1.0-12.1
gd
SUSE:Linux Enterprise Software Development Kit 12 SP1
before 2.1.0-12.1
2.1.0-12.1
gd
SUSE:Linux Enterprise Server 12 SP1
before 2.1.0-12.1
2.1.0-12.1
gd
SUSE:Linux Enterprise Server for SAP Applications 12 SP1
before 2.1.0-12.1
2.1.0-12.1
Show 4 moreShow less
Affected packages
PackageAffectedFixed
gd
SUSE:Linux Enterprise Workstation Extension 12 SP1
before 2.1.0-12.1
2.1.0-12.1
libgd2
Ubuntu:14.04:LTS
before 2.1.0-3ubuntu0.3, plus listed versions
2.1.0-22.1.0-32.1.0-3ubuntu0.12.1.0-3ubuntu0.2
2.1.0-3ubuntu0.3
libgd2
Ubuntu:16.04:LTS
before 2.1.1-4ubuntu0.16.04.3, plus listed versions
2.1.1-4build12.1.1-4build22.1.1-4ubuntu0.16.04.12.1.1-4ubuntu0.16.04.2
2.1.1-4ubuntu0.16.04.3
gd
openSUSE:Tumbleweed
before 2.2.3-2.1
2.2.3-2.1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 37 moreShow less
MoveEnter Open