Every CVE Search/ Get API key

CVE-2016-6175

Eval injection vulnerability in php-gettext 1.0.12 and earlier allows remote attackers to execute...

9.8 CriticalPublic exploitFix available

CVE-2016-6175 is a critical vulnerability (CVSS 9.8) in Php-gettext Project Php-gettext, published February 7, 2017. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 19.7%, the 97th percentile. Fixed in php-gettext 1.0.12-1.

Eval injection vulnerability in php-gettext 1.0.12 and earlier allows remote attackers to execute arbitrary PHP code via a crafted plural forms header.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

19.7%Up 11.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

Eval injection vulnerability in php-gettext 1.0.12 and earlier allows remote attackers to execute arbitrary PHP code via a crafted plural forms header.

Record
CVE-2016-6175
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-94
Updated
2026-11-02
CVE List No score

Eval injection vulnerability in php-gettext 1.0.12 and earlier allows remote attackers to execute arbitrary PHP code via a crafted plural forms header.

Record
CVE-2016-6175
Updated
2026-11-02
EUVDEUVD-2016-7109 No score

Eval injection vulnerability in php-gettext 1.0.12 and earlier allows remote attackers to execute arbitrary PHP code via a crafted plural forms header.

Record
EUVD-2016-7109
Updated
2026-11-03
GitHub AdvisoriesGHSA-6f39-vhv8-5hcw 9.8

Eval injection vulnerability in php-gettext 1.0.12 and earlier allows remote attackers to execute...

Eval injection vulnerability in php-gettext 1.0.12 and earlier allows remote attackers to execute arbitrary PHP code via a crafted plural forms header.

Record
GHSA-6f39-vhv8-5hcw
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-94
Updated
2026-11-02
OSV 9.8

Eval injection vulnerability in php-gettext 1.0.12 and earlier allows remote attackers to execute arbitrary PHP code via a crafted plural forms header.

Record
CVE-2016-6175
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-6175 9.8

Eval injection vulnerability in php-gettext 1.0.12 and earlier allows remote attackers to execute arbitrary PHP code via a crafted plural forms header.

Record
DEBIAN-CVE-2016-6175
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-6175 9.8

Eval injection vulnerability in php-gettext 1.0.12 and earlier allows remote attackers to execute arbitrary PHP code via a crafted plural forms header.

Record
UBUNTU-CVE-2016-6175
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
php-gettext
Debian:12
before 1.0.12-1
1.0.12-1
php-gettext
Debian:14
before 1.0.12-1, plus listed versions
1.0.10-11.0.11-11.0.11-21.0.11-31.0.11-4
Show 11 moreShow less
1.0.12-0.11.0.7-11.0.7-21.0.7-31.0.7-41.0.7-51.0.7-61.0.7-71.0.7-81.0.9-11.0.9-2
1.0.12-1
php-gettext
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
1.0.11-11.0.11-1ubuntu0.1~esm1
None known
php-gettext
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
1.0.11-11.0.11-21.0.11-2build11.0.11-2ubuntu0.1~esm1
None known
php-gettext
Ubuntu:18.04:LTS
All versions, plus listed versions
1.0.12-0.1
None known

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBPHP gettext 1.0.12 - 'gettext.php' Code Execution2016-07-25

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

References

MoveEnter Open