Every CVE Search/ Get API key

CVE-2016-6331

ApiParse in MediaWiki before 1.23.15, 1.26.x before 1.26.4, and 1.27.x before 1.27.1 allows...

7.5 HighFix available

CVE-2016-6331 is a high vulnerability (CVSS 7.5) in Mediawiki, published September 16, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.13%, the 81st percentile. Fixed in mediawiki 1:1.27.1-1.

ApiParse in MediaWiki before 1.23.15, 1.26.x before 1.26.4, and 1.27.x before 1.27.1 allows remote attackers to bypass intended per-title read restrictions via a parse action to api.php.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

2.13%Up 1.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

ApiParse in MediaWiki before 1.23.15, 1.26.x before 1.26.4, and 1.27.x before 1.27.1 allows remote attackers to bypass intended per-title read restrictions via a parse action to api.php.

Record
CVE-2016-6331
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-284
Updated
2026-11-02
CVE List No score

ApiParse in MediaWiki before 1.23.15, 1.26.x before 1.26.4, and 1.27.x before 1.27.1 allows remote attackers to bypass intended per-title read restrictions via a parse action to api.php.

Record
CVE-2016-6331
Updated
2026-11-02
EUVDEUVD-2016-7258 No score

ApiParse in MediaWiki before 1.23.15, 1.26.x before 1.26.4, and 1.27.x before 1.27.1 allows remote attackers to bypass intended per-title read restrictions via a parse action to api.php.

Record
EUVD-2016-7258
Updated
2026-11-03
GitHub AdvisoriesGHSA-fp5m-f325-vm83 7.5

ApiParse in MediaWiki before 1.23.15, 1.26.x before 1.26.4, and 1.27.x before 1.27.1 allows...

ApiParse in MediaWiki before 1.23.15, 1.26.x before 1.26.4, and 1.27.x before 1.27.1 allows remote attackers to bypass intended per-title read restrictions via a parse action to api.php.

Record
GHSA-fp5m-f325-vm83
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-284
Updated
2026-11-02
OSV 7.5

ApiParse in MediaWiki before 1.23.15, 1.26.x before 1.26.4, and 1.27.x before 1.27.1 allows remote attackers to bypass intended per-title read restrictions via a parse action to api.php.

Record
CVE-2016-6331
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2016-6331 7.5

ApiParse in MediaWiki before 1.23.15, 1.26.x before 1.26.4, and 1.27.x before 1.27.1 allows remote attackers to bypass intended per-title read restrictions via a parse action to api.php.

Record
DEBIAN-CVE-2016-6331
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVMGASA-2016-0305 No score

Updated mediawiki packages fix security vulnerability

Check read permission when loading page content in ApiParse (CVE-2016-6331)

Make blocks log users out if $wgBlockDisablesLogin is true (CVE-2016-6332)

Make $wgBlockDisablesLogin also restrict logged in permissions (CVE-2016-6332)

Require login to preview user CSS pages (CVE-2016-6333)

Escape '<' and ']]>' in inline <style> blocks (CVE-2016-6333)

XSS in unclosed internal links (CVE-2016-6334)

API: Generate head items in the context of the given title (CVE-2016-6335)

Do not allow undeleting a revision deleted file if it is the top file (CVE-2016-6336)

The mediawiki package has been updated to version 1.23.15, which contains the above fixes.

Record
MGASA-2016-0305
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mediawiki
Debian:12
before 1:1.27.1-1
1:1.27.1-1
mediawiki
Debian:13
before 1:1.27.1-1
1:1.27.1-1
mediawiki
Debian:14
before 1:1.27.1-1
1:1.27.1-1
mediawiki
Mageia:5
before 1.23.15-1.mga5
1.23.15-1.mga5

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

MoveEnter Open