CVE-2016-6348
JacksonJsonpInterceptor susceptible to cross-site script inclusion (XSSI) attack
CVE-2016-6348 is a medium vulnerability (CVSS 6.1) in Redhat Resteasy, published April 12, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.57%, the 75th percentile. Fixed in org.jboss.resteasy:resteasy-client 3.0.20.Final.
JacksonJsonpInterceptor in RESTEasy might allow remote attackers to conduct a cross-site script inclusion (XSSI) attack.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
JacksonJsonpInterceptor in RESTEasy might allow remote attackers to conduct a cross-site script inclusion (XSSI) attack.
- Record
CVE-2016-6348- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
JacksonJsonpInterceptor in RESTEasy might allow remote attackers to conduct a cross-site script inclusion (XSSI) attack.
- Record
CVE-2016-6348- Updated
- 2026-11-02
EUVDEUVD-2022-3464 No score
JacksonJsonpInterceptor in RESTEasy might allow remote attackers to conduct a cross-site script inclusion (XSSI) attack.
- Record
EUVD-2022-3464- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-9xfc-j5mf-9w5p
6.1
JacksonJsonpInterceptor susceptible to cross-site script inclusion (XSSI) attack
JacksonJsonpInterceptor in RESTEasy might allow remote attackers to conduct a cross-site script inclusion (XSSI) attack.
- Record
GHSA-9xfc-j5mf-9w5p- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
JacksonJsonpInterceptor in RESTEasy might allow remote attackers to conduct a cross-site script inclusion (XSSI) attack.
- Record
CVE-2016-6348- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-6348
6.1
JacksonJsonpInterceptor in RESTEasy might allow remote attackers to conduct a cross-site script inclusion (XSSI) attack.
- Record
DEBIAN-CVE-2016-6348- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-9xfc-j5mf-9w5p
6.1
JacksonJsonpInterceptor susceptible to cross-site script inclusion (XSSI) attack
JacksonJsonpInterceptor in RESTEasy might allow remote attackers to conduct a cross-site script inclusion (XSSI) attack.
- Record
GHSA-9xfc-j5mf-9w5p- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-6348
6.1
JacksonJsonpInterceptor in RESTEasy might allow remote attackers to conduct a cross-site script inclusion (XSSI) attack.
- Record
UBUNTU-CVE-2016-6348- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVUSN-7630-1 No score
resteasy, resteasy3.0 vulnerabilities
It was discovered that RESTEasy made insufficient use of random values in asynchronous jobs. An attacker could possibly use this issue to steal user data. This issue only affected Ubuntu 16.04 LTS. (CVE-2016-6345)
It was discovered that RESTEasy enabled a vulnerable GZIP decompression module by default. An attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 16.04 LTS. (CVE-2016-6346)
It was discovered that RESTEasy improperly made use of unsanitized data while handling certain errors. An attacker could possibly use this issue to cause a denial of service or execute arbitrary code. This issue only affected Ubuntu 16.04 LTS. (CVE-2016-6347)
It was discovered that RESTEasy enabled a vulnerable JSON manipulation module by default. An attacker could possibly use this issue to cause a denial of service or execute arbitrary code. This issue only affected Ubuntu 16.04 LTS. (CVE-2016-6348)
It was discovered that RESTEasy enabled a vulnerable deserialization module by default. An attacker could possibly use this issue to cause a denial of service or execute arbitrary code. This issue only affected Ubuntu 16.04 LTS. (CVE-2016-7050)
Nikos Papadopoulos discovered that RESTEasy improperly handled URL encoding when certain errors occur. An attacker could possibly use this issue to modify the app's behavior for other users throughout the network. This issue did not affect resteasy3.0 in Ubuntu 24.04 LTS, Ubuntu 24.10, and Ubuntu 25.04. (CVE-2020-10688)
Mirko Selber discovered that RESTEasy improperly validated user input during HTTP response construction. An attacker could possibly use this issue to to cause a denial of service or execute arbitrary code. This issue did not affect resteasy3.0 in Ubuntu 22.04 LTS, Ubuntu 24.04 LTS, Ubuntu 24.10, and Ubuntu 25.04. (CVE-2020-1695)
It was discovered that RESTEasy improperly handled receiving the WebApplicationException during a client call. An attacker could possibly use this issue to obtain potentially sensitive server information. (CVE-2020-25633)
It was discovered that RESTEasy improperly populated exception responses with endpoint class and method names. An attacker could possibly use this issue to obtain potentially sensitive server information. (CVE-2021-20289)
It was discovered that RESTEasy used improper permissions when creating temporary files. An attacker could possibly use this issue to get access to sensitive data. (CVE-2023-0482)
It was discovered that RESTEasy improperly handled certain HTTP requests containing ASCII control characters. An attacker could possibly use this issue to cause a denial of service. (CVE-2024-9622)
- Record
USN-7630-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.jboss.resteasy:resteasy-clientMaven |
before 3.0.20.Final | 3.0.20.Final |
resteasy3.0Debian:12 |
before 3.0.26-1 | 3.0.26-1 |
resteasy3.0Debian:13 |
before 3.0.26-1 | 3.0.26-1 |
resteasy3.0Debian:14 |
before 3.0.26-1 | 3.0.26-1 |
org.jboss.resteasy:resteasy-clientMaven |
before 3.0.20.Final, plus listed versions 1.0-beta-61.0-beta-71.0-beta-83.0-beta-13.0-beta-2 Show 25 moreShow less3.0-beta-33.0-beta-43.0-beta-53.0-beta-63.0-rc-13.0.0.Final3.0.1.Final3.0.10.Final3.0.11.Final3.0.12.Final3.0.13.Final3.0.14.Final3.0.15.Final3.0.16.Final3.0.17.Final3.0.18.Final3.0.19.Final3.0.2.Final3.0.3.Final3.0.4.Final3.0.5.Final3.0.6.Final3.0.7.Final3.0.8.Final3.0.9.Final |
3.0.20.Final |
resteasyUbuntu:Pro:16.04:LTS |
before 3.0.6-3ubuntu0.1~esm1, plus listed versions 3.0.6-3 |
3.0.6-3ubuntu0.1~esm1 |
resteasy3.0Ubuntu:Pro:18.04:LTS |
before 3.0.26-1~18.04.1~esm1, plus listed versions 3.0.19-13.0.19-23.0.26-1~18.04 |
3.0.26-1~18.04.1~esm1 |
resteasy3.0Ubuntu:Pro:20.04:LTS |
before 3.0.26-1ubuntu0.1~esm1, plus listed versions 3.0.26-1 |
3.0.26-1ubuntu0.1~esm1 |
resteasy3.0Ubuntu:22.04:LTS |
before 3.0.26-3ubuntu0.1, plus listed versions 3.0.26-23.0.26-3 |
3.0.26-3ubuntu0.1 |
resteasy3.0Ubuntu:24.04:LTS |
before 3.0.26-6ubuntu0.24.04.1, plus listed versions 3.0.26-6 |
3.0.26-6ubuntu0.24.04.1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
bugzilla.redhat.com/show_bug.cgi?id=1372129
nvd.nist.gov/vuln/detail/CVE-2016-6348
github.com/advisories/GHSA-9xfc-j5mf-9w5p
security-tracker.debian.org/tracker/CVE-2016-6348
github.com/resteasy/Resteasy
ubuntu.com/security/CVE-2016-6348
Show 12 moreShow less
cve.org/CVERecord?id=CVE-2016-6348
ubuntu.com/security/notices/USN-7630-1
ubuntu.com/security/CVE-2016-6345
ubuntu.com/security/CVE-2016-6346
ubuntu.com/security/CVE-2016-6347
ubuntu.com/security/CVE-2016-7050
ubuntu.com/security/CVE-2020-1695
ubuntu.com/security/CVE-2020-10688
ubuntu.com/security/CVE-2020-25633
ubuntu.com/security/CVE-2021-20289
ubuntu.com/security/CVE-2023-0482
ubuntu.com/security/CVE-2024-9622