CVE-2016-6902
lshell 0.9.16 allows remote authenticated users to break out of a limited shell and execute...
CVE-2016-6902 is a critical vulnerability (CVSS 9.9) in Lshell Project Lshell, published April 24, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.47%, the 92nd percentile. Fixed in python-lshell 0.9.18-2.mga5.
lshell 0.9.16 allows remote authenticated users to break out of a limited shell and execute arbitrary commands.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.9
lshell 0.9.16 allows remote authenticated users to break out of a limited shell and execute arbitrary commands.
- Record
CVE-2016-6902- CVSS 3.0
- 9.9 Critical
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H - CVSS 2.0
- 9.0 High
AV:N/AC:L/Au:S/C:C/I:C/A:C - Weakness
- CWE-264
- Updated
- 2026-11-02
CVE List No score
lshell 0.9.16 allows remote authenticated users to break out of a limited shell and execute arbitrary commands.
- Record
CVE-2016-6902- Updated
- 2026-11-02
EUVDEUVD-2016-7787 No score
lshell 0.9.16 allows remote authenticated users to break out of a limited shell and execute arbitrary commands.
- Record
EUVD-2016-7787- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-f3r7-j2g2-9mjw
9.9
lshell 0.9.16 allows remote authenticated users to break out of a limited shell and execute...
lshell 0.9.16 allows remote authenticated users to break out of a limited shell and execute arbitrary commands.
- Record
GHSA-f3r7-j2g2-9mjw- CVSS 3.0
- 9.9 Critical
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
OSV
9.9
lshell 0.9.16 allows remote authenticated users to break out of a limited shell and execute arbitrary commands.
- Record
CVE-2016-6902- CVSS 3.0
- 9.9 Critical
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
OSVPYSEC-2017-153
9.9
lshell 0.9.16 allows remote authenticated users to break out of a limited shell and execute arbitrary commands.
- Record
PYSEC-2017-153- CVSS 3.0
- 9.9 Critical
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-6902
9.9
lshell 0.9.16 allows remote authenticated users to break out of a limited shell and execute arbitrary commands.
- Record
UBUNTU-CVE-2016-6902- CVSS 3.0
- 9.9 Critical
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2017-0126 No score
Updated python-lshell package fixes security vulnerabilities
Shell outbreak due to bad syntax parse (CVE-2016-6902). Shell outbreak with multiline commands (CVE-2016-6903).
- Record
MGASA-2017-0126- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
python-lshellMageia:5 |
before 0.9.18-2.mga5 | 0.9.18-2.mga5 |
limited-shellPyPI |
through 0.9.16 | None known |
lshellUbuntu:16.04:LTS |
All versions, plus listed versions 0.9.17-1 |
None known |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |