Every CVE Search/ Get API key

CVE-2016-7138

Plone XSS

6.1 MediumFix available

Cross-site scripting (XSS) vulnerability in the URL checking infrastructure in Plone CMS 5.x through 5.0.6, 4.x through 4.3.11, and 3.3.x through 3.3.6 allows remote attackers to inject arbitrary web script or HTML via a crafted URL.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.59%Up 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.1

Cross-site scripting (XSS) vulnerability in the URL checking infrastructure in Plone CMS 5.x through 5.0.6, 4.x through 4.3.11, and 3.3.x through 3.3.6 allows remote attackers to inject arbitrary web script or HTML via a crafted URL.

Record
CVE-2016-7138
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in the URL checking infrastructure in Plone CMS 5.x through 5.0.6, 4.x through 4.3.11, and 3.3.x through 3.3.6 allows remote attackers to inject arbitrary web script or HTML via a crafted URL.

Record
CVE-2016-7138
Updated
2026-11-02
EUVDEUVD-2017-0094 No score

Cross-site scripting (XSS) vulnerability in the URL checking infrastructure in Plone CMS 5.x through 5.0.6, 4.x through 4.3.11, and 3.3.x through 3.3.6 allows remote attackers to inject arbitrary web script or HTML via a crafted URL.

Record
EUVD-2017-0094
Updated
2026-11-03
GitHub AdvisoriesGHSA-v3hp-f8qr-cf3p 5.3

Plone XSS

Cross-site scripting (XSS) vulnerability in the URL checking infrastructure in Plone CMS 5.x through 5.0.6, 4.x through 4.3.11, and 3.3.x through 3.3.6 allows remote attackers to inject arbitrary web script or HTML via a crafted URL.

Record
GHSA-v3hp-f8qr-cf3p
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

Cross-site scripting (XSS) vulnerability in the URL checking infrastructure in Plone CMS 5.x through 5.0.6, 4.x through 4.3.11, and 3.3.x through 3.3.6 allows remote attackers to inject arbitrary web script or HTML via a crafted URL.

Record
CVE-2016-7138
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-v3hp-f8qr-cf3p 5.3

Plone XSS

Cross-site scripting (XSS) vulnerability in the URL checking infrastructure in Plone CMS 5.x through 5.0.6, 4.x through 4.3.11, and 3.3.x through 3.3.6 allows remote attackers to inject arbitrary web script or HTML via a crafted URL.

Record
GHSA-v3hp-f8qr-cf3p
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVPYSEC-2017-61 No score

Cross-site scripting (XSS) vulnerability in the URL checking infrastructure in Plone CMS 5.x through 5.0.6, 4.x through 4.3.11, and 3.3.x through 3.3.6 allows remote attackers to inject arbitrary web script or HTML via a crafted URL.

Record
PYSEC-2017-61
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
plone
PyPI
5.0.0 to 5.0.6 None known
plone
PyPI
4.0.0 to 4.3.11 None known
plone
PyPI
3.3.0 to 3.3.6 None known
plone
PyPI
5.0.0 to 5.0.6, plus listed versions
5.05.0.15.0.25.0.35.0.45.0.5
None known
plone
PyPI
4.0.0 to 4.3.11, plus listed versions
4.04.0.14.0.104.0.24.0.3
Show 45 moreShow less
4.0.44.0.54.0.64.0.74.0.84.0.94.14.1.14.1.24.1.34.1.44.1.54.1.64.1a14.1a24.1a34.1b14.1b24.1rc24.1rc34.24.2.14.2.24.2.34.2.44.2.54.2.64.2.74.2a14.2a24.2b14.2b24.2rc14.2rc24.34.3.14.3.104.3.24.3.34.3.44.3.54.3.64.3.74.3.84.3.9
None known
plone
PyPI
3.3.0 to 3.3.6, plus listed versions
3.33.3.13.3.23.3.33.3.43.3.5
None known
plone
PyPI
5.0 up to 5.0.7, 4.0 up to 4.3.12, 3.3 up to 4.0a1, plus listed versions
3.3.13.3.23.3.33.3.43.3.5
Show 45 moreShow less
3.3.64.0.14.0.104.0.24.0.34.0.44.0.54.0.64.0.74.0.84.0.94.14.1.14.1.24.1.34.1.44.1.54.1.64.1a14.1a24.1a34.1b14.1b24.1rc24.1rc34.24.2.14.2.24.2.34.2.44.2.54.2.64.2.74.2a14.2a24.2b14.2b24.2rc14.2rc24.34.3.14.3.104.3.114.3.24.3.3
5.0.74.3.124.0a1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-7138 is a medium vulnerability (CVSS 6.1) in Plone, published March 7, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.59%, the 75th percentile. Fixed in plone 5.0.7.

References

Show 7 moreShow less
This page doesn't list everything

Left out here: 22 versions. The JSON record has them.

MoveEnter Open