CVE-2016-7785
The avi_read_seek function in libavformat/avidec.c in FFmpeg before 3.1.4 allows remote attackers...
CVE-2016-7785 is a medium vulnerability (CVSS 5.5) in Ffmpeg, published October 18, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.30%, the 70th percentile. Fixed in ffmpeg 2.8.11-r0.
The avi_read_seek function in libavformat/avidec.c in FFmpeg before 3.1.4 allows remote attackers to cause a denial of service (assert fault) via a crafted AVI file.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
5.5
The avi_read_seek function in libavformat/avidec.c in FFmpeg before 3.1.4 allows remote attackers to cause a denial of service (assert fault) via a crafted AVI file.
- Record
CVE-2016-7785- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
The avi_read_seek function in libavformat/avidec.c in FFmpeg before 3.1.4 allows remote attackers to cause a denial of service (assert fault) via a crafted AVI file.
- Record
CVE-2016-7785- Updated
- 2026-11-02
EUVDEUVD-2016-8635 No score
The avi_read_seek function in libavformat/avidec.c in FFmpeg before 3.1.4 allows remote attackers to cause a denial of service (assert fault) via a crafted AVI file.
- Record
EUVD-2016-8635- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-rx33-q8gm-pjjw
5.5
The avi_read_seek function in libavformat/avidec.c in FFmpeg before 3.1.4 allows remote attackers...
The avi_read_seek function in libavformat/avidec.c in FFmpeg before 3.1.4 allows remote attackers to cause a denial of service (assert fault) via a crafted AVI file.
- Record
GHSA-rx33-q8gm-pjjw- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSVALPINE-CVE-2016-7785
5.5
The avi_read_seek function in libavformat/avidec.c in FFmpeg before 3.1.4 allows remote attackers to cause a denial of service (assert fault) via a crafted AVI file.
- Record
ALPINE-CVE-2016-7785- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSV
5.5
The avi_read_seek function in libavformat/avidec.c in FFmpeg before 3.1.4 allows remote attackers to cause a denial of service (assert fault) via a crafted AVI file.
- Record
CVE-2016-7785- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Show 5 moreShow less
OSVDEBIAN-CVE-2016-7785
5.5
The avi_read_seek function in libavformat/avidec.c in FFmpeg before 3.1.4 allows remote attackers to cause a denial of service (assert fault) via a crafted AVI file.
- Record
DEBIAN-CVE-2016-7785- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-7785
5.5
The avi_read_seek function in libavformat/avidec.c in FFmpeg before 3.1.4 allows remote attackers to cause a denial of service (assert fault) via a crafted AVI file.
- Record
UBUNTU-CVE-2016-7785- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVMGASA-2018-0008 No score
Updated ffmpeg packages fix security vulnerability
This update provides ffmpeg version 2.4.14, which fixes several security vulnerabilities and other bugs which were corrected upstream.
- Record
MGASA-2018-0008- Updated
- 2026-11-02
OSVopenSUSE-SU-2016:2556-1 No score
Security update for ffmpeg
This update for ffmpeg fixes multiple security issues in ffmpeg (boo#1003806)
These vulnerabilities can be triggered when processing specially crafted avi video content, and could lead to crashes or have unspecified further impact including potential code execution.
- CVE-2016-7562: out-of-bounds array write fault via specially crafted avi files
- CVE-2016-7502: out-of-bounds array write via incorrect block values
- CVE-2016-7905: null-point-exception when decoding avi files with crafted 'gab2' structs
- CVE-2016-7555: memory leak when decoding avi files with crafted 'strh' struct
- CVE-2016-7785: assert fault via avi files with crafted 'strh' struct
- Record
openSUSE-SU-2016:2556-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2016:2560-1 No score
Security update for ffmpeg
This update for ffmpeg fixes multiple security issues in ffmpeg (boo#1003806)
These vulnerabilities can be triggered when processing specially crafted avi video content, and could lead to crashes or have unspecified further impact including potential code execution.
- CVE-2016-7562: out-of-bounds array write fault via specially crafted avi files
- CVE-2016-7502: out-of-bounds array write via incorrect block values
- CVE-2016-7905: null-point-exception when decoding avi files with crafted 'gab2' structs
- CVE-2016-7555: memory leak when decoding avi files with crafted 'strh' struct
- CVE-2016-7785: assert fault via avi files with crafted 'strh' struct
- Record
openSUSE-SU-2016:2560-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ffmpegAlpine:v3.3 |
before 2.8.11-r0 | 2.8.11-r0 |
ffmpegAlpine:v3.4 |
before 3.0.7-r0 | 3.0.7-r0 |
ffmpegDebian:12 |
before 7:3.1.4-1 | 7:3.1.4-1 |
ffmpegDebian:13 |
before 7:3.1.4-1 | 7:3.1.4-1 |
ffmpegDebian:14 |
before 7:3.1.4-1 | 7:3.1.4-1 |
ffmpegMageia:5 |
before 2.4.14-1.mga5 | 2.4.14-1.mga5 |
ffmpegMageia:5 |
before 2.4.14-1.mga5.tainted | 2.4.14-1.mga5.tainted |
ffmpegUbuntu:16.04:LTS |
before 7:2.8.10-0ubuntu0.16.04.1, plus listed versions 7:2.7.2-1build17:2.8.1-1ubuntu17:2.8.2-1ubuntu17:2.8.3-17:2.8.4-1 Show 7 moreShow less7:2.8.4-1ubuntu17:2.8.4-1ubuntu27:2.8.4-1ubuntu37:2.8.4-1ubuntu47:2.8.6-1ubuntu17:2.8.6-1ubuntu27:2.8.8-0ubuntu0.16.04.1 |
7:2.8.10-0ubuntu0.16.04.1 |
ffmpegSUSE:Package Hub 12 SP1 |
before 2.8.8-6.1 | 2.8.8-6.1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
openwall.com/lists/oss-security/2016/10/08/1
security.gentoo.org/glsa/201701-71
securityfocus.com/bid/94833
nvd.nist.gov/vuln/detail/CVE-2016-7785
github.com/advisories/GHSA-rx33-q8gm-pjjw
security.alpinelinux.org/vuln/CVE-2016-7785
Show 12 moreShow less
security-tracker.debian.org/tracker/CVE-2016-7785
advisories.mageia.org/MGASA-2018-0008.html
bugs.mageia.org/show_bug.cgi?id=20757
ubuntu.com/security/CVE-2016-7785
git.ffmpeg.org/gitweb/ffmpeg.git/commit/c8c5f66b42edc37474baa5cb51460cbf6f33075b
cve.org/CVERecord?id=CVE-2016-7785
bugzilla.suse.com/1003806
suse.com/security/cve/CVE-2016-7502
suse.com/security/cve/CVE-2016-7555
suse.com/security/cve/CVE-2016-7562
suse.com/security/cve/CVE-2016-7785
suse.com/security/cve/CVE-2016-7905