Every CVE Search/ Get API key

CVE-2016-7787

A maliciously crafted command line for kdesu can result in the user only seeing part of the...

4.9 MediumFix available

CVE-2016-7787 is a medium vulnerability (CVSS 4.9) in Kde Kde-cli-tools, published October 11, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.66%, the 76th percentile. Fixed in kde-cli-tools 4:5.8.0-1.

A maliciously crafted command line for kdesu can result in the user only seeing part of the commands that will actually get executed as super user.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
High
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

1.66%Up 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.9

A maliciously crafted command line for kdesu can result in the user only seeing part of the commands that will actually get executed as super user.

Record
CVE-2016-7787
CVSS 3.0
4.9 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:N/I:P/A:N
Weakness
CWE-94
Updated
2026-11-02
CVE List No score

A maliciously crafted command line for kdesu can result in the user only seeing part of the commands that will actually get executed as super user.

Record
CVE-2016-7787
Updated
2026-11-02
EUVDEUVD-2016-8637 No score

A maliciously crafted command line for kdesu can result in the user only seeing part of the commands that will actually get executed as super user.

Record
EUVD-2016-8637
Updated
2026-11-03
GitHub AdvisoriesGHSA-2rvv-92pm-m5p9 4.9

A maliciously crafted command line for kdesu can result in the user only seeing part of the...

A maliciously crafted command line for kdesu can result in the user only seeing part of the commands that will actually get executed as super user.

Record
GHSA-2rvv-92pm-m5p9
CVSS 3.0
4.9 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-94
Updated
2026-11-02
OSV 4.9

A maliciously crafted command line for kdesu can result in the user only seeing part of the commands that will actually get executed as super user.

Record
CVE-2016-7787
CVSS 3.0
4.9 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2016-7787 4.9

A maliciously crafted command line for kdesu can result in the user only seeing part of the commands that will actually get executed as super user.

Record
DEBIAN-CVE-2016-7787
CVSS 3.0
4.9 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2016-7787 4.9

A maliciously crafted command line for kdesu can result in the user only seeing part of the commands that will actually get executed as super user.

Record
UBUNTU-CVE-2016-7787
CVSS 3.0
4.9 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVMGASA-2017-0473 No score

Updated kdebase4-runtime packages fix security vulnerability

A user could sneak an unicode string terminator in the kdesu invocation, which could hide the fact that more commands could be executed (CVE-2016-7787).

Record
MGASA-2017-0473
Updated
2026-11-02
OSVopenSUSE-SU-2016:2495-1 No score

Security update for kde-cli-tools5

This update for kde-cli-tools5 fixes the following vulnerability:

  • CVE-2016-7787: user could sneak an unicode string terminator in the kdesu invocation (boo#1001916)
Record
openSUSE-SU-2016:2495-1
Updated
2026-11-02
OSVopenSUSE-SU-2016:2498-1 No score

Security update for kde-cli-tools5

This update for kde-cli-tools5 fixes the following vulnerability:

  • CVE-2016-7787: user could sneak an unicode string terminator in the kdesu invocation (boo#1001916)
Record
openSUSE-SU-2016:2498-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
kde-cli-tools
Debian:12
before 4:5.8.0-1
4:5.8.0-1
kde-cli-tools
Debian:13
before 4:5.8.0-1
4:5.8.0-1
kde-cli-tools
Debian:14
before 4:5.8.0-1
4:5.8.0-1
kdebase4-runtime
Mageia:5
before 4.14.3-5.1.mga5
4.14.3-5.1.mga5
kde-cli-tools
Ubuntu:16.04:LTS
before 4:5.5.5-0ubuntu1.1, plus listed versions
4:5.4.2-0ubuntu14:5.4.3-0ubuntu14:5.5.4-0ubuntu14:5.5.5-0ubuntu1
4:5.5.5-0ubuntu1.1
kde-cli-tools5
SUSE:Package Hub 12 SP1
before 5.5.5-12.1
5.5.5-12.1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 8 moreShow less
MoveEnter Open