CVE-2016-7837
Buffer overflow in BlueZ 5.41 and earlier allows an attacker to execute arbitrary code via the...
Buffer overflow in BlueZ 5.41 and earlier allows an attacker to execute arbitrary code via the parse_line function used in some userland utilities.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
Buffer overflow in BlueZ 5.41 and earlier allows an attacker to execute arbitrary code via the parse_line function used in some userland utilities.
- Record
CVE-2016-7837- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 4.6 Medium
AV:L/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
Buffer overflow in BlueZ 5.41 and earlier allows an attacker to execute arbitrary code via the parse_line function used in some userland utilities.
- Record
CVE-2016-7837- Updated
- 2026-11-02
EUVDEUVD-2016-8686 No score
Buffer overflow in BlueZ 5.41 and earlier allows an attacker to execute arbitrary code via the parse_line function used in some userland utilities.
- Record
EUVD-2016-8686- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-rqrx-f2rh-m32q
7.8
Buffer overflow in BlueZ 5.41 and earlier allows an attacker to execute arbitrary code via the...
Buffer overflow in BlueZ 5.41 and earlier allows an attacker to execute arbitrary code via the parse_line function used in some userland utilities.
- Record
GHSA-rqrx-f2rh-m32q- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSV
7.8
Buffer overflow in BlueZ 5.41 and earlier allows an attacker to execute arbitrary code via the parse_line function used in some userland utilities.
- Record
CVE-2016-7837- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-7837
7.8
Buffer overflow in BlueZ 5.41 and earlier allows an attacker to execute arbitrary code via the parse_line function used in some userland utilities.
- Record
DEBIAN-CVE-2016-7837- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 5 moreShow less
OSVUBUNTU-CVE-2016-7837
7.8
Buffer overflow in BlueZ 5.41 and earlier allows an attacker to execute arbitrary code via the parse_line function used in some userland utilities.
- Record
UBUNTU-CVE-2016-7837- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2017-0414 No score
Updated bluez packages fix security vulnerability
Buffer overflow in parse_line function in the csr tool (CVE-2016-7837).
- Record
MGASA-2017-0414- Updated
- 2026-11-02
OSVSUSE-SU-2018:1778-1 No score
Security update for bluez
This update for bluez fixes the following issues:
Security issues fixed:
- CVE-2016-9800: Fix hcidump memory leak in pin_code_reply_dump() (bsc#1013721).
- CVE-2016-9804: Fix hcidump buffer overflow in commands_dump() (bsc#1013877).
- CVE-2016-7837: Fix possible buffer overflow, make sure we don't write past the end of the array (bsc#1026652).
- CVE-2017-1000250: Fix information disclosure vulnerability in service_search_attr_req (bsc#1057342).
- Record
SUSE-SU-2018:1778-1- Updated
- 2026-11-02
OSVSUSE-SU-2019:0510-1 No score
Security update for bluez
This update for bluez fixes the following issues:
Security issues fixed:
- CVE-2016-7837: Fixed possible buffer overflow, make sure we don't write past the end of the array.(bsc#1026652)
- CVE-2016-9800: Fix hcidump memory leak in pin_code_reply_dump() (bsc#1013721).
- CVE-2016-9801: Fixed a buffer overflow in set_ext_ctrl function (bsc#1013732)
- CVE-2016-9804: Fix hcidump buffer overflow in commands_dump() (bsc#1013877).
- CVE-2016-9918: Fixed an out-of-bounds read in packet_hexdump() (bsc#1015173)
- CVE-2017-1000250: Fixed a information leak in SDP (part of the recently published BlueBorne vulnerabilities) (bsc#1057342)
- Record
SUSE-SU-2019:0510-1- Updated
- 2026-11-02
OSVUSN-4311-1 No score
bluez vulnerabilities
It was discovered that BlueZ incorrectly handled bonding HID and HOGP devices. A local attacker could possibly use this issue to impersonate non-bonded devices. (CVE-2020-0556)
It was discovered that BlueZ incorrectly handled certain commands. A local attacker could use this issue to cause BlueZ to crash, resulting in a denial of service, or possibly execute arbitrary code. This issue only affected Ubuntu 16.04 LTS. (CVE-2016-7837)
- Record
USN-4311-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
bluezDebian:12 |
before 5.43-1 | 5.43-1 |
bluezDebian:13 |
before 5.43-1 | 5.43-1 |
bluezDebian:14 |
before 5.43-1 | 5.43-1 |
bluezMageia:5 |
before 5.28-1.2.mga5 | 5.28-1.2.mga5 |
bluezSUSE:Linux Enterprise Desktop 12 SP3 |
before 5.13-5.4.1 | 5.13-5.4.1 |
bluezSUSE:Linux Enterprise Software Development Kit 12 SP3 |
before 5.13-5.4.1 | 5.13-5.4.1 |
bluezSUSE:Linux Enterprise Server 12 SP3 |
before 5.13-5.4.1 | 5.13-5.4.1 |
bluezSUSE:Linux Enterprise Server for SAP Applications 12 SP3 |
before 5.13-5.4.1 | 5.13-5.4.1 |
bluezSUSE:Linux Enterprise Workstation Extension 12 SP3 |
before 5.13-5.4.1 | 5.13-5.4.1 |
bluezSUSE:Linux Enterprise Server for SAP Applications 12 SP1 |
before 5.13-3.10.1 | 5.13-3.10.1 |
Show 5 moreShow less
| Package | Affected | Fixed |
|---|---|---|
bluezSUSE:Linux Enterprise Server 12-LTSS |
before 5.13-3.10.1 | 5.13-3.10.1 |
bluezSUSE:Linux Enterprise Server 12 SP1-LTSS |
before 5.13-3.10.1 | 5.13-3.10.1 |
bluezUbuntu:14.04:LTS |
before 4.101-0ubuntu13.3, plus listed versions 4.101-0ubuntu8b14.101-0ubuntu94.101-0ubuntu104.101-0ubuntu114.101-0ubuntu124.101-0ubuntu134.101-0ubuntu13.1 |
4.101-0ubuntu13.3 |
bluezUbuntu:16.04:LTS |
before 5.37-0ubuntu5.3, plus listed versions 5.35-0ubuntu25.36-0ubuntu15.37-0ubuntu55.37-0ubuntu5.1 |
5.37-0ubuntu5.3 |
bluezUbuntu:18.04:LTS |
before 5.48-0ubuntu3.4, plus listed versions 5.46-0ubuntu35.46-0ubuntu45.48-0ubuntu35.48-0ubuntu3.15.48-0ubuntu3.25.48-0ubuntu3.3 |
5.48-0ubuntu3.4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-7837 is a high vulnerability (CVSS 7.8) in Bluez, published June 9, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.56%, the 46th percentile. Fixed in bluez 5.43-1.
References
jvn.jp/en/jp/JVN38755305/index.html
git.kernel.org/pub/scm/bluetooth/bluez.git/commit?id=8514068150759c1d6a46d4605d2351babfde1601
securityfocus.com/bid/95067
usn.ubuntu.com/4311-1
nvd.nist.gov/vuln/detail/CVE-2016-7837
github.com/advisories/GHSA-rqrx-f2rh-m32q
Show 22 moreShow less
security-tracker.debian.org/tracker/CVE-2016-7837
advisories.mageia.org/MGASA-2017-0414.html
bugs.mageia.org/show_bug.cgi?id=21904
lists.opensuse.org/opensuse-updates/2017-10/msg00069.html
suse.com/support/update/announcement/2018/suse-su-20181778-1
bugzilla.suse.com/1013721
bugzilla.suse.com/1013877
bugzilla.suse.com/1026652
bugzilla.suse.com/1057342
suse.com/security/cve/CVE-2016-7837
suse.com/security/cve/CVE-2016-9800
suse.com/security/cve/CVE-2016-9804
suse.com/security/cve/CVE-2017-1000250
suse.com/support/update/announcement/2019/suse-su-20190510-1
bugzilla.suse.com/1013732
bugzilla.suse.com/1015173
suse.com/security/cve/CVE-2016-9801
suse.com/security/cve/CVE-2016-9918
ubuntu.com/security/CVE-2016-7837
ubuntu.com/security/notices/USN-4311-1
cve.org/CVERecord?id=CVE-2016-7837
ubuntu.com/security/CVE-2020-0556