Every CVE Search/ Get API key

CVE-2016-7970

Buffer overflow in the calc_coeff function in libass/ass_blur.c in libass before 0.13.4 allows...

7.5 HighFix available

CVE-2016-7970 is a high vulnerability (CVSS 7.5) in Libass Project Libass, published October 12, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.66%, the 91st percentile. Fixed in libass 0.13.4-r0.

Buffer overflow in the calc_coeff function in libass/ass_blur.c in libass before 0.13.4 allows remote attackers to cause a denial of service via unspecified vectors.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

4.66%Up 2.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Buffer overflow in the calc_coeff function in libass/ass_blur.c in libass before 0.13.4 allows remote attackers to cause a denial of service via unspecified vectors.

Record
CVE-2016-7970
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Buffer overflow in the calc_coeff function in libass/ass_blur.c in libass before 0.13.4 allows remote attackers to cause a denial of service via unspecified vectors.

Record
CVE-2016-7970
Updated
2026-11-02
EUVDEUVD-2016-8818 No score

Buffer overflow in the calc_coeff function in libass/ass_blur.c in libass before 0.13.4 allows remote attackers to cause a denial of service via unspecified vectors.

Record
EUVD-2016-8818
Updated
2026-11-03
GitHub AdvisoriesGHSA-5phf-q389-vx4x 7.5

Buffer overflow in the calc_coeff function in libass/ass_blur.c in libass before 0.13.4 allows...

Buffer overflow in the calc_coeff function in libass/ass_blur.c in libass before 0.13.4 allows remote attackers to cause a denial of service via unspecified vectors.

Record
GHSA-5phf-q389-vx4x
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-119
Updated
2026-11-02
OSVALPINE-CVE-2016-7970 7.5

Buffer overflow in the calc_coeff function in libass/ass_blur.c in libass before 0.13.4 allows remote attackers to cause a denial of service via unspecified vectors.

Record
ALPINE-CVE-2016-7970
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV 7.5

Buffer overflow in the calc_coeff function in libass/ass_blur.c in libass before 0.13.4 allows remote attackers to cause a denial of service via unspecified vectors.

Record
CVE-2016-7970
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 6 moreShow less
OSVDEBIAN-CVE-2016-7970 7.5

Buffer overflow in the calc_coeff function in libass/ass_blur.c in libass before 0.13.4 allows remote attackers to cause a denial of service via unspecified vectors.

Record
DEBIAN-CVE-2016-7970
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-7970 7.5

Buffer overflow in the calc_coeff function in libass/ass_blur.c in libass before 0.13.4 allows remote attackers to cause a denial of service via unspecified vectors.

Record
UBUNTU-CVE-2016-7970
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2016-0341 No score

Updated libass packages fixes security vulnerabilities

Amount of memory allocated during memory reallocation in the shaper wasn't tracked, possibly resulting in undefined behavior (CVE-2016-7972).

Illegal read in Gaussian blur coefficient calculations (CVE-2016-7970).

Mode 0/3 line wrapping equalization in specific cases could result in illegal reads while laying out and shaping text. (CVE-2016-7969)

The libass package has been updated to version 0.13.4, fixing this issue and several other bugs.

Record
MGASA-2016-0341
Updated
2026-11-02
OSVopenSUSE-SU-2024:10508-1 No score

libass-devel-0.13.4-2.1 on GA media

These are all security issues fixed in the libass-devel-0.13.4-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10508-1
Updated
2026-11-02
OSVSUSE-SU-2016:3107-1 No score

Security update for libass

This update for libass fixes the following issues:

CVE-2016-7969, CVE-2016-7970, CVE-2016-7971, CVE-2016-7972: Fixed multiple memory allocation issues found by fuzzing (bsc#1002982).

Record
SUSE-SU-2016:3107-1
Updated
2026-11-02
OSVUSN-4797-1 No score

libass vulnerabilities

It was discovered that LibASS incorrectly handled certain ASS files. A remote attacker could possibly use this issue to cause a denial of service. One of the issues, CVE-2016-7970, only affected Ubuntu 16.04 ESM. (CVE-2016-7969, CVE-2016-7970, CVE-2016-7972)

It was discovered that LibASS incorrectly handled parsing operations for specific nested character strings. An attacker could possibly use this issue to cause a denial of service. This issue was only fixed in Ubuntu 16.04 LTS. (CVE-2020-24994)

Record
USN-4797-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libass
Alpine:v3.10
before 0.13.4-r0
0.13.4-r0
libass
Alpine:v3.11
before 0.13.4-r0
0.13.4-r0
libass
Alpine:v3.3
before 0.13.4-r0
0.13.4-r0
libass
Alpine:v3.4
before 0.13.4-r0
0.13.4-r0
libass
Alpine:v3.5
before 0.13.4-r0
0.13.4-r0
libass
Alpine:v3.6
before 0.13.4-r0
0.13.4-r0
libass
Alpine:v3.7
before 0.13.4-r0
0.13.4-r0
libass
Alpine:v3.8
before 0.13.4-r0
0.13.4-r0
libass
Alpine:v3.9
before 0.13.4-r0
0.13.4-r0
libass
Debian:12
before 0.13.4-1
0.13.4-1
Show 15 moreShow less
Affected packages
PackageAffectedFixed
libass
Debian:13
before 0.13.4-1
0.13.4-1
libass
Debian:14
before 0.13.4-1
0.13.4-1
libass
Mageia:5
before 0.13.4-1.mga5
0.13.4-1.mga5
libass
SUSE:Linux Enterprise Desktop 12 SP1
before 0.10.2-3.1
0.10.2-3.1
libass
SUSE:Linux Enterprise Desktop 12 SP2
before 0.10.2-3.1
0.10.2-3.1
libass
SUSE:Linux Enterprise Server for Raspberry Pi 12 SP2
before 0.10.2-3.1
0.10.2-3.1
libass
SUSE:Linux Enterprise Software Development Kit 12 SP1
before 0.10.2-3.1
0.10.2-3.1
libass
SUSE:Linux Enterprise Software Development Kit 12 SP2
before 0.10.2-3.1
0.10.2-3.1
libass
SUSE:Linux Enterprise Server 12 SP1
before 0.10.2-3.1
0.10.2-3.1
libass
SUSE:Linux Enterprise Server for SAP Applications 12 SP1
before 0.10.2-3.1
0.10.2-3.1
libass
SUSE:Linux Enterprise Server 12 SP2
before 0.10.2-3.1
0.10.2-3.1
libass
SUSE:Linux Enterprise Server for SAP Applications 12 SP2
before 0.10.2-3.1
0.10.2-3.1
libass
Ubuntu:Pro:16.04:LTS
before 0.13.1-1ubuntu0.1~esm1, plus listed versions
0.12.3-20.13.0-10.13.1-1
0.13.1-1ubuntu0.1~esm1
libass
Ubuntu:Pro:14.04:LTS
before 0.10.1-3ubuntu1+esm1, plus listed versions
0.10.1-1ubuntu10.10.1-30.10.1-3ubuntu1
0.10.1-3ubuntu1+esm1
libass
Ubuntu:Pro:16.04:LTS
before 0.13.1-1ubuntu0.1~esm2, plus listed versions
0.12.3-20.13.0-10.13.1-10.13.1-1ubuntu0.1~esm1
0.13.1-1ubuntu0.1~esm2

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 25 moreShow less
MoveEnter Open