Every CVE Search/ Get API key

CVE-2016-8640

SQL Injection in pycsw

9.1 CriticalFix available

CVE-2016-8640 is a critical vulnerability (CVSS 9.1) in Https://github.com/geopython Pycsw, published August 1, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.31%, the 83rd percentile. Fixed in pycsw 1.8.6.

A SQL injection vulnerability in pycsw all versions before 2.0.2, 1.10.5 and 1.8.6 that leads to read and extract of any data from any table in the pycsw database that the database user has access to. Also on PostgreSQL (at least) it is possible to perform updates/inserts/deletes and database modifications to any table the database user has access to.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
None

Exploit likelihood

2.31%Up 1.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.1

A SQL injection vulnerability in pycsw all versions before 2.0.2, 1.10.5 and 1.8.6 that leads to read and extract of any data from any table in the pycsw database that the database user has access to. Also on PostgreSQL (at least) it is possible to perform updates/inserts/deletes and database modifications to any table the database user has access to.

Record
CVE-2016-8640
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-89
Updated
2026-11-02
CVE List No score

A SQL injection vulnerability in pycsw all versions before 2.0.2, 1.10.5 and 1.8.6 that leads to read and extract of any data from any table in the pycsw database that the database user has access to. Also on PostgreSQL (at least) it is possible to perform updates/inserts/deletes and database modifications to any table the database user has access to.

Record
CVE-2016-8640
Weakness
CWE-89
Updated
2026-11-02
EUVDEUVD-2018-0121 No score

A SQL injection vulnerability in pycsw all versions before 2.0.2, 1.10.5 and 1.8.6 that leads to read and extract of any data from any table in the pycsw database that the database user has access to. Also on PostgreSQL (at least) it is possible to perform updates/inserts/deletes and database modifications to any table the database user has access to.

Record
EUVD-2018-0121
Updated
2026-11-03
GitHub AdvisoriesGHSA-hg4c-rgvm-964g 9.3

SQL Injection in pycsw

A SQL injection vulnerability in pycsw all versions before 2.0.2, 1.10.5 and 1.8.6 that leads to read and extract of any data from any table in the pycsw database that the database user has access to. Also on PostgreSQL (at least) it is possible to perform updates/inserts/deletes and database modifications to any table the database user has access to.

Record
GHSA-hg4c-rgvm-964g
CVSS 4.0
9.3 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-89
Updated
2026-11-02
OSV 9.1

A SQL injection vulnerability in pycsw all versions before 2.0.2, 1.10.5 and 1.8.6 that leads to read and extract of any data from any table in the pycsw database that the database user has access to. Also on PostgreSQL (at least) it is possible to perform updates/inserts/deletes and database modifications to any table the database user has access to.

Record
CVE-2016-8640
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2016-8640 9.1

A SQL injection vulnerability in pycsw all versions before 2.0.2, 1.10.5 and 1.8.6 that leads to read and extract of any data from any table in the pycsw database that the database user has access to. Also on PostgreSQL (at least) it is possible to perform updates/inserts/deletes and database modifications to any table the database user has access to.

Record
DEBIAN-CVE-2016-8640
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02
OSVGHSA-hg4c-rgvm-964g 9.3

SQL Injection in pycsw

A SQL injection vulnerability in pycsw all versions before 2.0.2, 1.10.5 and 1.8.6 that leads to read and extract of any data from any table in the pycsw database that the database user has access to. Also on PostgreSQL (at least) it is possible to perform updates/inserts/deletes and database modifications to any table the database user has access to.

Record
GHSA-hg4c-rgvm-964g
CVSS 4.0
9.3 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-89
Updated
2026-11-02
OSVUBUNTU-CVE-2016-8640 9.1

A SQL injection vulnerability in pycsw all versions before 2.0.2, 1.10.5 and 1.8.6 that leads to read and extract of any data from any table in the pycsw database that the database user has access to. Also on PostgreSQL (at least) it is possible to perform updates/inserts/deletes and database modifications to any table the database user has access to.

Record
UBUNTU-CVE-2016-8640
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02
OSVPYSEC-2018-98 No score

A SQL injection vulnerability in pycsw all versions before 2.0.2, 1.10.5 and 1.8.6 that leads to read and extract of any data from any table in the pycsw database that the database user has access to. Also on PostgreSQL (at least) it is possible to perform updates/inserts/deletes and database modifications to any table the database user has access to.

Record
PYSEC-2018-98
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pycsw
PyPI
before 1.8.6
1.8.6
pycsw
PyPI
1.10.0 up to 1.10.5
1.10.5
pycsw
PyPI
2.0.0 up to 2.0.2
2.0.2
pycsw
Debian:12
before 2.0.2+dfsg-1, plus listed versions
1.10.0+dfsg-11.10.1+dfsg-11.10.1+dfsg-21.10.4+dfsg-11.10.4+dfsg-2
Show 7 moreShow less
2.0.0+dfsg-12.0.0+dfsg-1~exp12.0.0+dfsg-1~exp22.0.0+dfsg-1~exp32.0.0~rc1+dfsg-1~exp12.0.0~rc1+dfsg-1~exp22.0.1+dfsg-1
2.0.2+dfsg-1
pycsw
Debian:13
before 2.0.2+dfsg-1, plus listed versions
1.10.0+dfsg-11.10.1+dfsg-11.10.1+dfsg-21.10.4+dfsg-11.10.4+dfsg-2
Show 7 moreShow less
2.0.0+dfsg-12.0.0+dfsg-1~exp12.0.0+dfsg-1~exp22.0.0+dfsg-1~exp32.0.0~rc1+dfsg-1~exp12.0.0~rc1+dfsg-1~exp22.0.1+dfsg-1
2.0.2+dfsg-1
pycsw
Debian:14
before 2.0.2+dfsg-1, plus listed versions
1.10.0+dfsg-11.10.1+dfsg-11.10.1+dfsg-21.10.4+dfsg-11.10.4+dfsg-2
Show 7 moreShow less
2.0.0+dfsg-12.0.0+dfsg-1~exp12.0.0+dfsg-1~exp22.0.0+dfsg-1~exp32.0.0~rc1+dfsg-1~exp12.0.0~rc1+dfsg-1~exp22.0.1+dfsg-1
2.0.2+dfsg-1
pycsw
PyPI
2.0.0 up to 2.0.2, plus listed versions
2.0.1
2.0.2
pycsw
PyPI
before 1.8.6, plus listed versions
1.4.01.4.11.4.21.6.01.6.1
Show 9 moreShow less
1.6.21.6.31.6.41.8.01.8.11.8.21.8.31.8.41.8.5
1.8.6
pycsw
PyPI
1.10.0 up to 1.10.5, plus listed versions
1.10.11.10.21.10.31.10.4
1.10.5
pycsw
PyPI
before 1.8.6, 1.10.0 up to 1.10.5, 2.0.0 up to 2.0.2, plus listed versions
1.10.11.10.21.10.31.10.41.4.0
Show 14 moreShow less
1.4.11.4.21.6.01.6.11.6.21.6.31.6.41.8.01.8.11.8.21.8.31.8.41.8.52.0.1
1.8.61.10.52.0.2
pycsw
Ubuntu:16.04:LTS
All versions, plus listed versions
1.10.1+dfsg-2
None known

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 8 moreShow less
MoveEnter Open