Every CVE Search/ Get API key

CVE-2016-8642

Moodle Unauthenticated Access

5.3 MediumFix available

In Moodle 2.x and 3.x, the question engine allows access to files that should not be available.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
None

Exploit likelihood

1.20%Up 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.3

In Moodle 2.x and 3.x, the question engine allows access to files that should not be available.

Record
CVE-2016-8642
CVSS 3.0
5.3 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-284
Updated
2026-11-02
CVE List No score

In Moodle 2.x and 3.x, the question engine allows access to files that should not be available.

Record
CVE-2016-8642
Updated
2026-11-02
EUVDEUVD-2022-5690 No score

In Moodle 2.x and 3.x, the question engine allows access to files that should not be available.

Record
EUVD-2022-5690
Updated
2026-11-03
GitHub AdvisoriesGHSA-x32v-7qw8-cpq8 5.3

Moodle Unauthenticated Access

In Moodle 2.x and 3.x, the question engine allows access to files that should not be available.

Record
GHSA-x32v-7qw8-cpq8
CVSS 3.0
5.3 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-284
Updated
2026-11-02
OSV 5.3

In Moodle 2.x and 3.x, the question engine allows access to files that should not be available.

Record
CVE-2016-8642
CVSS 3.0
5.3 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
OSVGHSA-x32v-7qw8-cpq8 5.3

Moodle Unauthenticated Access

In Moodle 2.x and 3.x, the question engine allows access to files that should not be available.

Record
GHSA-x32v-7qw8-cpq8
CVSS 3.0
5.3 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-284
Updated
2026-11-02
OSVUBUNTU-CVE-2016-8642 5.3

In Moodle 2.x and 3.x, the question engine allows access to files that should not be available.

Record
UBUNTU-CVE-2016-8642
CVSS 3.0
5.3 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
3.1.0 to 3.1.2
3.1.3
moodle/moodle
Packagist
3.0.0 to 3.0.6
3.0.7
moodle/moodle
Packagist
2.9.0 to 2.9.8
2.9.9
moodle/moodle
Packagist
2.8.0 to 2.8.12 None known
moodle/moodle
Packagist
2.7.0 to 2.7.16
2.7.17
moodle/moodle
Packagist
3.1.0 up to 3.1.3, plus listed versions
v3.1.0v3.1.1v3.1.2
3.1.3
moodle/moodle
Packagist
3.0.0 up to 3.0.7, plus listed versions
v3.0.0v3.0.1v3.0.2v3.0.3v3.0.4v3.0.5v3.0.6
3.0.7
moodle/moodle
Packagist
2.9.0 up to 2.9.9, plus listed versions
v2.9.0v2.9.1v2.9.2v2.9.3v2.9.4
Show 4 moreShow less
v2.9.5v2.9.6v2.9.7v2.9.8
2.9.9
moodle/moodle
Packagist
2.8.0 to 2.8.12, plus listed versions
v2.8.0v2.8.1v2.8.10v2.8.11v2.8.12
Show 8 moreShow less
v2.8.2v2.8.3v2.8.4v2.8.5v2.8.6v2.8.7v2.8.8v2.8.9
None known
moodle/moodle
Packagist
2.7.0 up to 2.7.17, plus listed versions
v2.7.0v2.7.1v2.7.10v2.7.11v2.7.12
Show 12 moreShow less
v2.7.13v2.7.14v2.7.15v2.7.16v2.7.2v2.7.3v2.7.4v2.7.5v2.7.6v2.7.7v2.7.8v2.7.9
2.7.17
moodle
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known
moodle
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-8642 is a medium vulnerability (CVSS 5.3) in Moodle, published January 20, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.20%, the 68th percentile. Fixed in moodle/moodle 3.1.3.

References

Show 4 moreShow less
MoveEnter Open