Every CVE Search/ Get API key

CVE-2016-8748

Cross-site Scripting in Apache NiFi

5.4 MediumFix available

CVE-2016-8748 is a medium vulnerability (CVSS 5.4) in Apache Nifi, published October 19, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.99%, the 80th percentile. Fixed in org.apache.nifi:nifi 1.0.1.

In Apache NiFi before 1.0.1 and 1.1.x before 1.1.1, there is a cross-site scripting vulnerability in connection details dialog when accessed by an authorized user. The user supplied text was not being properly handled when added to the DOM.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.99%Up 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.4

In Apache NiFi before 1.0.1 and 1.1.x before 1.1.1, there is a cross-site scripting vulnerability in connection details dialog when accessed by an authorized user. The user supplied text was not being properly handled when added to the DOM.

Record
CVE-2016-8748
CVSS 3.0
5.4 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

In Apache NiFi before 1.0.1 and 1.1.x before 1.1.1, there is a cross-site scripting vulnerability in connection details dialog when accessed by an authorized user. The user supplied text was not being properly handled when added to the DOM.

Record
CVE-2016-8748
Updated
2026-11-02
EUVDEUVD-2022-3860 No score

In Apache NiFi before 1.0.1 and 1.1.x before 1.1.1, there is a cross-site scripting vulnerability in connection details dialog when accessed by an authorized user. The user supplied text was not being properly handled when added to the DOM.

Record
EUVD-2022-3860
Updated
2026-11-03
GitHub AdvisoriesGHSA-g2fm-x3cp-mqw9 5.4

Cross-site Scripting in Apache NiFi

In Apache NiFi before 1.0.1 and 1.1.x before 1.1.1, there is a cross-site scripting vulnerability in connection details dialog when accessed by an authorized user. The user supplied text was not being properly handled when added to the DOM.

Record
GHSA-g2fm-x3cp-mqw9
CVSS 3.0
5.4 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 5.4

In Apache NiFi before 1.0.1 and 1.1.x before 1.1.1, there is a cross-site scripting vulnerability in connection details dialog when accessed by an authorized user. The user supplied text was not being properly handled when added to the DOM.

Record
CVE-2016-8748
CVSS 3.0
5.4 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-g2fm-x3cp-mqw9 5.4

Cross-site Scripting in Apache NiFi

In Apache NiFi before 1.0.1 and 1.1.x before 1.1.1, there is a cross-site scripting vulnerability in connection details dialog when accessed by an authorized user. The user supplied text was not being properly handled when added to the DOM.

Record
GHSA-g2fm-x3cp-mqw9
CVSS 3.0
5.4 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.nifi:nifi
Maven
before 1.0.1
1.0.1
org.apache.nifi:nifi
Maven
1.1.0 up to 1.1.1
1.1.1
org.apache.nifi:nifi
Maven
before 1.0.1, plus listed versions
0.0.1-incubating0.0.2-incubating0.1.0-incubating0.2.0-incubating0.2.1
Show 14 moreShow less
0.3.00.4.00.4.10.5.00.5.10.6.00.6.10.7.00.7.10.7.20.7.30.7.41.0.01.0.0-BETA
1.0.1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

MoveEnter Open