CVE-2016-9119
MoinMoin Cross-site Scripting (XSS) vulnerability
Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.8 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.8 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
CVE-2016-9119- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.8 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
CVE-2016-9119- Updated
- 2026-11-02
EUVDEUVD-2017-0077 No score
Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.8 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
EUVD-2017-0077- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5fq5-pfv8-mrfv
5.1
MoinMoin Cross-site Scripting (XSS) vulnerability
Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.8 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
GHSA-5fq5-pfv8-mrfv- CVSS 4.0
- 5.1 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N - CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-5fq5-pfv8-mrfv
5.1
MoinMoin Cross-site Scripting (XSS) vulnerability
Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.8 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
GHSA-5fq5-pfv8-mrfv- CVSS 4.0
- 5.1 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N - CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-9119
6.1
Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.8 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
UBUNTU-CVE-2016-9119- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVPYSEC-2017-20 No score
Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.8 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
PYSEC-2017-20- Updated
- 2026-11-02
OSVUSN-3137-1 No score
moin vulnerabilities
It was discovered that MoinMoin did not properly sanitize certain inputs, resulting in cross-site scripting (XSS) vulnerabilities. With cross-site scripting vulnerabilities, if a user were tricked into viewing server output during a crafted server request, a remote attacker could exploit this to modify the contents, or steal confidential data, within the same domain.
- Record
USN-3137-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moinPyPI |
before 1.9.8 | 1.9.8 |
moinDebian:7 |
before 1.9.4-8+deb7u3, plus listed versions 1.9.4-8+deb7u11.9.4-8+deb7u2 |
1.9.4-8+deb7u3 |
moinDebian:8 |
before 1.9.8-1+deb8u1, plus listed versions 1.9.8-1 |
1.9.8-1+deb8u1 |
moinPyPI |
before 1.9.8, plus listed versions 1.8.41.8.51.8.61.8.71.9.0 Show 7 moreShow less1.9.11.9.21.9.31.9.41.9.51.9.61.9.7 |
1.9.8 |
moinUbuntu:14.04:LTS |
before 1.9.7-1ubuntu2.1, plus listed versions 1.9.5-5ubuntu11.9.7-1ubuntu11.9.7-1ubuntu2 |
1.9.7-1ubuntu2.1 |
moinUbuntu:16.04:LTS |
before 1.9.8-1ubuntu1.16.04.1, plus listed versions 1.9.7-2ubuntu31.9.8-1ubuntu1 |
1.9.8-1ubuntu1.16.04.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-9119 is a medium vulnerability (CVSS 6.1) in Moinmo Moinmoin, published November 14, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.46%, the 73rd percentile. Fixed in moin 1.9.8.
References
moinmo.in/SecurityFixes
securityfocus.com/bid/94501
ubuntu.com/usn/USN-3137-1
debian.org/security/2016/dsa-3715
nvd.nist.gov/vuln/detail/CVE-2016-9119
web.archive.org/web/20200227212253/http://www.securityfocus.com/bid/94501
Show 8 moreShow less
github.com/pypa/advisory-database/tree/main/vulns/moin/PYSEC-2017-20.yaml
github.com/advisories/GHSA-5fq5-pfv8-mrfv
github.com/moinwiki/moin
ubuntu.com/security/CVE-2016-9119
ubuntu.com/security/notices/USN-3137-1
cve.org/CVERecord?id=CVE-2016-9119
ubuntu.com/security/CVE-2016-7146
ubuntu.com/security/CVE-2016-7148