Every CVE Search/ Get API key

CVE-2016-9605

Cobbler Arbitrary File Read

6.1 MediumFix available

A flaw was found in cobbler software component version 2.6.11-1. It suffers from an invalid parameter validation vulnerability, leading the arbitrary file reading. The flaw is triggered by navigating to a vulnerable URL via cobbler-web on a default installation.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.81%Down 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

CVE List Score used 6.1

A flaw was found in cobbler software component version 2.6.11-1. It suffers from an invalid parameter validation vulnerability, leading the arbitrary file reading. The flaw is triggered by navigating to a vulnerable URL via cobbler-web on a default installation.

Record
CVE-2016-9605
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2022-2448 6.1

A flaw was found in cobbler software component version 2.6.11-1. It suffers from an invalid parameter validation vulnerability, leading the arbitrary file reading. The flaw is triggered by navigating to a vulnerable URL via cobbler-web on a default installation.

Record
EUVD-2022-2448
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-4vc9-4xpq-77vm 6.1

Cobbler Arbitrary File Read

A flaw was found in cobbler software component version 2.6.11-1. It suffers from an invalid parameter validation vulnerability, leading the arbitrary file reading. The flaw is triggered by navigating to a vulnerable URL via cobbler-web on a default installation.

Record
GHSA-4vc9-4xpq-77vm
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
NVD 6.1

A flaw was found in cobbler software component version 2.6.11-1. It suffers from an invalid parameter validation vulnerability, leading the arbitrary file reading. The flaw is triggered by navigating to a vulnerable URL via cobbler-web on a default installation.

Record
CVE-2016-9605
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-4vc9-4xpq-77vm 6.1

Cobbler Arbitrary File Read

A flaw was found in cobbler software component version 2.6.11-1. It suffers from an invalid parameter validation vulnerability, leading the arbitrary file reading. The flaw is triggered by navigating to a vulnerable URL via cobbler-web on a default installation.

Record
GHSA-4vc9-4xpq-77vm
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVPYSEC-2026-623 6.1

Cobbler Arbitrary File Read

A flaw was found in cobbler software component version 2.6.11-1. It suffers from an invalid parameter validation vulnerability, leading the arbitrary file reading. The flaw is triggered by navigating to a vulnerable URL via cobbler-web on a default installation.

Record
PYSEC-2026-623
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVopenSUSE-SU-2024:10690-1 No score

cobbler-3.2.1.336+git.5639a3af-1.1 on GA media

These are all security issues fixed in the cobbler-3.2.1.336+git.5639a3af-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10690-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:10897-1 No score

koan-3.0.1-1.2 on GA media

These are all security issues fixed in the koan-3.0.1-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10897-1
Updated
2026-11-02
OSVSUSE-SU-2017:1699-1 No score

Security update for cobbler

This update for cobbler fixes the following issues:

  • CVE-2016-9605: A directory traversal problem in the fix script endpoint was fixed that could be used to leak file content. (bsc#1030582)
Record
SUSE-SU-2017:1699-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
cobbler
PyPI
through 2.6.11-1 None known
cobbler
PyPI
through 2.6.11-1, plus listed versions
0.6.3-2
None known
cobbler
SUSE:Manager Client Tools 12
before 2.6.6-48.1
2.6.6-48.1
cobbler
SUSE:Manager Server 3.0
before 2.6.6-48.1
2.6.6-48.1
cobbler
openSUSE:Tumbleweed
before 3.2.1.336+git.5639a3af-1.1
3.2.1.336+git.5639a3af-1.1
koan
openSUSE:Tumbleweed
before 3.0.1-1.2
3.0.1-1.2

History

History
RecordedChangedSources
aliases, productsEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-9605 is a medium vulnerability (CVSS 6.1) in Cobbler, published June 26, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.81%, the 56th percentile. Fixed in cobbler 2.6.6-48.1.

References

Show 7 moreShow less
MoveEnter Open