Every CVE Search/ Get API key

CVE-2016-9814

SimpleSAMLphp SAML2 spoof SAML responses

9.1 CriticalFix available

CVE-2016-9814 is a critical vulnerability (CVSS 9.1) in Simplesamlphp Saml2, published February 16, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.41%, the 84th percentile. Fixed in simplesamlphp/saml2 1.10.3.

The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x before 1.10.3, and 2.x before 2.3.3 allows remote attackers to spoof SAML responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
High

Exploit likelihood

2.41%Up 1.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.1

The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x before 1.10.3, and 2.x before 2.3.3 allows remote attackers to spoof SAML responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.

Record
CVE-2016-9814
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
CVSS 2.0
8.5 HighAV:N/AC:L/Au:N/C:N/I:P/A:C
Weakness
CWE-399
Updated
2026-11-02
CVE List No score

The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x before 1.10.3, and 2.x before 2.3.3 allows remote attackers to spoof SAML responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.

Record
CVE-2016-9814
Updated
2026-11-02
EUVDEUVD-2022-5133 No score

The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x before 1.10.3, and 2.x before 2.3.3 allows remote attackers to spoof SAML responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.

Record
EUVD-2022-5133
Updated
2026-11-03
GitHub AdvisoriesGHSA-r8v4-7vwj-983x 9.1

SimpleSAMLphp SAML2 spoof SAML responses

The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x before 1.10.3, and 2.x before 2.3.3 allows remote attackers to spoof SAML responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.

Record
GHSA-r8v4-7vwj-983x
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
Updated
2026-11-02
OSV 9.1

The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x before 1.10.3, and 2.x before 2.3.3 allows remote attackers to spoof SAML responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.

Record
CVE-2016-9814
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-9814 9.1

The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x before 1.10.3, and 2.x before 2.3.3 allows remote attackers to spoof SAML responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.

Record
DEBIAN-CVE-2016-9814
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
Updated
2026-11-02
OSVGHSA-r8v4-7vwj-983x 9.1

SimpleSAMLphp SAML2 spoof SAML responses

The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x before 1.10.3, and 2.x before 2.3.3 allows remote attackers to spoof SAML responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.

Record
GHSA-r8v4-7vwj-983x
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-9814 9.1

The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x before 1.10.3, and 2.x before 2.3.3 allows remote attackers to spoof SAML responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.

Record
UBUNTU-CVE-2016-9814
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
simplesamlphp/saml2
Packagist
1.10 up to 1.10.3
1.10.3
simplesamlphp/saml2
Packagist
before 1.8.1
1.8.1
simplesamlphp/saml2
Packagist
1.9.0 up to 1.9.1
1.9.1
simplesamlphp/saml2
Packagist
2.0 up to 2.3.3
2.3.3
simplesamlphp
Debian:12
before 1.14.10-1
1.14.10-1
simplesamlphp
Debian:14
before 1.14.10-1, plus listed versions
1.10.0-11.11.0-11.12.0-11.12.0~rc1-11.12.0~rc2-1
Show 31 moreShow less
1.13.0-11.13.1-11.13.1-21.13.2-11.14.0-11.14.1-11.14.2-11.14.2-21.14.3-11.14.4-11.14.5-11.14.6-11.14.7-11.14.8-11.14.9-11.6.0-11.6.1-11.6.2-11.6.3-11.6.3-21.6.3-31.7.0-11.7.0-21.8.0-11.8.1-11.8.2-11.9.0-11.9.0~rc1-11.9.0~rc2-11.9.1-11.9.2-1
1.14.10-1
simplesamlphp
Debian:7
before 1.9.2-1+deb7u3, plus listed versions
1.9.2-11.9.2-1+deb7u11.9.2-1+deb7u2
1.9.2-1+deb7u3
simplesamlphp/saml2
Packagist
1.10 up to 1.10.3, plus listed versions
v1.10v1.10.1v1.10.2
1.10.3
simplesamlphp/saml2
Packagist
before 1.8.1, plus listed versions
v0.1.0v0.1.0-alphav0.3.0v0.4.0v0.4.1
Show 29 moreShow less
v0.4.2v0.5.0v0.6.0v0.6.1v0.6.2v0.6.3v0.6.4v0.7.0v0.7.1v0.8.0v0.8.1v1.0.0v1.1.0v1.2.0v1.3.0v1.3.1v1.3.2v1.4.0v1.5.0v1.5.1v1.5.2v1.5.3v1.5.4v1.6.0v1.6.1v1.7.0v1.7.1v1.7.2v1.8
1.8.1
simplesamlphp/saml2
Packagist
2.0 up to 2.3.3, plus listed versions
v2.0.0v2.0.1v2.1v2.2v2.3v2.3.1v2.3.2
2.3.3
simplesamlphp
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
1.13.2-11.14.0-11.14.0-1ubuntu21.14.0-1ubuntu2+esm1
None known

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 7 moreShow less
MoveEnter Open