CVE-2016-9839
In MapServer before 7.0.3, OGR driver error messages are too verbose and may leak sensitive...
CVE-2016-9839 is a high vulnerability (CVSS 7.5) in Osgeo Mapserver, published December 7, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.50%, the 74th percentile. Fixed in mapserver 7.0.3-1.
In MapServer before 7.0.3, OGR driver error messages are too verbose and may leak sensitive information if data connection fails.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.5
In MapServer before 7.0.3, OGR driver error messages are too verbose and may leak sensitive information if data connection fails.
- Record
CVE-2016-9839- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
CVE List No score
In MapServer before 7.0.3, OGR driver error messages are too verbose and may leak sensitive information if data connection fails.
- Record
CVE-2016-9839- Updated
- 2026-11-02
EUVDEUVD-2016-10639 No score
In MapServer before 7.0.3, OGR driver error messages are too verbose and may leak sensitive information if data connection fails.
- Record
EUVD-2016-10639- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-92rp-xfpf-gq53
7.5
In MapServer before 7.0.3, OGR driver error messages are too verbose and may leak sensitive...
In MapServer before 7.0.3, OGR driver error messages are too verbose and may leak sensitive information if data connection fails.
- Record
GHSA-92rp-xfpf-gq53- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-200
- Updated
- 2026-11-02
OSV
7.5
In MapServer before 7.0.3, OGR driver error messages are too verbose and may leak sensitive information if data connection fails.
- Record
CVE-2016-9839- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-9839
7.5
In MapServer before 7.0.3, OGR driver error messages are too verbose and may leak sensitive information if data connection fails.
- Record
DEBIAN-CVE-2016-9839- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-9839
7.5
In MapServer before 7.0.3, OGR driver error messages are too verbose and may leak sensitive information if data connection fails.
- Record
UBUNTU-CVE-2016-9839- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mapserverDebian:12 |
before 7.0.3-1 | 7.0.3-1 |
mapserverDebian:13 |
before 7.0.3-1 | 7.0.3-1 |
mapserverDebian:14 |
before 7.0.3-1 | 7.0.3-1 |
mapserverDebian:7 |
before 6.0.1-3.2+deb7u3, plus listed versions 6.0.1-3.26.0.1-3.2+deb7u16.0.1-3.2+deb7u2 |
6.0.1-3.2+deb7u3 |
mapserverUbuntu:14.04:LTS |
before 6.4.1-2ubuntu0.1, plus listed versions 6.2.1-36.4.0-26.4.0-3build16.4.1-16.4.1-1build16.4.1-2 |
6.4.1-2ubuntu0.1 |
mapserverUbuntu:16.04:LTS |
before 7.0.0-9ubuntu3.1, plus listed versions 7.0.0-4build17.0.0-5ubuntu17.0.0-77.0.0-87.0.0-8build1 Show 4 moreShow less7.0.0-97.0.0-9ubuntu17.0.0-9ubuntu27.0.0-9ubuntu3 |
7.0.0-9ubuntu3.1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
github.com/mapserver/mapserver/pull/5356
securityfocus.com/bid/94856
nvd.nist.gov/vuln/detail/CVE-2016-9839
github.com/advisories/GHSA-92rp-xfpf-gq53
security-tracker.debian.org/tracker/CVE-2016-9839
ubuntu.com/security/CVE-2016-9839
lists.osgeo.org/pipermail/mapserver-dev/2016-December/014979.html
github.com/mapserver/mapserver/pull/4928
cve.org/CVERecord?id=CVE-2016-9839