Every CVE Search/ Get API key

CVE-2016-9909

Improper Neutralization of Input During Web Page Generation in html5lib

6.1 MediumFix available

CVE-2016-9909 is a medium vulnerability (CVSS 6.1) in Html5lib, published January 3, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.16%, the 82nd percentile. Fixed in html5lib 0.999999999.

The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of the < (less than) character in attribute values.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

2.16%Up 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.1

The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of the < (less than) character in attribute values.

Record
CVE-2016-9909
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of the < (less than) character in attribute values.

Record
CVE-2016-9909
Updated
2026-11-02
EUVDEUVD-2017-0060 No score

The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of the < (less than) character in attribute values.

Record
EUVD-2017-0060
Updated
2026-11-03
GitHub AdvisoriesGHSA-v9v9-xffq-rwr4 5.3

Improper Neutralization of Input During Web Page Generation in html5lib

The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of the < (less than) character in attribute values.

Record
GHSA-v9v9-xffq-rwr4
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of the < (less than) character in attribute values.

Record
CVE-2016-9909
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2016-9909 6.1

The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of the < (less than) character in attribute values.

Record
DEBIAN-CVE-2016-9909
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
Show 4 moreShow less
OSVGHSA-v9v9-xffq-rwr4 5.3

Improper Neutralization of Input During Web Page Generation in html5lib

The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of the < (less than) character in attribute values.

Record
GHSA-v9v9-xffq-rwr4
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVUBUNTU-CVE-2016-9909 6.1

The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of the < (less than) character in attribute values.

Record
UBUNTU-CVE-2016-9909
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVMGASA-2017-0001 No score

Updated python-html5lib packages fix security vulnerability

Fixes a potential cross-site scripting vulnerablity: quote attributes that need escaping in legacy browsers. (CVE-2016-9909, CVE-2016-9910)

Record
MGASA-2017-0001
Updated
2026-11-02
OSVPYSEC-2017-14 No score

The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of the < (less than) character in attribute values.

Record
PYSEC-2017-14
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
html5lib
PyPI
before 0.999999999
0.999999999
html5lib
Debian:12
before 0.999999999-1
0.999999999-1
html5lib
Debian:13
before 0.999999999-1
0.999999999-1
html5lib
Debian:14
before 0.999999999-1
0.999999999-1
html5lib
PyPI
before 0.999999999, plus listed versions
0.100.110.11.10.20.9
Show 9 moreShow less
0.900.950.990.9990.99990.999990.9999990.99999990.99999999
0.999999999
python-html5lib
Mageia:5
before 1.0b3-7.1.mga5
1.0b3-7.1.mga5
html5lib
Ubuntu:16.04:LTS
All versions, plus listed versions
0.999-3build10.999-4
None known

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 12 moreShow less
MoveEnter Open