Every CVE Search/ Get API key

CVE-2016-9956

The route manager in FlightGear before 2016.4.4 allows remote attackers to write to arbitrary...

7.5 HighFix available

The route manager in FlightGear before 2016.4.4 allows remote attackers to write to arbitrary files via a crafted Nasal script.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

3.24%Up 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

The route manager in FlightGear before 2016.4.4 allows remote attackers to write to arbitrary files via a crafted Nasal script.

Record
CVE-2016-9956
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Weakness
CWE-284
Updated
2026-11-02
CVE List No score

The route manager in FlightGear before 2016.4.4 allows remote attackers to write to arbitrary files via a crafted Nasal script.

Record
CVE-2016-9956
Updated
2026-11-02
EUVDEUVD-2016-10742 No score

The route manager in FlightGear before 2016.4.4 allows remote attackers to write to arbitrary files via a crafted Nasal script.

Record
EUVD-2016-10742
Updated
2026-11-03
GitHub AdvisoriesGHSA-gx42-hf7v-vhvg 7.5

The route manager in FlightGear before 2016.4.4 allows remote attackers to write to arbitrary...

The route manager in FlightGear before 2016.4.4 allows remote attackers to write to arbitrary files via a crafted Nasal script.

Record
GHSA-gx42-hf7v-vhvg
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-284
Updated
2026-11-02
OSV 7.5

The route manager in FlightGear before 2016.4.4 allows remote attackers to write to arbitrary files via a crafted Nasal script.

Record
CVE-2016-9956
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2016-9956 7.5

The route manager in FlightGear before 2016.4.4 allows remote attackers to write to arbitrary files via a crafted Nasal script.

Record
DEBIAN-CVE-2016-9956
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2016-9956 7.5

The route manager in FlightGear before 2016.4.4 allows remote attackers to write to arbitrary files via a crafted Nasal script.

Record
UBUNTU-CVE-2016-9956
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVMGASA-2017-0011 No score

Updated flightgear packages fix security vulnerability

A security bug CVE-2016-9956 was found in all FlightGear versions since 2009, that allow an attacker to overwrite any file the flightgear user owns. The Debian adaptation of upstream patch was applied to the Mageia FlightGear package.

Record
MGASA-2017-0011
Updated
2026-11-02
OSVopenSUSE-SU-2024:10595-1 No score

FlightGear-2020.3.11-1.3 on GA media

These are all security issues fixed in the FlightGear-2020.3.11-1.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10595-1
Updated
2026-11-02
OSVUSN-4588-1 No score

flightgear vulnerability

It was discovered that FlightGear could write arbitrary files if received a special nasal script. A remote attacker could exploit this with a crafted file to execute arbitrary code.

Record
USN-4588-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
flightgear
Debian:12
before 1:2016.4.3+dfsg-1
1:2016.4.3+dfsg-1
flightgear
Debian:13
before 1:2016.4.3+dfsg-1
1:2016.4.3+dfsg-1
flightgear
Debian:8
before 3.0.0-5+deb8u1, plus listed versions
3.0.0-5
3.0.0-5+deb8u1
flightgear
Mageia:5
before 3.4.0-2.1.mga5
3.4.0-2.1.mga5
flightgear
Ubuntu:16.04:LTS
before 3.4.0-3ubuntu1.1, plus listed versions
3.4.0-1build13.4.0-23.4.0-33.4.0-3ubuntu1
3.4.0-3ubuntu1.1
FlightGear
openSUSE:Tumbleweed
before 2020.3.11-1.3
2020.3.11-1.3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-9956 is a high vulnerability (CVSS 7.5) in Flightgear, published December 20, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.24%, the 88th percentile. Fixed in flightgear 1:2016.4.3+dfsg-1.

References

Show 16 moreShow less
MoveEnter Open