CVE-2017-0318
All versions of NVIDIA Linux GPU Display Driver contain a vulnerability in the kernel mode layer...
All versions of NVIDIA Linux GPU Display Driver contain a vulnerability in the kernel mode layer handler where improper validation of an input parameter may cause a denial of service on the system.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
5.5
All versions of NVIDIA Linux GPU Display Driver contain a vulnerability in the kernel mode layer handler where improper validation of an input parameter may cause a denial of service on the system.
- Record
CVE-2017-0318- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.9 Medium
AV:L/AC:L/Au:N/C:N/I:N/A:C - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
All versions of NVIDIA Linux GPU Display Driver contain a vulnerability in the kernel mode layer handler where improper validation of an input parameter may cause a denial of service on the system.
- Record
CVE-2017-0318- Updated
- 2026-11-02
EUVDEUVD-2017-0674 No score
All versions of NVIDIA Linux GPU Display Driver contain a vulnerability in the kernel mode layer handler where improper validation of an input parameter may cause a denial of service on the system.
- Record
EUVD-2017-0674- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3jm3-4g5c-j2w3
5.5
All versions of NVIDIA Linux GPU Display Driver contain a vulnerability in the kernel mode layer...
All versions of NVIDIA Linux GPU Display Driver contain a vulnerability in the kernel mode layer handler where improper validation of an input parameter may cause a denial of service on the system.
- Record
GHSA-3jm3-4g5c-j2w3- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
5.5
All versions of NVIDIA Linux GPU Display Driver contain a vulnerability in the kernel mode layer handler where improper validation of an input parameter may cause a denial of service on the system.
- Record
CVE-2017-0318- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-0318
5.5
All versions of NVIDIA Linux GPU Display Driver contain a vulnerability in the kernel mode layer handler where improper validation of an input parameter may cause a denial of service on the system.
- Record
DEBIAN-CVE-2017-0318- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-0318
5.5
All versions of NVIDIA Linux GPU Display Driver contain a vulnerability in the kernel mode layer handler where improper validation of an input parameter may cause a denial of service on the system.
- Record
UBUNTU-CVE-2017-0318- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUSN-3240-1 No score
nvidia-graphics-drivers-304, nvidia-graphics-drivers-340, nvidia-graphics-drivers-375 vulnerability
It was discovered that the NVIDIA graphics drivers contained a flaw in the kernel mode layer. A local attacker could use this issue to cause a denial of service.
- Record
USN-3240-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
nvidia-graphics-driversDebian:12 |
before 375.39-1, plus listed versions 1.0.6629+1-21.0.7167-11.0.7174-11.0.7174-21.0.7174-3 Show 45 moreShow less1.0.7174-41.0.7664-11.0.7664-21.0.7667-11.0.7667-31.0.7676-11.0.7676-21.0.8174-11.0.8178-0bpo11.0.8178-11.0.8178-21.0.8178-31.0.8756-11.0.8756-21.0.8756-31.0.8756-41.0.8762-11.0.8762-21.0.8774-11.0.8774-21.0.8774-31.0.8774-41.0.8774-51.0.8774-61.0.8774-71.0.8776-11.0.8776-21.0.8776-31.0.8776-41.0.9625-11.0.9625-21.0.9631-11.0.9746-11.0.9746-21.0.9755-1100.14.06-1100.14.09-1100.14.11-1100.14.19-1169.07-1169.07-2169.09-1169.12-1169.12-2169.12-3 |
375.39-1 |
nvidia-graphics-driversDebian:13 |
before 375.39-1, plus listed versions 1.0.6629+1-21.0.7167-11.0.7174-11.0.7174-21.0.7174-3 Show 45 moreShow less1.0.7174-41.0.7664-11.0.7664-21.0.7667-11.0.7667-31.0.7676-11.0.7676-21.0.8174-11.0.8178-0bpo11.0.8178-11.0.8178-21.0.8178-31.0.8756-11.0.8756-21.0.8756-31.0.8756-41.0.8762-11.0.8762-21.0.8774-11.0.8774-21.0.8774-31.0.8774-41.0.8774-51.0.8774-61.0.8774-71.0.8776-11.0.8776-21.0.8776-31.0.8776-41.0.9625-11.0.9625-21.0.9631-11.0.9746-11.0.9746-21.0.9755-1100.14.06-1100.14.09-1100.14.11-1100.14.19-1169.07-1169.07-2169.09-1169.12-1169.12-2169.12-3 |
375.39-1 |
nvidia-graphics-driversDebian:14 |
before 375.39-1, plus listed versions 1.0.6629+1-21.0.7167-11.0.7174-11.0.7174-21.0.7174-3 Show 45 moreShow less1.0.7174-41.0.7664-11.0.7664-21.0.7667-11.0.7667-31.0.7676-11.0.7676-21.0.8174-11.0.8178-0bpo11.0.8178-11.0.8178-21.0.8178-31.0.8756-11.0.8756-21.0.8756-31.0.8756-41.0.8762-11.0.8762-21.0.8774-11.0.8774-21.0.8774-31.0.8774-41.0.8774-51.0.8774-61.0.8774-71.0.8776-11.0.8776-21.0.8776-31.0.8776-41.0.9625-11.0.9625-21.0.9631-11.0.9746-11.0.9746-21.0.9755-1100.14.06-1100.14.09-1100.14.11-1100.14.19-1169.07-1169.07-2169.09-1169.12-1169.12-2169.12-3 |
375.39-1 |
nvidia-graphics-drivers-304Ubuntu:14.04:LTS |
before 304.135-0ubuntu0.14.04.1, plus listed versions 304.88-0ubuntu8304.88-0ubuntu9304.88-0ubuntu10304.88-0ubuntu11304.116-0ubuntu1 Show 9 moreShow less304.116-0ubuntu2304.117-0ubuntu1304.125-0ubuntu0.0.1304.125-0ubuntu0.0.2304.128-0ubuntu0.0.1304.131-0ubuntu0.14.04.1304.131-0ubuntu0.14.04.2304.132-0ubuntu0.14.04.2304.134-0ubuntu0.14.04.1 |
304.135-0ubuntu0.14.04.1 |
nvidia-graphics-drivers-340Ubuntu:14.04:LTS |
before 340.102-0ubuntu0.14.04.1, plus listed versions 340.76-0ubuntu0.1340.93-0ubuntu0.0.1340.96-0ubuntu0.14.04.1340.98-0ubuntu0.14.04.1340.101-0ubuntu0.14.04.1 |
340.102-0ubuntu0.14.04.1 |
nvidia-graphics-drivers-375Ubuntu:14.04:LTS |
before 375.39-0ubuntu0.14.04.1 | 375.39-0ubuntu0.14.04.1 |
nvidia-graphics-drivers-304Ubuntu:16.04:LTS |
before 304.135-0ubuntu0.16.04.1, plus listed versions 304.128-0ubuntu1304.131-0ubuntu2304.131-0ubuntu3304.132-0ubuntu0.16.04.2304.134-0ubuntu0.16.04.1 |
304.135-0ubuntu0.16.04.1 |
nvidia-graphics-drivers-340Ubuntu:16.04:LTS |
before 340.102-0ubuntu0.16.04.1, plus listed versions 340.93-0ubuntu1340.93-0ubuntu2340.96-0ubuntu1340.96-0ubuntu2340.96-0ubuntu3340.98-0ubuntu0.16.04.1340.101-0ubuntu0.16.04.1 |
340.102-0ubuntu0.16.04.1 |
nvidia-graphics-drivers-375Ubuntu:16.04:LTS |
before 375.39-0ubuntu0.16.04.1 | 375.39-0ubuntu0.16.04.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-0318 is a medium vulnerability (CVSS 5.5) in Nvidia Corporation Linux Gpu Display Driver, published February 15, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.34%, the 27th percentile. Fixed in nvidia-graphics-drivers 375.39-1.
References
Left out here: 798 versions. The JSON record has them.