CVE-2017-0373
The gen_class_pod implementation in lib/Config/Model/Utils/GenClassPod.pm in Config-Model (aka...
The gen_class_pod implementation in lib/Config/Model/Utils/GenClassPod.pm in Config-Model (aka libconfig-model-perl) before 2.102 has a dangerous "use lib" line, which allows remote attackers to have an unspecified impact via a crafted Debian package file.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.3
The gen_class_pod implementation in lib/Config/Model/Utils/GenClassPod.pm in Config-Model (aka libconfig-model-perl) before 2.102 has a dangerous "use lib" line, which allows remote attackers to have an unspecified impact via a crafted Debian package file.
- Record
CVE-2017-0373- CVSS 3.0
- 7.3 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
The gen_class_pod implementation in lib/Config/Model/Utils/GenClassPod.pm in Config-Model (aka libconfig-model-perl) before 2.102 has a dangerous "use lib" line, which allows remote attackers to have an unspecified impact via a crafted Debian package file.
- Record
CVE-2017-0373- Updated
- 2026-11-02
EUVDEUVD-2017-0727 No score
The gen_class_pod implementation in lib/Config/Model/Utils/GenClassPod.pm in Config-Model (aka libconfig-model-perl) before 2.102 has a dangerous "use lib" line, which allows remote attackers to have an unspecified impact via a crafted Debian package file.
- Record
EUVD-2017-0727- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-pcw9-xjj5-7cp5
7.3
The gen_class_pod implementation in lib/Config/Model/Utils/GenClassPod.pm in Config-Model (aka...
The gen_class_pod implementation in lib/Config/Model/Utils/GenClassPod.pm in Config-Model (aka libconfig-model-perl) before 2.102 has a dangerous "use lib" line, which allows remote attackers to have an unspecified impact via a crafted Debian package file.
- Record
GHSA-pcw9-xjj5-7cp5- CVSS 3.0
- 7.3 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
7.3
The gen_class_pod implementation in lib/Config/Model/Utils/GenClassPod.pm in Config-Model (aka libconfig-model-perl) before 2.102 has a dangerous "use lib" line, which allows remote attackers to have an unspecified impact via a crafted Debian package file.
- Record
CVE-2017-0373- CVSS 3.0
- 7.3 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-0373
7.3
The gen_class_pod implementation in lib/Config/Model/Utils/GenClassPod.pm in Config-Model (aka libconfig-model-perl) before 2.102 has a dangerous "use lib" line, which allows remote attackers to have an unspecified impact via a crafted Debian package file.
- Record
DEBIAN-CVE-2017-0373- CVSS 3.0
- 7.3 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-0373
7.3
The gen_class_pod implementation in lib/Config/Model/Utils/GenClassPod.pm in Config-Model (aka libconfig-model-perl) before 2.102 has a dangerous "use lib" line, which allows remote attackers to have an unspecified impact via a crafted Debian package file.
- Record
UBUNTU-CVE-2017-0373- CVSS 3.0
- 7.3 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libconfig-model-perlDebian:12 |
before 2.097-2 | 2.097-2 |
libconfig-model-perlDebian:13 |
before 2.097-2 | 2.097-2 |
libconfig-model-perlDebian:14 |
before 2.097-2 | 2.097-2 |
libconfig-model-perlUbuntu:16.04:LTS |
All versions, plus listed versions 2.073-12.074-12.075-12.075-22.082-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-0373 is a high vulnerability (CVSS 7.3) in Config-model Project Config-model, published May 23, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.85%, the 79th percentile. Fixed in libconfig-model-perl 2.097-2.
References
anonscm.debian.org/cgit/pkg-perl/packages/libconfig-model-perl.git/commit?h=stretch&id=e7e5dd1a650939a0e021d1d5b311dbb3c4884773
cpansearch.perl.org/src/DDUMONT/Config-Model-2.102/Changes
security-tracker.debian.org/tracker/CVE-2017-0373
nvd.nist.gov/vuln/detail/CVE-2017-0373
github.com/advisories/GHSA-pcw9-xjj5-7cp5
ubuntu.com/security/CVE-2017-0373
cve.org/CVERecord?id=CVE-2017-0373