Every CVE Search/ Get API key

CVE-2017-0386

An elevation of privilege vulnerability in the libnl library could enable a local malicious...

7.8 HighFix available

An elevation of privilege vulnerability in the libnl library could enable a local malicious application to execute arbitrary code within the context of a privileged process. This issue is rated as High because it could be used to gain local access to elevated capabilities, which are not normally accessible to a third-party application. Product: Android. Versions: 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1. Android ID: A-32255299.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.15%Up 0.7 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.8

An elevation of privilege vulnerability in the libnl library could enable a local malicious application to execute arbitrary code within the context of a privileged process. This issue is rated as High because it could be used to gain local access to elevated capabilities, which are not normally accessible to a third-party application. Product: Android. Versions: 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1. Android ID: A-32255299.

Record
CVE-2017-0386
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Updated
2026-11-02
CVE List No score

An elevation of privilege vulnerability in the libnl library could enable a local malicious application to execute arbitrary code within the context of a privileged process. This issue is rated as High because it could be used to gain local access to elevated capabilities, which are not normally accessible to a third-party application. Product: Android. Versions: 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1. Android ID: A-32255299.

Record
CVE-2017-0386
Updated
2026-11-02
EUVDEUVD-2017-0740 No score

An elevation of privilege vulnerability in the libnl library could enable a local malicious application to execute arbitrary code within the context of a privileged process. This issue is rated as High because it could be used to gain local access to elevated capabilities, which are not normally accessible to a third-party application. Product: Android. Versions: 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1. Android ID: A-32255299.

Record
EUVD-2017-0740
Updated
2026-11-03
GitHub AdvisoriesGHSA-h6x2-f4w7-459j 7.8

An elevation of privilege vulnerability in the libnl library could enable a local malicious...

An elevation of privilege vulnerability in the libnl library could enable a local malicious application to execute arbitrary code within the context of a privileged process. This issue is rated as High because it could be used to gain local access to elevated capabilities, which are not normally accessible to a third-party application. Product: Android. Versions: 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1. Android ID: A-32255299.

Record
GHSA-h6x2-f4w7-459j
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2017-0158 No score

Updated libnl3 packages fix security vulnerability

An elevation of privilege vulnerability in the libnl library could enable a local malicious application to execute arbitrary code within the context of a privileged process (CVE-2017-0386).

An integer overflow vulnerability was found in nlmsg_reserve() triggered by crafted @len argument resulting into reserving too few bytes (CVE-2017-0553).

Record
MGASA-2017-0158
Updated
2026-11-02
OSVSUSE-SU-2022:3207-1 No score

Security update for libnl-1_1

This update for libnl-1_1 fixes the following issues:

  • CVE-2017-0386: Fixed an issue that could enable a local malicious application to execute arbitrary code within the context of a different process. This only affects setups were libnl is passed untrusted arguments. (bsc#1020123)
Record
SUSE-SU-2022:3207-1
Updated
2026-11-02
OSVSUSE-SU-2022:3208-1 No score

Security update for libnl3

This update for libnl3 fixes the following issues:

  • CVE-2017-0386: Fixed an issue that could enable a local malicious application to execute arbitrary code within the context of a different process. This only affects setups were libnl is passed untrusted arguments. (bsc#1020123)
Record
SUSE-SU-2022:3208-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libnl3
Mageia:5
before 3.2.25-3.1.mga5
3.2.25-3.1.mga5
libnl-1_1
SUSE:Linux Enterprise Software Development Kit 12 SP5
before 1.1.4-6.3.1
1.1.4-6.3.1
libnl-1_1
SUSE:Linux Enterprise Server 12 SP5
before 1.1.4-6.3.1
1.1.4-6.3.1
libnl-1_1
SUSE:Linux Enterprise Server for SAP Applications 12 SP5
before 1.1.4-6.3.1
1.1.4-6.3.1
libnl3
SUSE:Linux Enterprise Software Development Kit 12 SP5
before 3.2.23-4.7.1
3.2.23-4.7.1
libnl3
SUSE:Linux Enterprise Server 12 SP5
before 3.2.23-4.7.1
3.2.23-4.7.1
libnl3
SUSE:Linux Enterprise Server for SAP Applications 12 SP5
before 3.2.23-4.7.1
3.2.23-4.7.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-0386 is a high vulnerability (CVSS 7.8) in Google Android, published January 12, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.15%, the 66th percentile. Fixed in libnl3 3.2.25-3.1.mga5.

References

Show 6 moreShow less
MoveEnter Open