Every CVE Search/ Get API key

CVE-2017-0889

paperclip Server-Side Request Forgery vulnerability

9.8 CriticalFix available

CVE-2017-0889 is a critical vulnerability (CVSS 9.8) in Thoughtbot Paperclip, published November 13, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.05%, the 87th percentile. Fixed in paperclip 5.2.0.

Paperclip ruby gem version 3.1.4 and later suffers from a Server-SIde Request Forgery (SSRF) vulnerability in the Paperclip::UriAdapter class. Attackers may be able to access information about internal network resources.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

3.05%Up 2.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

Paperclip ruby gem version 3.1.4 and later suffers from a Server-SIde Request Forgery (SSRF) vulnerability in the Paperclip::UriAdapter class. Attackers may be able to access information about internal network resources.

Record
CVE-2017-0889
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-918
Updated
2026-11-02
CVE List No score

Paperclip ruby gem version 3.1.4 and later suffers from a Server-SIde Request Forgery (SSRF) vulnerability in the Paperclip::UriAdapter class. Attackers may be able to access information about internal network resources.

Record
CVE-2017-0889
Weakness
CWE-918
Updated
2026-11-02
EUVDEUVD-2018-0152 No score

Paperclip ruby gem version 3.1.4 and later suffers from a Server-SIde Request Forgery (SSRF) vulnerability in the Paperclip::UriAdapter class. Attackers may be able to access information about internal network resources.

Record
EUVD-2018-0152
Updated
2026-11-03
GitHub AdvisoriesGHSA-5jcf-c5rg-rmm8 9.8

paperclip Server-Side Request Forgery vulnerability

Paperclip ruby gem version 3.1.4 and later suffers from a Server-SIde Request Forgery (SSRF) vulnerability in the Paperclip::UriAdapter class. Attackers may be able to access information about internal network resources.

Record
GHSA-5jcf-c5rg-rmm8
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-918
Updated
2026-11-02
OSV 9.8

Paperclip ruby gem version 3.1.4 and later suffers from a Server-SIde Request Forgery (SSRF) vulnerability in the Paperclip::UriAdapter class. Attackers may be able to access information about internal network resources.

Record
CVE-2017-0889
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-5jcf-c5rg-rmm8 9.8

paperclip Server-Side Request Forgery vulnerability

Paperclip ruby gem version 3.1.4 and later suffers from a Server-SIde Request Forgery (SSRF) vulnerability in the Paperclip::UriAdapter class. Attackers may be able to access information about internal network resources.

Record
GHSA-5jcf-c5rg-rmm8
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-918
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
paperclip
RubyGems
3.1.4 up to 5.2.0
5.2.0
paperclip
RubyGems
3.1.4 up to 5.2.0, plus listed versions
3.2.03.2.13.3.03.3.13.4.0
Show 27 moreShow less
3.4.13.4.23.5.03.5.13.5.23.5.33.5.44.0.04.1.04.1.14.2.04.2.14.2.24.2.34.2.44.3.04.3.14.3.24.3.34.3.44.3.54.3.64.3.75.0.05.0.0.beta15.0.0.beta25.1.0
5.2.0

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

MoveEnter Open