Every CVE Search/ Get API key

CVE-2017-0905

Recurly gem Server-Side Request Forgery in Resource#find method

9.8 CriticalFix available

The Recurly Client Ruby Library before 2.0.13, 2.1.11, 2.2.5, 2.3.10, 2.4.11, 2.5.4, 2.6.3, 2.7.8, 2.8.2, 2.9.2, 2.10.4, 2.11.3 is vulnerable to a Server-Side Request Forgery vulnerability in the "Resource#find" method that could result in compromise of API keys or other critical resources.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.59%Up 1.8 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

The Recurly Client Ruby Library before 2.0.13, 2.1.11, 2.2.5, 2.3.10, 2.4.11, 2.5.4, 2.6.3, 2.7.8, 2.8.2, 2.9.2, 2.10.4, 2.11.3 is vulnerable to a Server-Side Request Forgery vulnerability in the "Resource#find" method that could result in compromise of API keys or other critical resources.

Record
CVE-2017-0905
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-918
Updated
2026-11-02
CVE List No score

The Recurly Client Ruby Library before 2.0.13, 2.1.11, 2.2.5, 2.3.10, 2.4.11, 2.5.4, 2.6.3, 2.7.8, 2.8.2, 2.9.2, 2.10.4, 2.11.3 is vulnerable to a Server-Side Request Forgery vulnerability in the "Resource#find" method that could result in compromise of API keys or other critical resources.

Record
CVE-2017-0905
Weakness
CWE-918
Updated
2026-11-02
EUVDEUVD-2017-0367 No score

The Recurly Client Ruby Library before 2.0.13, 2.1.11, 2.2.5, 2.3.10, 2.4.11, 2.5.4, 2.6.3, 2.7.8, 2.8.2, 2.9.2, 2.10.4, 2.11.3 is vulnerable to a Server-Side Request Forgery vulnerability in the "Resource#find" method that could result in compromise of API keys or other critical resources.

Record
EUVD-2017-0367
Updated
2026-11-03
GitHub AdvisoriesGHSA-x27v-x225-gq8g 9.8

Recurly gem Server-Side Request Forgery in Resource#find method

The Recurly Client Ruby Library before 2.0.13, 2.1.11, 2.2.5, 2.3.10, 2.4.11, 2.5.4, 2.6.3, 2.7.8, 2.8.2, 2.9.2, 2.10.4, 2.11.3 is vulnerable to a Server-Side Request Forgery vulnerability in the Resource#find method that could result in compromise of API keys or other critical resources.

Record
GHSA-x27v-x225-gq8g
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-918
Updated
2026-11-02
OSV 9.8

The Recurly Client Ruby Library before 2.0.13, 2.1.11, 2.2.5, 2.3.10, 2.4.11, 2.5.4, 2.6.3, 2.7.8, 2.8.2, 2.9.2, 2.10.4, 2.11.3 is vulnerable to a Server-Side Request Forgery vulnerability in the "Resource#find" method that could result in compromise of API keys or other critical resources.

Record
CVE-2017-0905
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-x27v-x225-gq8g 9.8

Recurly gem Server-Side Request Forgery in Resource#find method

The Recurly Client Ruby Library before 2.0.13, 2.1.11, 2.2.5, 2.3.10, 2.4.11, 2.5.4, 2.6.3, 2.7.8, 2.8.2, 2.9.2, 2.10.4, 2.11.3 is vulnerable to a Server-Side Request Forgery vulnerability in the Resource#find method that could result in compromise of API keys or other critical resources.

Record
GHSA-x27v-x225-gq8g
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-918
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
recurly
RubyGems
2.11.0 up to 2.11.3
2.11.3
recurly
RubyGems
2.10.0 up to 2.10.4
2.10.4
recurly
RubyGems
2.9.0 up to 2.9.2
2.9.2
recurly
RubyGems
2.8.0 up to 2.8.2
2.8.2
recurly
RubyGems
2.7.0 up to 2.7.8
2.7.8
recurly
RubyGems
2.6.0 up to 2.6.3
2.6.3
recurly
RubyGems
2.5.0 up to 2.5.4
2.5.4
recurly
RubyGems
2.4.0 up to 2.4.11
2.4.11
recurly
RubyGems
2.3.0 up to 2.3.10
2.3.10
recurly
RubyGems
2.2.0 up to 2.2.5
2.2.5
Show 14 moreShow less
Affected packages
PackageAffectedFixed
recurly
RubyGems
2.1.0 up to 2.1.11
2.1.11
recurly
RubyGems
2.0.0 up to 2.0.13
2.0.13
recurly
RubyGems
2.3.0 up to 2.3.10, plus listed versions
2.3.12.3.22.3.32.3.42.3.5
Show 4 moreShow less
2.3.62.3.72.3.82.3.9
2.3.10
recurly
RubyGems
2.2.0 up to 2.2.5, plus listed versions
2.2.12.2.22.2.32.2.4
2.2.5
recurly
RubyGems
2.1.0 up to 2.1.11, plus listed versions
2.1.12.1.102.1.22.1.32.1.4
Show 4 moreShow less
2.1.52.1.72.1.82.1.9
2.1.11
recurly
RubyGems
2.0.0 up to 2.0.13, plus listed versions
2.0.12.0.102.0.112.0.122.0.2
Show 6 moreShow less
2.0.32.0.42.0.52.0.62.0.82.0.9
2.0.13
recurly
RubyGems
2.9.0 up to 2.9.2, plus listed versions
2.9.1
2.9.2
recurly
RubyGems
2.8.0 up to 2.8.2, plus listed versions
2.8.1
2.8.2
recurly
RubyGems
2.7.0 up to 2.7.8, plus listed versions
2.7.12.7.22.7.32.7.42.7.52.7.62.7.7
2.7.8
recurly
RubyGems
2.6.0 up to 2.6.3, plus listed versions
2.6.12.6.2
2.6.3
recurly
RubyGems
2.5.0 up to 2.5.4, plus listed versions
2.5.12.5.22.5.3
2.5.4
recurly
RubyGems
2.4.0 up to 2.4.11, plus listed versions
2.4.12.4.102.4.22.4.32.4.4
Show 5 moreShow less
2.4.52.4.62.4.72.4.82.4.9
2.4.11
recurly
RubyGems
2.11.0 up to 2.11.3, plus listed versions
2.11.12.11.2
2.11.3
recurly
RubyGems
2.10.0 up to 2.10.4, plus listed versions
2.10.12.10.22.10.3
2.10.4

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-0905 is a critical vulnerability (CVSS 9.8) in Recurly Client Ruby, published November 13, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.59%, the 85th percentile. Fixed in recurly 2.11.3.

References

MoveEnter Open