Every CVE Search/ Get API key

CVE-2017-0906

Recurly vulnerable to SSRF

9.8 CriticalFix available

The Recurly Client Python Library before 2.0.5, 2.1.16, 2.2.22, 2.3.1, 2.4.5, 2.5.1, 2.6.2 is vulnerable to a Server-Side Request Forgery vulnerability in the "Resource.get" method that could result in compromise of API keys or other critical resources.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.62%Up 1.8 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

The Recurly Client Python Library before 2.0.5, 2.1.16, 2.2.22, 2.3.1, 2.4.5, 2.5.1, 2.6.2 is vulnerable to a Server-Side Request Forgery vulnerability in the "Resource.get" method that could result in compromise of API keys or other critical resources.

Record
CVE-2017-0906
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-918
Updated
2026-11-02
CVE List No score

The Recurly Client Python Library before 2.0.5, 2.1.16, 2.2.22, 2.3.1, 2.4.5, 2.5.1, 2.6.2 is vulnerable to a Server-Side Request Forgery vulnerability in the "Resource.get" method that could result in compromise of API keys or other critical resources.

Record
CVE-2017-0906
Weakness
CWE-918
Updated
2026-11-02
EUVDEUVD-2017-0111 No score

The Recurly Client Python Library before 2.0.5, 2.1.16, 2.2.22, 2.3.1, 2.4.5, 2.5.1, 2.6.2 is vulnerable to a Server-Side Request Forgery vulnerability in the "Resource.get" method that could result in compromise of API keys or other critical resources.

Record
EUVD-2017-0111
Updated
2026-11-03
GitHub AdvisoriesGHSA-38rv-5jqc-m2cv 9.3

Recurly vulnerable to SSRF

The Recurly Client Python Library before 2.0.5, 2.1.16, 2.2.22, 2.3.1, 2.4.5, 2.5.1, 2.6.2 is vulnerable to a Server-Side Request Forgery vulnerability in the Resource.get method that could result in compromise of API keys or other critical resources.

Record
GHSA-38rv-5jqc-m2cv
CVSS 4.0
9.3 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-918
Updated
2026-11-02
OSV 9.8

The Recurly Client Python Library before 2.0.5, 2.1.16, 2.2.22, 2.3.1, 2.4.5, 2.5.1, 2.6.2 is vulnerable to a Server-Side Request Forgery vulnerability in the "Resource.get" method that could result in compromise of API keys or other critical resources.

Record
CVE-2017-0906
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-38rv-5jqc-m2cv 9.3

Recurly vulnerable to SSRF

The Recurly Client Python Library before 2.0.5, 2.1.16, 2.2.22, 2.3.1, 2.4.5, 2.5.1, 2.6.2 is vulnerable to a Server-Side Request Forgery vulnerability in the Resource.get method that could result in compromise of API keys or other critical resources.

Record
GHSA-38rv-5jqc-m2cv
CVSS 4.0
9.3 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-918
Updated
2026-11-02
OSVPYSEC-2017-68 No score

The Recurly Client Python Library before 2.0.5, 2.1.16, 2.2.22, 2.3.1, 2.4.5, 2.5.1, 2.6.2 is vulnerable to a Server-Side Request Forgery vulnerability in the "Resource.get" method that could result in compromise of API keys or other critical resources.

Record
PYSEC-2017-68
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
recurly
PyPI
2.6.0 up to 2.6.2
2.6.2
recurly
PyPI
2.5.0 to 2.5.0
2.5.1
recurly
PyPI
2.4.0 up to 2.4.5
2.4.5
recurly
PyPI
2.3.0 to 2.3.0
2.3.1
recurly
PyPI
2.2.0 up to 2.2.22
2.2.22
recurly
PyPI
2.1.0 up to 2.1.16
2.1.16
recurly
PyPI
before 2.0.5
2.0.5
recurly
PyPI
2.6.0 up to 2.6.2, plus listed versions
2.6.1
2.6.2
recurly
PyPI
2.5.0 up to 2.5.1
2.5.1
recurly
PyPI
2.4.0 up to 2.4.5, plus listed versions
2.4.12.4.22.4.32.4.4
2.4.5
Show 5 moreShow less
Affected packages
PackageAffectedFixed
recurly
PyPI
2.3.0 up to 2.3.1
2.3.1
recurly
PyPI
2.2.0 up to 2.2.22, plus listed versions
2.2.12.2.102.2.112.2.122.2.13
Show 15 moreShow less
2.2.142.2.152.2.162.2.172.2.182.2.192.2.22.2.202.2.212.2.32.2.42.2.62.2.72.2.82.2.9
2.2.22
recurly
PyPI
2.1.0 up to 2.1.16, plus listed versions
2.1.12.1.102.1.112.1.122.1.13
Show 10 moreShow less
2.1.142.1.152.1.22.1.32.1.42.1.52.1.62.1.72.1.82.1.9
2.1.16
recurly
PyPI
before 2.0.5, plus listed versions
2.0.02.0.22.0.32.0.4
2.0.5
recurly
PyPI
2.0 up to 2.0.5, 2.1 up to 2.1.16, 2.2 up to 2.2.22, 2.3 up to 2.3.1, 2.4 up to 2.4.5, 2.5 up to 2.5.1, 2.6 up to 2.6.2, plus listed versions
2.0.02.0.22.0.32.0.42.1.0
Show 45 moreShow less
2.1.12.1.102.1.112.1.122.1.132.1.142.1.152.1.22.1.32.1.42.1.52.1.62.1.72.1.82.1.92.2.02.2.12.2.102.2.112.2.122.2.132.2.142.2.152.2.162.2.172.2.182.2.192.2.22.2.202.2.212.2.32.2.42.2.62.2.72.2.82.2.92.3.02.4.02.4.12.4.22.4.32.4.42.5.02.6.02.6.1
2.0.52.1.162.2.222.3.12.4.52.5.12.6.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-0906 is a critical vulnerability (CVSS 9.8) in Recurly Client Python, published November 13, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.62%, the 85th percentile. Fixed in recurly 2.6.2.

References

MoveEnter Open