CVE-2017-0907
Critical severity vulnerability that affects recurly-api-client
The Recurly Client .NET Library before 1.0.1, 1.1.10, 1.2.8, 1.3.2, 1.4.14, 1.5.3, 1.6.2, 1.7.1, 1.8.1 is vulnerable to a Server-Side Request Forgery vulnerability due to incorrect use of "Uri.EscapeUriString" that could result in compromise of API keys or other critical resources.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
The Recurly Client .NET Library before 1.0.1, 1.1.10, 1.2.8, 1.3.2, 1.4.14, 1.5.3, 1.6.2, 1.7.1, 1.8.1 is vulnerable to a Server-Side Request Forgery vulnerability due to incorrect use of "Uri.EscapeUriString" that could result in compromise of API keys or other critical resources.
- Record
CVE-2017-0907- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-918
- Updated
- 2026-11-02
CVE List No score
The Recurly Client .NET Library before 1.0.1, 1.1.10, 1.2.8, 1.3.2, 1.4.14, 1.5.3, 1.6.2, 1.7.1, 1.8.1 is vulnerable to a Server-Side Request Forgery vulnerability due to incorrect use of "Uri.EscapeUriString" that could result in compromise of API keys or other critical resources.
- Record
CVE-2017-0907- Weakness
- CWE-918
- Updated
- 2026-11-02
EUVDEUVD-2018-0717 No score
The Recurly Client .NET Library before 1.0.1, 1.1.10, 1.2.8, 1.3.2, 1.4.14, 1.5.3, 1.6.2, 1.7.1, 1.8.1 is vulnerable to a Server-Side Request Forgery vulnerability due to incorrect use of "Uri.EscapeUriString" that could result in compromise of API keys or other critical resources.
- Record
EUVD-2018-0717- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-xpwp-rq3x-x6v7 No score
Critical severity vulnerability that affects recurly-api-client
The Recurly Client .NET Library before 1.0.1, 1.1.10, 1.2.8, 1.3.2, 1.4.14, 1.5.3, 1.6.2, 1.7.1, 1.8.1 is vulnerable to a Server-Side Request Forgery vulnerability due to incorrect use of "Uri.EscapeUriString" that could result in compromise of API keys or other critical resources.
- Record
GHSA-xpwp-rq3x-x6v7- Weakness
- CWE-918
- Updated
- 2026-11-02
OSV
9.8
The Recurly Client .NET Library before 1.0.1, 1.1.10, 1.2.8, 1.3.2, 1.4.14, 1.5.3, 1.6.2, 1.7.1, 1.8.1 is vulnerable to a Server-Side Request Forgery vulnerability due to incorrect use of "Uri.EscapeUriString" that could result in compromise of API keys or other critical resources.
- Record
CVE-2017-0907- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-xpwp-rq3x-x6v7 No score
Critical severity vulnerability that affects recurly-api-client
The Recurly Client .NET Library before 1.0.1, 1.1.10, 1.2.8, 1.3.2, 1.4.14, 1.5.3, 1.6.2, 1.7.1, 1.8.1 is vulnerable to a Server-Side Request Forgery vulnerability due to incorrect use of "Uri.EscapeUriString" that could result in compromise of API keys or other critical resources.
- Record
GHSA-xpwp-rq3x-x6v7- Weakness
- CWE-918
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
recurly-api-clientNuGet |
before 1.0.1 | 1.0.1 |
recurly-api-clientNuGet |
1.1.0 up to 1.1.10 | 1.1.10 |
recurly-api-clientNuGet |
1.2.0 up to 1.2.8 | 1.2.8 |
recurly-api-clientNuGet |
1.3.0 up to 1.3.2 | 1.3.2 |
recurly-api-clientNuGet |
1.4.0 up to 1.4.14 | 1.4.14 |
recurly-api-clientNuGet |
1.5.0 up to 1.5.3 | 1.5.3 |
recurly-api-clientNuGet |
1.6.0 up to 1.6.2 | 1.6.2 |
recurly-api-clientNuGet |
1.7.0 to 1.7.0 | 1.7.1 |
recurly-api-clientNuGet |
1.8.0 to 1.8.0 | 1.8.1 |
recurly-api-clientNuGet |
before 1.0.1, plus listed versions 1.0.0 |
1.0.1 |
Show 8 moreShow less
| Package | Affected | Fixed |
|---|---|---|
recurly-api-clientNuGet |
1.1.0 up to 1.1.10, plus listed versions 1.1.11.1.21.1.31.1.41.1.5 Show 4 moreShow less1.1.61.1.71.1.81.1.9 |
1.1.10 |
recurly-api-clientNuGet |
1.2.0 up to 1.2.8, plus listed versions 1.2.11.2.21.2.31.2.41.2.51.2.61.2.7 |
1.2.8 |
recurly-api-clientNuGet |
1.3.0 up to 1.3.2, plus listed versions 1.3.1 |
1.3.2 |
recurly-api-clientNuGet |
1.4.0 up to 1.4.14, plus listed versions 1.4.11.4.101.4.111.4.121.4.13 Show 8 moreShow less1.4.21.4.31.4.41.4.51.4.61.4.71.4.81.4.9 |
1.4.14 |
recurly-api-clientNuGet |
1.5.0 up to 1.5.3, plus listed versions 1.5.11.5.2 |
1.5.3 |
recurly-api-clientNuGet |
1.6.0 up to 1.6.2, plus listed versions 1.6.1 |
1.6.2 |
recurly-api-clientNuGet |
1.7.0 up to 1.7.1 | 1.7.1 |
recurly-api-clientNuGet |
1.8.0 up to 1.8.1 | 1.8.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-0907 is a critical vulnerability (CVSS 9.8) in Recurly Client .net, published November 13, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.59%, the 85th percentile. Fixed in recurly-api-client 1.0.1.