CVE-2017-1000001
FedMsg not properly completing message validation
FedMsg 0.18.1 and older is vulnerable to a message validation flaw resulting in message validation not being enabled if configured to be on.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.5
FedMsg 0.18.1 and older is vulnerable to a message validation flaw resulting in message validation not being enabled if configured to be on.
- Record
CVE-2017-1000001- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:P/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
FedMsg 0.18.1 and older is vulnerable to a message validation flaw resulting in message validation not being enabled if configured to be on.
- Record
CVE-2017-1000001- Updated
- 2026-11-02
EUVDEUVD-2017-0057 No score
FedMsg 0.18.1 and older is vulnerable to a message validation flaw resulting in message validation not being enabled if configured to be on.
- Record
EUVD-2017-0057- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-p7xc-35m8-57pr
8.7
FedMsg not properly completing message validation
FedMsg 0.18.1 and older is vulnerable to a message validation flaw resulting in message validation not being enabled if configured to be on.
- Record
GHSA-p7xc-35m8-57pr- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N - CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
7.5
FedMsg 0.18.1 and older is vulnerable to a message validation flaw resulting in message validation not being enabled if configured to be on.
- Record
CVE-2017-1000001- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVGHSA-p7xc-35m8-57pr
8.7
FedMsg not properly completing message validation
FedMsg 0.18.1 and older is vulnerable to a message validation flaw resulting in message validation not being enabled if configured to be on.
- Record
GHSA-p7xc-35m8-57pr- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N - CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-1000001
7.5
FedMsg 0.18.1 and older is vulnerable to a message validation flaw resulting in message validation not being enabled if configured to be on.
- Record
UBUNTU-CVE-2017-1000001- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVPYSEC-2017-13 No score
FedMsg 0.18.1 and older is vulnerable to a message validation flaw resulting in message validation not being enabled if configured to be on.
- Record
PYSEC-2017-13- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
fedmsgPyPI |
before 0.18.2 | 0.18.2 |
fedmsgPyPI |
before 0.18.2, plus listed versions 0.0.10.0.1a0.0.1a20.0.1a30.0.1a4 Show 45 moreShow less0.0.1a50.0.20.0.30.0.40.0.50.0.60.0.70.0.80.0.90.1.00.1.10.1.20.1.30.1.40.1.50.1.60.1.70.1.80.10.00.11.00.11.10.12.00.12.10.12.20.12.30.13.00.13.10.13.20.13.30.14.00.14.10.15.00.16.00.16.10.16.20.16.30.16.40.17.00.17.10.17.20.18.00.18.10.2.00.2.10.2.2 |
0.18.2 |
fedmsgUbuntu:16.04:LTS |
All versions, plus listed versions 0.9.3-10.9.3-2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-1000001 is a high vulnerability (CVSS 7.5) in Fedoraproject Fedmsg, published July 13, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.50%, the 74th percentile. Fixed in fedmsg 0.18.2.
References
github.com/fedora-infra/fedmsg/blob/0.18.2/CHANGELOG.rst
nvd.nist.gov/vuln/detail/CVE-2017-1000001
github.com/advisories/GHSA-p7xc-35m8-57pr
github.com/pypa/advisory-database/tree/main/vulns/fedmsg/PYSEC-2017-13.yaml
github.com/fedora-infra/fedmsg
ubuntu.com/security/CVE-2017-1000001
github.com/fedora-infra/fedmsg/commit/5c21cf88a
cve.org/CVERecord?id=CVE-2017-1000001
Left out here: 48 versions. The JSON record has them.