CVE-2017-1000006
Cross Site Scripting (XSS) in plotly.js
Plotly, Inc. plotly.js versions prior to 1.16.0 are vulnerable to an XSS issue.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Plotly, Inc. plotly.js versions prior to 1.16.0 are vulnerable to an XSS issue.
- Record
CVE-2017-1000006- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Plotly, Inc. plotly.js versions prior to 1.16.0 are vulnerable to an XSS issue.
- Record
CVE-2017-1000006- Updated
- 2026-11-02
EUVDEUVD-2017-0150 No score
Plotly, Inc. plotly.js versions prior to 1.16.0 are vulnerable to an XSS issue.
- Record
EUVD-2017-0150- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-2fqv-h3r5-m4vf
6.1
Cross Site Scripting (XSS) in plotly.js
Affected versions of plotly.js are vulnerable to cross-site scripting if an attacker can convince a user to visit a malicious plot on a site using this package.
Recommendation
Update to 1.16.0 or later.
- Record
GHSA-2fqv-h3r5-m4vf- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
Plotly, Inc. plotly.js versions prior to 1.16.0 are vulnerable to an XSS issue.
- Record
CVE-2017-1000006- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-2fqv-h3r5-m4vf
6.1
Cross Site Scripting (XSS) in plotly.js
Affected versions of plotly.js are vulnerable to cross-site scripting if an attacker can convince a user to visit a malicious plot on a site using this package.
Recommendation
Update to 1.16.0 or later.
- Record
GHSA-2fqv-h3r5-m4vf- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
plotly.jsnpm |
before 1.16.0 | 1.16.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-1000006 is a medium vulnerability (CVSS 6.1) in Plotly Plotly.js, published July 13, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.88%, the 59th percentile. Fixed in plotly.js 1.16.0.