Every CVE Search/ Get API key

CVE-2017-1000017

phpMyAdmin SSRF in replication

8.8 HighFix available

phpMyAdmin 4.0, 4.4 and 4.6 are vulnerable to a weakness where a user with appropriate permissions is able to connect to an arbitrary MySQL server

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.35%Down 1.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

phpMyAdmin 4.0, 4.4 and 4.6 are vulnerable to a weakness where a user with appropriate permissions is able to connect to an arbitrary MySQL server

Record
CVE-2017-1000017
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:P
Weakness
CWE-918
Updated
2026-11-02
CVE List No score

phpMyAdmin 4.0, 4.4 and 4.6 are vulnerable to a weakness where a user with appropriate permissions is able to connect to an arbitrary MySQL server

Record
CVE-2017-1000017
Updated
2026-11-02
EUVDEUVD-2022-3344 No score

phpMyAdmin 4.0, 4.4 and 4.6 are vulnerable to a weakness where a user with appropriate permissions is able to connect to an arbitrary MySQL server

Record
EUVD-2022-3344
Updated
2026-11-03
GitHub AdvisoriesGHSA-99xj-xqc9-98hr 8.8

phpMyAdmin SSRF in replication

phpMyAdmin 4.0, 4.4 and 4.6 are vulnerable to a weakness where a user with appropriate permissions is able to connect to an arbitrary MySQL server

Record
GHSA-99xj-xqc9-98hr
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-918
Updated
2026-11-02
OSV 8.8

phpMyAdmin 4.0, 4.4 and 4.6 are vulnerable to a weakness where a user with appropriate permissions is able to connect to an arbitrary MySQL server

Record
CVE-2017-1000017
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-1000017 8.8

phpMyAdmin 4.0, 4.4 and 4.6 are vulnerable to a weakness where a user with appropriate permissions is able to connect to an arbitrary MySQL server

Record
DEBIAN-CVE-2017-1000017
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-99xj-xqc9-98hr 8.8

phpMyAdmin SSRF in replication

phpMyAdmin 4.0, 4.4 and 4.6 are vulnerable to a weakness where a user with appropriate permissions is able to connect to an arbitrary MySQL server

Record
GHSA-99xj-xqc9-98hr
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-918
Updated
2026-11-02
OSVUBUNTU-CVE-2017-1000017 8.8

phpMyAdmin 4.0, 4.4 and 4.6 are vulnerable to a weakness where a user with appropriate permissions is able to connect to an arbitrary MySQL server

Record
UBUNTU-CVE-2017-1000017
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:11171-1 No score

phpMyAdmin-5.1.1-1.2 on GA media

These are all security issues fixed in the phpMyAdmin-5.1.1-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11171-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
phpmyadmin/phpmyadmin
Packagist
4.6 up to 4.6.6
4.6.6
phpmyadmin/phpmyadmin
Packagist
4.4 up to 4.4.15.10
4.4.15.10
phpmyadmin/phpmyadmin
Packagist
4.0 up to 4.0.10.19
4.0.10.19
phpmyadmin
Debian:12
before 4:4.6.6-1
4:4.6.6-1
phpmyadmin
Debian:13
before 4:4.6.6-1
4:4.6.6-1
phpmyadmin
Debian:14
before 4:4.6.6-1
4:4.6.6-1
phpmyadmin/phpmyadmin
Packagist
4.0 up to 4.0.10.19, plus listed versions
4.0.04.0.14.0.104.0.10.14.0.10.2
Show 17 moreShow less
4.0.10.34.0.10.44.0.10.54.0.10.64.0.10.74.0.10.84.0.10.94.0.24.0.34.0.44.0.4.14.0.4.24.0.54.0.64.0.74.0.84.0.9
4.0.10.19
phpmyadmin
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
4:4.0.6-14:4.0.8-14:4.0.9-14:4.0.10-14:4.0.10-1ubuntu0.1
Show 4 moreShow less
4:4.0.10-1ubuntu0.1+esm14:4.0.10-1ubuntu0.1+esm24:4.0.10-1ubuntu0.1+esm34:4.0.10-1ubuntu0.1+esm4
None known
phpmyadmin
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
4:4.4.13.1-14:4.5.0.2-24:4.5.1-14:4.5.1-24:4.5.1-3
Show 13 moreShow less
4:4.5.2-14:4.5.2-24:4.5.3.1-14:4.5.4-14:4.5.4.1-24:4.5.4.1-2ubuntu14:4.5.4.1-2ubuntu24:4.5.4.1-2ubuntu2.14:4.5.4.1-2ubuntu2.1+esm24:4.5.4.1-2ubuntu2.1+esm34:4.5.4.1-2ubuntu2.1+esm44:4.5.4.1-2ubuntu2.1+esm54:4.5.4.1-2ubuntu2.1+esm6
None known
phpMyAdmin
openSUSE:Tumbleweed
From an advisory covering 31 CVEs
before 5.1.1-1.2
5.1.1-1.2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-1000017 is a high vulnerability (CVSS 8.8) in Phpmyadmin, published July 13, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.35%, the 71st percentile. Fixed in phpmyadmin/phpmyadmin 4.6.6.

References

Show 33 moreShow less
MoveEnter Open