CVE-2017-1000025
GNOME Web (Epiphany) 3.23 before 3.23.5, 3.22 before 3.22.6, 3.20 before 3.20.7, 3.18 before 3.18...
GNOME Web (Epiphany) 3.23 before 3.23.5, 3.22 before 3.22.6, 3.20 before 3.20.7, 3.18 before 3.18.11, and prior versions, is vulnerable to a password manager sweep attack resulting in the remote exfiltration of stored passwords for a selected set of websites.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.5
GNOME Web (Epiphany) 3.23 before 3.23.5, 3.22 before 3.22.6, 3.20 before 3.20.7, 3.18 before 3.18.11, and prior versions, is vulnerable to a password manager sweep attack resulting in the remote exfiltration of stored passwords for a selected set of websites.
- Record
CVE-2017-1000025- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
CVE List No score
GNOME Web (Epiphany) 3.23 before 3.23.5, 3.22 before 3.22.6, 3.20 before 3.20.7, 3.18 before 3.18.11, and prior versions, is vulnerable to a password manager sweep attack resulting in the remote exfiltration of stored passwords for a selected set of websites.
- Record
CVE-2017-1000025- Updated
- 2026-11-02
EUVDEUVD-2017-1354 No score
GNOME Web (Epiphany) 3.23 before 3.23.5, 3.22 before 3.22.6, 3.20 before 3.20.7, 3.18 before 3.18.11, and prior versions, is vulnerable to a password manager sweep attack resulting in the remote exfiltration of stored passwords for a selected set of websites.
- Record
EUVD-2017-1354- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3gg9-xvf5-p5wm
7.5
GNOME Web (Epiphany) 3.23 before 3.23.5, 3.22 before 3.22.6, 3.20 before 3.20.7, 3.18 before 3.18...
GNOME Web (Epiphany) 3.23 before 3.23.5, 3.22 before 3.22.6, 3.20 before 3.20.7, 3.18 before 3.18.11, and prior versions, is vulnerable to a password manager sweep attack resulting in the remote exfiltration of stored passwords for a selected set of websites.
- Record
GHSA-3gg9-xvf5-p5wm- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
OSV
7.5
GNOME Web (Epiphany) 3.23 before 3.23.5, 3.22 before 3.22.6, 3.20 before 3.20.7, 3.18 before 3.18.11, and prior versions, is vulnerable to a password manager sweep attack resulting in the remote exfiltration of stored passwords for a selected set of websites.
- Record
CVE-2017-1000025- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-1000025
7.5
GNOME Web (Epiphany) 3.23 before 3.23.5, 3.22 before 3.22.6, 3.20 before 3.20.7, 3.18 before 3.18.11, and prior versions, is vulnerable to a password manager sweep attack resulting in the remote exfiltration of stored passwords for a selected set of websites.
- Record
DEBIAN-CVE-2017-1000025- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-1000025
7.5
GNOME Web (Epiphany) 3.23 before 3.23.5, 3.22 before 3.22.6, 3.20 before 3.20.7, 3.18 before 3.18.11, and prior versions, is vulnerable to a password manager sweep attack resulting in the remote exfiltration of stored passwords for a selected set of websites.
- Record
UBUNTU-CVE-2017-1000025- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
epiphany-browserDebian:12 |
before 3.22.6-1 | 3.22.6-1 |
epiphany-browserDebian:13 |
before 3.22.6-1 | 3.22.6-1 |
epiphany-browserDebian:14 |
before 3.22.6-1 | 3.22.6-1 |
epiphanyUbuntu:16.04:LTS |
All versions, plus listed versions 0.7.0+0-3build1 |
None known |
epiphany-browserUbuntu:16.04:LTS |
All versions, plus listed versions 3.16.3-1ubuntu13.18.0-1ubuntu23.18.1-1ubuntu13.18.3-0ubuntu13.18.5-0ubuntu13.18.5-0ubuntu1.13.18.10-0ubuntu13.18.11-0ubuntu1 |
None known |
epiphanyUbuntu:18.04:LTS |
All versions, plus listed versions 0.7.0+0-3build1 |
None known |
epiphanyUbuntu:20.04:LTS |
All versions, plus listed versions 0.7.0+0-50.7.0+0-60.7.0+0-6build1 |
None known |
epiphanyUbuntu:22.04:LTS |
All versions, plus listed versions 0.7.0+0-6build10.7.0+0-7 |
None known |
epiphanyUbuntu:24.04:LTS |
All versions, plus listed versions 0.7.0+0-7 |
None known |
epiphanyUbuntu:25.10 |
All versions, plus listed versions 0.7.0+0-7 |
None known |
epiphanyUbuntu:26.10 |
All versions, plus listed versions 0.7.0+0-8 |
None known |
epiphanyUbuntu:26.04:LTS |
All versions, plus listed versions 0.7.0+0-70.7.0+0-8 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-1000025 is a high vulnerability (CVSS 7.5) in Gnome Epiphany, published July 13, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.39%, the 72nd percentile. Fixed in epiphany-browser 3.22.6-1.
References
bugzilla.gnome.org/show_bug.cgi?id=752738
usenix.org/conference/usenixsecurity14/technical-sessions/presentation/silver
nvd.nist.gov/vuln/detail/CVE-2017-1000025
github.com/advisories/GHSA-3gg9-xvf5-p5wm
security-tracker.debian.org/tracker/CVE-2017-1000025
ubuntu.com/security/CVE-2017-1000025
openwall.com/lists/oss-security/2017/05/22
cve.org/CVERecord?id=CVE-2017-1000025