Every CVE Search/ Get API key

CVE-2017-1000056

Kubernetes Privilege Escalation

9.8 CriticalFix available

Kubernetes version 1.5.0-1.5.4 is vulnerable to a privilege escalation in the PodSecurityPolicy admission plugin resulting in the ability to make use of any existing PodSecurityPolicy object.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.84%Up 1.0 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

Kubernetes version 1.5.0-1.5.4 is vulnerable to a privilege escalation in the PodSecurityPolicy admission plugin resulting in the ability to make use of any existing PodSecurityPolicy object.

Record
CVE-2017-1000056
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-862
Updated
2026-11-02
CVE List No score

Kubernetes version 1.5.0-1.5.4 is vulnerable to a privilege escalation in the PodSecurityPolicy admission plugin resulting in the ability to make use of any existing PodSecurityPolicy object.

Record
CVE-2017-1000056
Updated
2026-11-02
EUVDEUVD-2021-0902 No score

Kubernetes version 1.5.0-1.5.4 is vulnerable to a privilege escalation in the PodSecurityPolicy admission plugin resulting in the ability to make use of any existing PodSecurityPolicy object.

Record
EUVD-2021-0902
Updated
2026-11-03
GitHub AdvisoriesGHSA-2jx2-76rc-2v7v 9.8

Kubernetes Privilege Escalation

Kubernetes version 1.5.0-1.5.4 is vulnerable to a privilege escalation in the PodSecurityPolicy admission plugin resulting in the ability to make use of any existing PodSecurityPolicy object.

Record
GHSA-2jx2-76rc-2v7v
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-862
Updated
2026-11-02
OSV 9.8

Kubernetes version 1.5.0-1.5.4 is vulnerable to a privilege escalation in the PodSecurityPolicy admission plugin resulting in the ability to make use of any existing PodSecurityPolicy object.

Record
CVE-2017-1000056
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-1000056 9.8

Kubernetes version 1.5.0-1.5.4 is vulnerable to a privilege escalation in the PodSecurityPolicy admission plugin resulting in the ability to make use of any existing PodSecurityPolicy object.

Record
DEBIAN-CVE-2017-1000056
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-2jx2-76rc-2v7v 9.8

Kubernetes Privilege Escalation

Kubernetes version 1.5.0-1.5.4 is vulnerable to a privilege escalation in the PodSecurityPolicy admission plugin resulting in the ability to make use of any existing PodSecurityPolicy object.

Record
GHSA-2jx2-76rc-2v7v
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-862
Updated
2026-11-02
OSVGO-2023-1492 No score

Kubernetes Privilege Escalation in k8s.io/kubernetes

Kubernetes Privilege Escalation in k8s.io/kubernetes

Record
GO-2023-1492
Updated
2026-11-02
OSVopenSUSE-SU-2025:15424-1 No score

govulncheck-vulndb-0.0.20250807T150727-1.1 on GA media

These are all security issues fixed in the govulncheck-vulndb-0.0.20250807T150727-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:15424-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
k8s.io/kubernetes
Go
1.5.0 up to 1.5.5
1.5.5
kubernetes
Debian:12
before 1.5.5+dfsg-1
1.5.5+dfsg-1
kubernetes
Debian:13
before 1.5.5+dfsg-1
1.5.5+dfsg-1
kubernetes
Debian:14
before 1.5.5+dfsg-1
1.5.5+dfsg-1
govulncheck-vulndb
openSUSE:Tumbleweed
From an advisory covering 44 CVEs
before 0.0.20250807T150727-1.1
0.0.20250807T150727-1.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-1000056 is a critical vulnerability (CVSS 9.8) in Kubernetes, published July 13, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.84%, the 86th percentile. Fixed in k8s.io/kubernetes 1.5.5.

References

Show 44 moreShow less
MoveEnter Open