CVE-2017-1000071
Jasig phpCAS version 1.3.4 is vulnerable to an authentication bypass in the validateCAS20...
Jasig phpCAS version 1.3.4 is vulnerable to an authentication bypass in the validateCAS20 function when configured to authenticate against an old CAS server.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.1
Jasig phpCAS version 1.3.4 is vulnerable to an authentication bypass in the validateCAS20 function when configured to authenticate against an old CAS server.
- Record
CVE-2017-1000071- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-287
- Updated
- 2026-11-02
CVE List No score
Jasig phpCAS version 1.3.4 is vulnerable to an authentication bypass in the validateCAS20 function when configured to authenticate against an old CAS server.
- Record
CVE-2017-1000071- Updated
- 2026-11-02
EUVDEUVD-2017-1388 No score
Jasig phpCAS version 1.3.4 is vulnerable to an authentication bypass in the validateCAS20 function when configured to authenticate against an old CAS server.
- Record
EUVD-2017-1388- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-fwrj-8jg7-7jr6
8.1
Jasig phpCAS version 1.3.4 is vulnerable to an authentication bypass in the validateCAS20...
Jasig phpCAS version 1.3.4 is vulnerable to an authentication bypass in the validateCAS20 function when configured to authenticate against an old CAS server.
- Record
GHSA-fwrj-8jg7-7jr6- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-287
- Updated
- 2026-11-02
OSV
8.1
Jasig phpCAS version 1.3.4 is vulnerable to an authentication bypass in the validateCAS20 function when configured to authenticate against an old CAS server.
- Record
CVE-2017-1000071- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-1000071
8.1
Jasig phpCAS version 1.3.4 is vulnerable to an authentication bypass in the validateCAS20 function when configured to authenticate against an old CAS server.
- Record
DEBIAN-CVE-2017-1000071- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-1000071
8.1
Jasig phpCAS version 1.3.4 is vulnerable to an authentication bypass in the validateCAS20 function when configured to authenticate against an old CAS server.
- Record
UBUNTU-CVE-2017-1000071- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
php-casDebian:12 |
before 1.3.6-1 | 1.3.6-1 |
php-casDebian:13 |
before 1.3.6-1 | 1.3.6-1 |
php-casDebian:14 |
before 1.3.6-1 | 1.3.6-1 |
php-casUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 1.3.3-11.3.3-21.3.3-2ubuntu11.3.3-2ubuntu1+esm1 |
None known |
php-casUbuntu:18.04:LTS |
All versions, plus listed versions 1.3.3-4 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-1000071 is a high vulnerability (CVSS 8.1) in Apereo Phpcas, published July 13, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.54%, the 89th percentile. Fixed in php-cas 1.3.6-1.
References
github.com/Jasig/phpCAS/blob/master/docs/ChangeLog
securityfocus.com/bid/99609
github.com/Jasig/phpCAS/issues/228
nvd.nist.gov/vuln/detail/CVE-2017-1000071
github.com/advisories/GHSA-fwrj-8jg7-7jr6
security-tracker.debian.org/tracker/CVE-2017-1000071
ubuntu.com/security/CVE-2017-1000071
cve.org/CVERecord?id=CVE-2017-1000071