CVE-2017-1000118
Improper Restriction of Operations within the Bounds of a Memory Buffer in akka-http-core
Akka HTTP versions <= 10.0.5 Illegal Media Range in Accept Header Causes StackOverflowError Leading to Denial of Service
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
Akka HTTP versions <= 10.0.5 Illegal Media Range in Accept Header Causes StackOverflowError Leading to Denial of Service
- Record
CVE-2017-1000118- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
Akka HTTP versions <= 10.0.5 Illegal Media Range in Accept Header Causes StackOverflowError Leading to Denial of Service
- Record
CVE-2017-1000118- Updated
- 2026-11-02
EUVDEUVD-2018-0601 No score
Akka HTTP versions <= 10.0.5 Illegal Media Range in Accept Header Causes StackOverflowError Leading to Denial of Service
- Record
EUVD-2018-0601- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-gfx6-ph4q-q54q
7.5
Improper Restriction of Operations within the Bounds of a Memory Buffer in akka-http-core
Akka HTTP versions <= 10.0.5 Illegal Media Range in Accept Header Causes StackOverflowError Leading to Denial of Service
- Record
GHSA-gfx6-ph4q-q54q- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSV
7.5
Akka HTTP versions <= 10.0.5 Illegal Media Range in Accept Header Causes StackOverflowError Leading to Denial of Service
- Record
CVE-2017-1000118- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVGHSA-gfx6-ph4q-q54q
7.5
Improper Restriction of Operations within the Bounds of a Memory Buffer in akka-http-core
Akka HTTP versions <= 10.0.5 Illegal Media Range in Accept Header Causes StackOverflowError Leading to Denial of Service
- Record
GHSA-gfx6-ph4q-q54q- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
com.typesafe.akka:akka-http-core_2.12Maven |
before 10.0.6 | 10.0.6 |
com.typesafe.akka:akka-http-core_2.11Maven |
before 10.0.6 | 10.0.6 |
com.typesafe.akka:akka-http-core_2.12Maven |
before 10.0.6, plus listed versions 10.0.010.0.0-RC210.0.110.0.210.0.310.0.410.0.5 |
10.0.6 |
com.typesafe.akka:akka-http-core_2.11Maven |
before 10.0.6, plus listed versions 10.0.010.0.0-RC210.0.110.0.210.0.3 Show 24 moreShow less10.0.410.0.52.4-ARTERY-M12.4-ARTERY-M22.4-ARTERY-M32.4-ARTERY-M42.4.102.4.112.4.11.12.4.11.22.4.22.4.2-RC12.4.2-RC22.4.2-RC32.4.32.4.42.4.52.4.62.4.72.4.82.4.92.4.9-RC12.4.9-RC23.0.0-RC1 |
10.0.6 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-1000118 is a high vulnerability (CVSS 7.5) in Akka Http Server, published October 4, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.10%, the 65th percentile. Fixed in com.typesafe.akka:akka-http-core_2.12 10.0.6.