CVE-2017-1000188
mde ejs vulnerable to XSS
nodejs ejs version older than 2.5.5 is vulnerable to a Cross-site-scripting in the ejs.renderFile() resulting in code injection
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
nodejs ejs version older than 2.5.5 is vulnerable to a Cross-site-scripting in the ejs.renderFile() resulting in code injection
- Record
CVE-2017-1000188- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
nodejs ejs version older than 2.5.5 is vulnerable to a Cross-site-scripting in the ejs.renderFile() resulting in code injection
- Record
CVE-2017-1000188- Updated
- 2026-11-02
EUVDEUVD-2017-0347 No score
nodejs ejs version older than 2.5.5 is vulnerable to a Cross-site-scripting in the ejs.renderFile() resulting in code injection
- Record
EUVD-2017-0347- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-hwcf-pp87-7x6p
6.1
mde ejs vulnerable to XSS
nodejs ejs version older than 2.5.5 is vulnerable to a Cross-site-scripting in the ejs.renderFile() resulting in code injection
- Record
GHSA-hwcf-pp87-7x6p- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
nodejs ejs version older than 2.5.5 is vulnerable to a Cross-site-scripting in the ejs.renderFile() resulting in code injection
- Record
CVE-2017-1000188- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-1000188
6.1
nodejs ejs version older than 2.5.5 is vulnerable to a Cross-site-scripting in the ejs.renderFile() resulting in code injection
- Record
DEBIAN-CVE-2017-1000188- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-hwcf-pp87-7x6p
6.1
mde ejs vulnerable to XSS
nodejs ejs version older than 2.5.5 is vulnerable to a Cross-site-scripting in the ejs.renderFile() resulting in code injection
- Record
GHSA-hwcf-pp87-7x6p- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-1000188
6.1
nodejs ejs version older than 2.5.5 is vulnerable to a Cross-site-scripting in the ejs.renderFile() resulting in code injection
- Record
UBUNTU-CVE-2017-1000188- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVCLSA-2026-1774570929 No score
TuxCare security update for ejs (5 CVEs)
TuxCare rebuilt ejs to address 5 CVEs. Fixed in 1.0.0-tuxcare.1.
- Record
CLSA-2026-1774570929- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ejsnpm |
before 2.5.5 | 2.5.5 |
ejsTuxCare:npm From an advisory covering 5 CVEs |
1.0.0-tuxcare.0 up to 1.0.0-tuxcare.1, plus listed versions 1.0.0 |
1.0.0-tuxcare.1 |
node-ejsDebian:12 |
before 2.5.7-1 | 2.5.7-1 |
node-ejsDebian:13 |
before 2.5.7-1 | 2.5.7-1 |
node-ejsDebian:14 |
before 2.5.7-1 | 2.5.7-1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-1000188 is a medium vulnerability (CVSS 6.1) in Ejs, published November 17, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.23%, the 69th percentile. Fixed in ejs 2.5.5.
References
github.com/mde/ejs/commit/49264e0037e313a0a3e033450b5c184112516d8f
securityfocus.com/bid/101889
nvd.nist.gov/vuln/detail/CVE-2017-1000188
github.com/advisories/GHSA-hwcf-pp87-7x6p
web.archive.org/web/20200227134555/http://www.securityfocus.com/bid/101889
security-tracker.debian.org/tracker/CVE-2017-1000188
github.com/mde/ejs
ubuntu.com/security/CVE-2017-1000188
cve.org/CVERecord?id=CVE-2017-1000188