CVE-2017-1000189
ejs vulnerable to DoS due to weak input validation
nodejs ejs version older than 2.5.5 is vulnerable to a denial-of-service due to weak input validation in the ejs.renderFile()
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
nodejs ejs version older than 2.5.5 is vulnerable to a denial-of-service due to weak input validation in the ejs.renderFile()
- Record
CVE-2017-1000189- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
nodejs ejs version older than 2.5.5 is vulnerable to a denial-of-service due to weak input validation in the ejs.renderFile()
- Record
CVE-2017-1000189- Updated
- 2026-11-02
EUVDEUVD-2018-0173 No score
nodejs ejs version older than 2.5.5 is vulnerable to a denial-of-service due to weak input validation in the ejs.renderFile()
- Record
EUVD-2018-0173- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6x77-rpqf-j6mw
7.5
ejs vulnerable to DoS due to weak input validation
nodejs ejs version older than 2.5.5 is vulnerable to a denial-of-service due to weak input validation in ejs.renderFile()
- Record
GHSA-6x77-rpqf-j6mw- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
7.5
nodejs ejs version older than 2.5.5 is vulnerable to a denial-of-service due to weak input validation in the ejs.renderFile()
- Record
CVE-2017-1000189- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-1000189
7.5
nodejs ejs version older than 2.5.5 is vulnerable to a denial-of-service due to weak input validation in the ejs.renderFile()
- Record
DEBIAN-CVE-2017-1000189- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVGHSA-6x77-rpqf-j6mw
7.5
ejs vulnerable to DoS due to weak input validation
nodejs ejs version older than 2.5.5 is vulnerable to a denial-of-service due to weak input validation in ejs.renderFile()
- Record
GHSA-6x77-rpqf-j6mw- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-1000189
7.5
nodejs ejs version older than 2.5.5 is vulnerable to a denial-of-service due to weak input validation in the ejs.renderFile()
- Record
UBUNTU-CVE-2017-1000189- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVCLSA-2026-1774570929 No score
TuxCare security update for ejs (5 CVEs)
TuxCare rebuilt ejs to address 5 CVEs. Fixed in 1.0.0-tuxcare.1.
- Record
CLSA-2026-1774570929- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ejsnpm |
before 2.5.5 | 2.5.5 |
ejsTuxCare:npm From an advisory covering 5 CVEs |
1.0.0-tuxcare.0 up to 1.0.0-tuxcare.1, plus listed versions 1.0.0 |
1.0.0-tuxcare.1 |
node-ejsDebian:12 |
before 2.5.7-1 | 2.5.7-1 |
node-ejsDebian:13 |
before 2.5.7-1 | 2.5.7-1 |
node-ejsDebian:14 |
before 2.5.7-1 | 2.5.7-1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-1000189 is a high vulnerability (CVSS 7.5) in Ejs, published November 17, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.27%, the 83rd percentile. Fixed in ejs 2.5.5.
References
securityfocus.com/bid/101893
github.com/mde/ejs/commit/49264e0037e313a0a3e033450b5c184112516d8f
nvd.nist.gov/vuln/detail/CVE-2017-1000189
github.com/advisories/GHSA-6x77-rpqf-j6mw
web.archive.org/web/20171123041449/http://www.securityfocus.com/bid/101893
security-tracker.debian.org/tracker/CVE-2017-1000189
github.com/mde/ejs
ubuntu.com/security/CVE-2017-1000189
cve.org/CVERecord?id=CVE-2017-1000189