CVE-2017-1000206
samtools htslib library version 1.4.0 and earlier is vulnerable to buffer overflow in the CRAM...
CVE-2017-1000206 is a critical vulnerability (CVSS 9.8) in Htslib, published November 17, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.23%, the 82nd percentile. Fixed in htslib 1.4.1-1.
samtools htslib library version 1.4.0 and earlier is vulnerable to buffer overflow in the CRAM rANS codec resulting in potential arbitrary code execution
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
samtools htslib library version 1.4.0 and earlier is vulnerable to buffer overflow in the CRAM rANS codec resulting in potential arbitrary code execution
- Record
CVE-2017-1000206- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
samtools htslib library version 1.4.0 and earlier is vulnerable to buffer overflow in the CRAM rANS codec resulting in potential arbitrary code execution
- Record
CVE-2017-1000206- Updated
- 2026-11-02
EUVDEUVD-2017-1483 No score
samtools htslib library version 1.4.0 and earlier is vulnerable to buffer overflow in the CRAM rANS codec resulting in potential arbitrary code execution
- Record
EUVD-2017-1483- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-mfgv-xhqh-pmvp
9.8
samtools htslib library version 1.4.0 and earlier is vulnerable to buffer overflow in the CRAM...
samtools htslib library version 1.4.0 and earlier is vulnerable to buffer overflow in the CRAM rANS codec resulting in potential arbitrary code execution
- Record
GHSA-mfgv-xhqh-pmvp- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSV
9.8
samtools htslib library version 1.4.0 and earlier is vulnerable to buffer overflow in the CRAM rANS codec resulting in potential arbitrary code execution
- Record
CVE-2017-1000206- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-1000206
9.8
samtools htslib library version 1.4.0 and earlier is vulnerable to buffer overflow in the CRAM rANS codec resulting in potential arbitrary code execution
- Record
DEBIAN-CVE-2017-1000206- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-1000206
9.8
samtools htslib library version 1.4.0 and earlier is vulnerable to buffer overflow in the CRAM rANS codec resulting in potential arbitrary code execution
- Record
UBUNTU-CVE-2017-1000206- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-4802-1 No score
htslib vulnerabilities
It was discovered that HTSlib incorrectly handled certain data. An attacker could possibly use this issue to execute arbitrary code. This issue affected only Ubuntu 16.04 ESM. (CVE-2017-1000206)
It was discovered that HTSlib incorrectly handled certain files. An attacker could possibly use this issue to cause a denial of service. (CVE-2018-13845)
- Record
USN-4802-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
htslibDebian:12 |
before 1.4.1-1 | 1.4.1-1 |
htslibDebian:13 |
before 1.4.1-1 | 1.4.1-1 |
htslibDebian:14 |
before 1.4.1-1 | 1.4.1-1 |
htslibUbuntu:Pro:16.04:LTS |
before 1.2.1-2ubuntu1+esm1, plus listed versions 1.2.1-11.2.1-21.2.1-2ubuntu1 |
1.2.1-2ubuntu1+esm1 |
htslibUbuntu:Pro:14.04:LTS |
before 0.2.0~rc3-1ubuntu0.1~esm1, plus listed versions 0.2.0~rc3-1 |
0.2.0~rc3-1ubuntu0.1~esm1 |
htslibUbuntu:Pro:18.04:LTS |
before 1.7-2ubuntu0.1~esm1, plus listed versions 1.5-11.5-4ubuntu11.6-3ubuntu11.6-41.6-4build11.7-2 |
1.7-2ubuntu0.1~esm1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
github.com/samtools/htslib/blob/1.4.1/NEWS
nvd.nist.gov/vuln/detail/CVE-2017-1000206
github.com/advisories/GHSA-mfgv-xhqh-pmvp
security-tracker.debian.org/tracker/CVE-2017-1000206
ubuntu.com/security/CVE-2017-1000206
github.com/samtools/htslib/pull/514
cve.org/CVERecord?id=CVE-2017-1000206
ubuntu.com/security/notices/USN-4802-1
ubuntu.com/security/CVE-2018-13845