CVE-2017-1000220
PIDUsage Enables OS Command Injection
soyuka/pidusage <=1.1.4 is vulnerable to command injection in the module resulting in arbitrary command execution
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
soyuka/pidusage <=1.1.4 is vulnerable to command injection in the module resulting in arbitrary command execution
- Record
CVE-2017-1000220- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-78
- Updated
- 2026-11-02
CVE List No score
soyuka/pidusage <=1.1.4 is vulnerable to command injection in the module resulting in arbitrary command execution
- Record
CVE-2017-1000220- Updated
- 2026-11-02
EUVDEUVD-2022-4045 No score
soyuka/pidusage <=1.1.4 is vulnerable to command injection in the module resulting in arbitrary command execution
- Record
EUVD-2022-4045- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-h2p3-h48h-9jj7
9.8
PIDUsage Enables OS Command Injection
Overview
Affected versions of pidusage pass unsanitized input to child_process.exec(), resulting in arbitrary code execution in the ps method.
This package is vulnerable to this PoC on Darwin, SunOS, FreeBSD, and AIX.
Windows and Linux are not vulnerable.
Proof of Concept
var pid = require('pidusage');
pid.stat('1 && /usr/local/bin/python');
Remediation
Update to version 1.1.5 or later.
- Record
GHSA-h2p3-h48h-9jj7- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
OSV
9.8
soyuka/pidusage <=1.1.4 is vulnerable to command injection in the module resulting in arbitrary command execution
- Record
CVE-2017-1000220- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-h2p3-h48h-9jj7
9.8
PIDUsage Enables OS Command Injection
Overview
Affected versions of pidusage pass unsanitized input to child_process.exec(), resulting in arbitrary code execution in the ps method.
This package is vulnerable to this PoC on Darwin, SunOS, FreeBSD, and AIX.
Windows and Linux are not vulnerable.
Proof of Concept
var pid = require('pidusage');
pid.stat('1 && /usr/local/bin/python');
Remediation
Update to version 1.1.5 or later.
- Record
GHSA-h2p3-h48h-9jj7- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
Affected products
Affected packages
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-1000220 is a critical vulnerability (CVSS 9.8) in Pidusage Project Pidusage, published November 17, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.06%, the 92nd percentile. Fixed in pidusage 1.1.5.